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GETTING	STARTED

INSTALLATION
Windows
Install
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Uninstall
Troubleshooting

Mac	OS	X
Install
Uninstall

Linux
Fedora

External	links

CREATE	NEW	SCORE
Start	center
Create	new	score
Title,	composer	and	other	information
Select	template
Choose	instruments/voice	parts	(optional)
Add	staff	to	an	instrument

Select	key	signature	and	tempo
Time	signature,	pickup	measure	(anacrusis),	and	number	of	measures
Adjustments	to	score	after	creation
Templates
System	template	folder
User	template	folder

See	also
External	links

LANGUAGE	SETTINGS	AND	TRANSLATION	UPDATES
Change	language
Update	translation
See	also

CHECKING	FOR	UPDATES
Automated	update	check
Check	for	update
See	also

BASICS

NOTE	INPUT
Basic	note	entry
Step	1:	Starting	position
Step	2:	Note	input	mode
Step	3:	Duration	of	the	note	(or	rest)
Step	4:	Enter	pitch	(or	rest)
Other	shortcuts

MIDI	keyboard
Coloring	of	notes	out	of	an	instrument's	range
Small	notes
Change	notes	already	entered
Change	duration
Change	pitch

Note	properties
See	also
External	links

CONCERT	PITCH
See	also
External	links
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Text
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Published on MuseScore (https://musescore.org)

This handbook is for MuseScore version 2.0 and above. It is maintained by the MuseScore
community. Find out how you can help.

Getting started
This chapter helps you to install and run MuseScore for the first time. The chapter will also show you
how to create a new score.

Installation
MuseScore works on many different computer systems including Windows, Mac OS X, and Linux.

Windows

Install

You can get the Windows installer from the download page of the MuseScore website. Click on the
link to start the download. Your Internet browser will ask you to confirm that you want to download this
file. Click Save File.

When the download finishes, double-click on the file to start the installation. Windows may prompt you
with a security window to confirm this before running the software. Click Run to continue, you'll then
briefly see

followed by

In case you don't see this installer window but something else, it's possible that the .msi extension is
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not associated with msiexec.exe. Either you can fix the association, or download and use the portable
version of MuseScore instead.

Continuing you'll see

If you click Cancel, here or later, you'll see:

If instead you click Next to continue, the setup wizard displays the terms of the free software license.
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Read the terms of the license, make sure the box next to I accept the terms in the License
Agreement is checked, and click Next to continue. Next the installer will ask you to confirm the location
in which to install MuseScore.

If you are installing a newer version of MuseScore but still want to keep the old version on your
computer, then you should change the folder (version 2.0 and 1.x can coexist and don't overwrite one
another, so no changes are needed for that). Otherwise click Next to continue.
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Click Install to continue.

Give the setup wizard a few minutes to install the necessary files and configurations. You'll see

and finally
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Click Finish to exit the installer. You may delete the installer file you downloaded.

Start MuseScore

To start MuseScore choose Start → All Programs → MuseScore 2 → MuseScore 2.

Uninstall

You can uninstall on 32-bit Windows with

    cd C:\Program Files\MuseScore
    Uninstall.exe /S

and on 64-bit Windows with

    cd C:\Program Files (x86)\MuseScore
    Uninstall.exe /S

Troubleshooting

On Windows XP and Vista, the installer might be blocked by the system. If you don't manage to install
MuseScore, right click the downloaded file and click Properties. If there is a message "This file came
from another computer and might be blocked to help protect this computer", click on "Unblock", "OK"
and double click on the downloaded file again.

Mac OS X

Install

You will find the DMG (disk image) file on the download page of the MuseScore website. Click on the
Mac OS X link to start the download. When the download is complete, double-click the DMG file to
mount the disk image.
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Drag and drop the MuseScore icon to the Applications folder icon.

If you are not logged in as administrator, Mac OS X may ask for a password: click Authenticate and
enter your password to proceed.

When the application has finished copying, eject the disk image. You can now launch MuseScore from
the Applications folder, Spotlight, or Launchpad.

Uninstall

Simply delete MuseScore from Applications folder.

Linux

Please see the download page for instructions pertaining to MuseScore on Linux. Packages are
provided for Debian, Ubuntu, Fedora and PCLinuxOS. Other distributions will require you to build the
application from source. For instructions specific to Fedora, see below.

Fedora

1. Import the GPG key:

su
rpm --import http://prereleases.musescore.org/linux/Fedora/RPM-GPG-KEY-Seve
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2. Go to the download page of the MuseScore website. Click on the link for the stable Fedora
download and choose the correct rpm package for your architecture.

3. Depending on your architecture, use one of the two sets of commands to install MuseScore

for arch i386

su
yum localinstall musescore-X.Y-1.fc10.i386.rpm

for arch x86_64

su
yum localinstall musescore-X.Y-1.fc10.x86_64.rpm

If you have difficulty with sound, see Fedora 11 and sound

External links

How to change the language in MuseScore
How to install MuseScore on Windows without administrator rights
How to run MuseScore as Administrator on Windows

Create new score
Upon starting MuseScore, you will see the Start Center.

Start center

You can choose between options such as

Create a new score (by using the icon with the plus sign)
Open a previously opened score
If opening MuseScore for the first time, open the "Getting Started" tutorial score
Open an existing score from your computer's file system
See the "In the spotlight" score of the day
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Search sheet music on musecore.com
Link to mobile apps
Link to follow MuseScore on social networks

Create new score

To create a new score when the Start Center is not open, choose File → New... or use the shortcut
Ctrl+N (Mac: Cmd+N). This opens the Create New Score wizard.

Title, composer and other information

Enter the title, composer, or any other information as shown above, then click on Next >.

Select template

20

http://musescore.com


Here, you can choose from a range of solo, ensemble and orchestral templates (discussed in more
detail below). If you wish to choose exactly what instruments should be in your score then click on the
"Choose Instruments" template (under "General").

Choose instruments/voice parts (optional)

If you can't find an appropriate template, then click "Choose Instruments".
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The instrument window is divided into two columns. The left column lists instruments, or voice parts to
choose from. The right column, while initially empty, will soon contain a list of the instruments for your
new score.

The instrument list in the left column is categorized into instrument families. Click a category to show
the full list of instruments in each family. Select an instrument and click Add. The instrument you
selected now appears in the right column. You can add more instruments or voice parts, if needed.

The default entry is "Common instruments" but you can choose from others, including "Jazz
instruments" and "Early music".

You can also type the name of an instrument into the search box to filter for it in "All instruments".

Staff type is usually standard (five lines), but some instruments may utilize other kinds
(drums/percussion, plucked string).

The order of the instruments in the right column reflects how they will appear in the score. To change
the order, click an instrument name and use the Up or Down buttons to move it higher/lower. When
done, click Next >.

Add staff to an instrument
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The Add option is used to create a Grand Staff, where a single instrument (such as a piano, harp or
guitar etc.) uses more than one staff line.

Highlight a staff line in your chosen instrument list in the right column (e.g., "Staff 1"; see image
above) and click either Add Staff or Add Linked Staff. The former will add a suitable unlinked staff
line to the highlighted choice; the latter will add an appropriate linked staff line. The difference is that
the contents of unlinked staves in a Grand Staff can be changed without affecting the other member;
but changes to a linked staff are automatically translated to the other staff (e.g. linked guitar staff/TAB
pairs—see Tablature).

The spacing of a Grand Staff can be controlled with the Grand Staff Distance setting.

Select key signature and tempo
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The wizard asks for two things: The initial key signature and tempo of the score. Select any of the
former and click Next > to continue. An initial tempo can be set here too.

Time signature, pickup measure (anacrusis), and number of measures

You can set your initial time signature here. If the score starts with a pickup, then mark the "Pickup
measure" checkbox and adjust the time signature (a setting known in the context menu 'Measure
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Properties' as actual duration).

The amount of measures can be specified here, but it is possible to amend this later.

Click Finish to create your new score.

Adjustments to score after creation

You can change any settings specified during the new score wizard, even after you start working on
the score.

To add/delete measures or create a pickup, see Measure operations

To change any text, see Text editing. To add a missing Title (or other text item), use the menu
Add → Text → Title (or other text item)

To add, delete, or change the order of instruments, use the menu Edit → Instruments... or
press i.

Templates

The second screen of the new score wizard allows you to choose a template to create a new score
from (see above for details). To create a score using this method, click on a template instead of the
"Choose Instruments" option. Continue and finish the new score wizard as usual.

Template files are normal MuseScore files, stored in a template folder. There are two template folders
created by default: the system template folder that contains the templates installed with MuseScore
and should not be modified, and a private user template folder to add your own templates to. You
can create a template that will show in the new score wizard by simply saving a score into that folder.

System template folder

On Windows, the system template folder is usually located at C:\Program Files\MuseScore
2\templates or in the 64-bit versions at C:\Program Files (x86)\MuseScore 2\templates.

On Linux, look under /usr/share/mscore-xxx if you installed from the package manager. If you
compiled MuseScore on Linux yourself, then look under /usr/local/share/mscore-xxx (with xxx being
the version you are using).

On Mac OS X, look under /Applications/MuseScore 2.app/Contents/Resources/templates.

User template folder

You can configure the location of your private templates folder in Edit → Preferences... → General,
but MuseScore does create a folder for this purpose.

On Windows, the user template folder is located at %HOMEPATH%\Documents\MuseScore2\Templates.

On Mac OS X and Linux, the user template folder is located at ~/Documents/MuseScore2/Templates.

The new score wizard will show templates from both the system and the user template folder.

See also

Key signature
Time signature
Clef
Tempo
Staff type properties

External links

Video tutorial: MuseScore in Minutes: Lesson 1 - Score Setup

Language settings and translation updates
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MuseScore will be installed and work with your "System" language (the one used for most programs,
and generally depending on your country and the language settings of the PC, or account).

Change language

1. Go to Edit → Preferences... (Mac: MuseScore → Preferences...)

2. In the General tab, there is a Language section:

You can change it and also update the translation with the Update Translations button. A new window
will appear, showing your language at the top - see below.

As then indicated, you will have to exit and reopen MuseScore for changes and updates to take effect.

Update translation

You can update the translation as explained above, via the preferences settings, but there is another
method:

1. Go to Help → Resource Manager

2. Click on the Update button
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Here too you will have to exit and reopen MuseScore for the update to take effect.

See also

Helping and improve translation

Checking for updates
There are two ways to check for updates.

Automated update check

1. Go to Edit → Preferences... (Mac: MuseScore → Preferences...)
2. Select the Update tab

3. Check for update...
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Now MuseScore will check for updates on every start and notify you, if need be.

Check for update

1. Select Help → Check for Update

2. A dialog will appear with the update status: either "No Update Available" or "An update for
MuseScore is available:" followed by a link to download it.

See also

Preferences: Updates

Basics
The previous "Getting started" chapter guides you through the installation and process for creating a
new score. The "Basics" chapter gives an overview of MuseScore and describes the general methods
for interacting with the score.

Note input
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Basic note entry

Adding notes and rests to a staff requires four basic steps:

1. Select your starting position for note input
2. Select note input mode
3. Select the duration of the note (or rest) you want to enter
4. Enter the pitch (or rest) using keyboard shortcut, mouse, or a MIDI keyboard

To add overlapping notes that start/end at different times (polyphony), see Voices. For chords,
continue reading here.

Step 1: Starting position

First, select a note or rest on the score as your starting position for note input. If you don't select a
starting point, the cursor will be at the beginning of the score when you begin note input (see below).
Note input in MuseScore replaces the existing rests or notes in a measure with your new notes (i.e.
overwrites, rather than inserts). However, you can insert new measures at any point (see Measure
operations: Insert), or use copy and paste to move a passage of notes.

Step 2: Note input mode

The "N" button at the left on the Note Input toolbar indicates whether you are in note input mode. To
enter or leave note input mode, you can click on the button, or you can use the shortcut N. To leave
note input mode, you can also hit Esc.

Step 3: Duration of the note (or rest)

After entering note input mode, select the duration you need from the Note input toolbar, or use the
corresponding shortcut.

Note that if you have an irregular rhythm division (such as three eighth notes in the time of two), see
Tuplet

The shortcuts for selecting the duration are as follows:

1: 64th (hemidemisemiquaver)
2: 32nd (demisemiquaver)
3: 16th (semiquaver)
4: Eighth (quaver)
5: Quarter (crotchet)
6: Half (minim)
7: Whole (semibreve)
8: Double whole (breve)
9: Longa
.: A period (dot) changes the selected duration into a dotted note/rest

Step 4: Enter pitch (or rest)

For all instruments (except unpitched percussion), you can add note pitches using the mouse by
clicking directly on the staff. (For instructions specific to percussion see Drum notation). However, you
may find it quicker to use a MIDI keyboard (see below), or your alphabetical computer keyboard. The
following examples use the latter method.

Enter pitches by typing the corresponding letter on your keyboard: C D E F G A B C

0 (Zero) creates a rest: for example, typing C D 0 E gives the result shown below. Notice that the
duration you select for the notes (quarter/crotchet notes in this example) also determines the duration
of the rest (quarter/crotchet rest).
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During note input, the cursor automatically advances in the score. If you want to add a chord note to
your previous entry, hold Shift and enter a note name: C D Shift+F Shift+A E F

To create chords with notes of different durations, see Voices.

If you want to create a dotted note, press .. For example 5 . C 4 D E F G A

When you type a note on the keyboard, MuseScore places it closest to the previous note entered
(above or below). When entering chords, though, the new notes are added above the current note
(bottom-up).
If either of these leads to a note ending up in the wrong octave, move it up or down by using the
following shortcuts:

Ctrl+↑ (Mac: ⌘+↑): Increase the pitch of a note by one octave.
Ctrl+↓ (Mac: ⌘+↓): Decrease the pitch of a note by one octave.

Other shortcuts

Other useful editing shortcuts available in note input mode:

↑ (Up): Increase the pitch of a note by a semitone (uses ♯).
↓ (Down): Decrease the pitch of a note by a semitone (uses ♭).
Alt+Shift+↑: Increase the pitch of a note using key signature
Alt+Shift+↓: Decrease the pitch of a note using key signature
J: change note to enharmonic note
R: Duplicate the last entered note
Q: Halve the duration of the last entered note
W: Double the duration of the last entered note
Backspace: Undo last entered note
X: Flip direction of note stem (can be reset to Auto position in Inspector)
Shift+X: Move note head to opposite side of stem (can be reset to Auto position in Inspector)

MIDI keyboard

You can also insert pitches using a MIDI keyboard.

1. Connect your MIDI keyboard to the computer and switch the former on
2. Start MuseScore (this must be done after the keyboard is switched on)
3. Create a new score
4. Click the rest (selecting it) in measure 1 to indicate where you want note input to begin
5. Press N to enter note input mode
6. Select a note duration such as 5 for quarter notes (crotchets), as described above
7. Press a note on your MIDI keyboard

The pitch should be added to your score.

Note: The MIDI keyboard enters one note or chord at a time. This mode of note input (often called
"step-time entry") is fast and reliable. Some notation software try to interpret "real-time entry", in which
the musician plays a passage and the software tries to produce notation. However, such results are
generally unreliable. MuseScore focuses on more reliable forms of note input.

If you have multiple MIDI devices connected to your computer, you may need to inform MuseScore
which is the MIDI keyboard. Go to Edit → Preferences... (Mac: MuseScore → Preferences...). In the

30

https://musescore.org/en/handbook/voices-0
https://musescore.org/en/handbook/inspector-and-object-properties
https://musescore.org/en/handbook/inspector-and-object-properties
https://musescore.org/en/handbook/create-new-score-0


preferences dialog, click on the I/O tab and select your device under the section labeled "PortAudio".

Coloring of notes out of an instrument's range

Notes within the playable range of an instrument or voice part appear black, while those extending
beyond the normal range of an instrument are marked red. For some instruments, the range depends
on the skill of the musician. For these instruments, notes outside the range of an early amateur
appear dark yellow, and notes outside the typical range of a professional appear red.

The colors are informational and appear on the computer screen, but not on printed copies. To disable
note colors, choose Edit → Preferences... (Mac: MuseScore → Preferences...), click on the Note
Input tab, and unmark "Color notes outside of usable pitch range".

Small notes

1. Select the note(s) you want in small size.
2. Check the "Small" checkbox in the Inspector. The one in the Note section is used to only change

the size of the individual note head; the one in the Chord section will change the note, stem,
beam, and flag sizes as a whole.

By default, the small size is 70% of the normal size. You can change that setting in Style → General →
Sizes.

Change notes already entered

Change duration

To change the length of a single note or rest, first press Esc to make sure that you're not in note input
mode and have no other notes selected; then click on the note or rest and use the duration shortcuts
listed above, or the duration icons in the toolbar, to change it to the duration of your choice. Increasing
the duration will overwrite the notes or rests that follow it; decreasing the duration will add rests
between it and the notes or rests following.

For example, to change three sixteenth rests into a single dotted eighth rest:

1. Click on the first sixteenth rest.
2. Hit 4 to turn it into an eighth rest.
3. Hit . to turn it into a dotted eighth rest.

As the duration increases, it overwrites the other two sixteenth rests following it.

Change pitch

To change the pitch of a single note, first press Esc to make sure that you're not in note input mode
and that you have no other notes selected; then either drag the notehead up or down with the mouse,
or else select it and use the ↑ (Up) or ↓ (Down) keys to change its pitch. You can also type the letter
name of the note you want to change it to, and use Ctrl+↓ or Ctrl+↑ to correct the octave, if necessary
(Mac: Cmd+↓ or Cmd+↑).

To change the enharmonic spelling of a note, select it and use the J command. For more information,
see Accidentals.

To change the pitches of a passage of music by a constant interval, you can use Transposition.

To change the pitches of a passage of music to a different melody, while keeping the rhythm
unchanged, use Re-pitch mode.

If your score contains a lot of misspelled accidentals, you might try the Respell Pitches command (see
Accidentals: Respell pitches).

Note properties

See Layout and formatting, especially the sections about notes, accidentals and tuplets
See Inspector and object properties for properties for a note or selection of notes
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See also

Drum notation
Tablature
Tuplet
Voices
Shared noteheads
Preferences

External links

How to enter a chord
How to enter a rest
How to span a stem over two staves
Video tutorial: MuseScore in Minutes: Lesson 3 - Note input
Video tutorial: MuseScore in Minutes: Lesson 4 - MIDI Keyboard Input
Video tutorial: MuseScore in Minutes: Lesson 5 - More Input Ideas

Concert pitch
The Concert Pitch button in the toolbar (towards the right) enables you to switch from displaying
notes on their staves as transposing instruments would need them to be written, where the nominal
pitch may differ from the actual sound of the note, to displaying them as the notes that they actually
sound like. This may change key signatures and/or clefs for transposing instruments.

Note: Before printing, make sure that parts are not in concert pitch mode if you have transposing
instruments in your score; otherwise the musicians will not be able to play in the correct key.

See also

Transposition: Transposing instruments
Accidental: Respell pitches

External links

Concert pitch or not?? (forum discussion)

Copy and paste
Copy and paste is a useful tool for repeating a section of music, or for shifting a passage by a beat or
a measure. Before selecting, copying, or pasting, press Esc to make sure you are not in note input
mode.

Copy

1. Click on the first note of your selection
2. Shift+Click on the last note of your selection. A blue rectangle highlights the region you

selected
3. From the menu choose Edit → Copy or press Ctrl+C (Mac: ⌘+C)

Paste

1. Click on the note or measure where you want your pasted selection to begin
2. From the menu, choose Edit → Paste or press Ctrl+V (Mac: ⌘+V)

Quick repetition

1. Select a note, measure, or passage as described above
2. Press R and MuseScore duplicates the selection

Selection filter

It is possible to use a filter before copying a selection, to choose exactly what is going to be copied
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and then pasted.

1. Enable the Selection Filter with F6 (Mac: fn+F6) or View → Selection Filter

The Selection Filter will appear by default below the Palettes. It can be undocked and made into a
floating window, and if that window is dragged directly onto the Palettes, or the Inspector, then both
will be accessible in the same space via a tab at the bottom.

1. Uncheck the boxes in the Selection Filter for things you don't want copied
Example: Articulations and Slurs are unchecked.

2. Copy and paste as before
(in the example, copy measure 4 and 5 and paste into measure 12 and 13)

3. See the result—slurs haven't been copied:
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See also

If you want to change notes without altering the rhythm, you may combine transposition or re-pitch
mode with copy and paste.

External links

Video tutorial: Lyrics, copying & dynamics

Edit mode
Edit mode is used to edit elements that have been added to a score. Not all elements can be edited in
edit mode, but several key types can be.

To enter edit mode: double-click any element; OR right-click on it and choose Edit Element; OR
click on it once and either right-click and choose Edit Element, or use the shortcut Ctrl+E (Mac:
Cmd+E).
To leave edit mode, hit Esc.

Text

For text edit mode, see Text editing.

Lines

Lines and similar elements, such as slurs, arpeggios, and brackets, show handles in edit mode, which
can adjusted with keyboard commands or by dragging with the mouse to change the shape.

Slur in Edit Mode:

Available keyboard commands:
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←: Move handle left 0.1 staff space (one staff space is the distance between two staff lines, as
set in Page Settings)
→: Move handle right 0.1 staff space
↑: Move handle up 0.1 staff space
↓: Move handle down 0.1 staff space
Ctrl+← (Mac: ⌘+←): Move handle left one staff space
Ctrl+→ (Mac: ⌘+→): Move handle right one staff space
Ctrl+↑ (Mac: ⌘+↑): Move handle up one staff space
Ctrl+↓ (Mac: ⌘+↓): Moves handle down one staff space
Alt+←: Move handle left 0.01 staff space
Alt+→: Move handle right 0.01 staff space
Alt+↑: Move handle up 0.01 staff space
Alt+↓: Move handle down 0.01 staff space
Shift+←: Move handle's anchor (the note or measure to which it is attached) left
Shift+→: Move handle's anchor right
Tab: Go to next handle

Notes

To edit spacing between individual notes

1. Double click on a note head (OR right-click note and select "Edit Element", OR select note and
press Ctrl + E)

2. Press the arrow key in the direction (left or right) that you wish to nudge the note
3. Press the Esc key to finalize the process (this will re-draw the note stem).

Note: you may need to delete and then re-enter ties, as they sometimes fail to re-draw.

Alternatively, you can just click on the note and change the "Horizontal offset" setting in the Chord
section of the Inspector without needing to enter edit mode at all.

Note: Edit mode for a note stem allows you to change the length of the stem, not move it horizontally.
To reposition a note stem, click on it and adjust horizontal offset in the Inspector.

See also

Text editing
Slur
Bracket
Line
Beam
Hairpin

Measure operations

Append

To append an empty measure at the end of a score, press Ctrl+B (Mac: ⌘+B), or use the menu
item Add → Measures → Append One Measure.

To append multiple measures at the end of the score, press Alt+Shift+B (Mac: Option+Shift+B)
or use the menu item Add → Measures → Append Measures..., then in the dialog set the number
of measures to append and hit OK.

Insert

To insert an empty measure into the score, select a measure, then press Ins or use the menu
item Add → Measures → Insert Measure.

To insert multiple measures, press Ctrl+Ins or use the menu item Add → Measures → Insert
Measures..., then in the dialog set the number of measures to insert and hit OK.

Delete

To delete a single measure: select the measure, then press Ctrl+Del (Mac: Cmd+Del).

35

https://musescore.org/en/handbook/layout-and-formatting-0#layout-page-settings
https://musescore.org/en/handbook/inspector-and-object-properties#inspector
https://musescore.org/en/handbook/inspector-and-object-properties#inspector
https://musescore.org/en/handbook/text-editing-0
https://musescore.org/en/handbook/slur-0
https://musescore.org/en/handbook/bracket-0
https://musescore.org/en/handbook/lines-0
https://musescore.org/en/handbook/beam-0
https://musescore.org/en/handbook/hairpin-0


To deleted a range of measures, click on the first measure in the range, pressShift, click on the
last measure in the range, release theShiftkey, and then press Ctrl+Del (Mac: Cmd+Del).

To delete from a selected measure to the end of the score, click on the first measure in the
range, press Ctrl+Shift+End (Mac: Cmd+Shift+End), release the keys and then press Ctrl+Del
(Mac: Cmd+Del).

To delete from the start of the score to a selected measure, click on the last measure in the
range, press Ctrl+Shift+Home (Mac: Cmd+Shift+Home), release the keys and then press Ctrl+Del
(Mac: Cmd+Del).

Note that in a multi-staff score in any of the above cases you'd not just delete the selected measures
in the selected staff, but all corresponding measures in the other staves of the system too, even if
those don't appear to be selected.

Properties

To edit the properties of a measure, right-click an empty part of the measure and select Measure
Properties...:

From within an open Measure Properties window, you can move to edit the previous or next measure
via these buttons, at the bottom left of the window:  (note that while the window changes,
the measure shown as selected in your score does not. Be careful).

Staves

The visible property allows you to show/hide the notes and staff lines for the current measure.
The stemless property allows you to show/hide all note stems for the current measure. Notes
that normally have a stem such as half notes (minims) and quarter notes (crotchets) only show
the note head when marked as stemless.

Measure duration

The Nominal duration (which cannot be edited) is the same as the time signature that is
displayed on the score.
You can change the Actual duration of a measure to anything regardless of the time signature
displayed on the score.
Normally, the nominal and actual duration of a measure are identical. However, a measure can
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have an actual duration that is shorter, such as a pickup measure (anacrusis), or longer, if
measures have been joined (see below).

In the figure below, the quarter note pickup has a nominal measure duration of 4/4, but an actual
duration of 1/4. The measures in the middle have both nominal and actual durations of 4/4. The
complimentary measure with only a dotted half note at the end has an actual duration of 3/4:

Other

Exclude from measure count 
Use "Exclude from measure count" for "irregular" measures, i.e. ones that should not get
counted in the measure numbering. Normally, a pickup measure is marked as "Exclude from
measure count".

Add to measure number 
You can also use the "Add to measure number" option to influence the measure numbering. You
can enter positive or negative numbers here. Please note that this affects all subsequent
measures. A value of "-1" has the same effect as marking a measure to be excluded from
measure count.

Layout stretch 
You can increase or decrease horizontal space between score elements (notes, rests, etc.) with
this option. This provides a more precise control over the exact same measure spacing property
as the menu commands or keyboard shortcuts for Increase/Decrease Stretch ({ and }), which
are accessed outside of the Measure Properties dialog while a measure is selected.

Repeat count 
If the measure is the last of a repeat, you can define how often it is played.

Break multimeasure rests 
This property will separate a multimeasure rest at the start of the selected measure. This option
should be checked before you turn on the "Create multimeasure rests" option in Style →
General..., in the "Score" tab.
Multimeasure rests are automatically broken at important breaks, such as rehearsal marks, time
signature changes, double barlines, irregular measures, etc.
The default for scores is off, for parts is on.

Numbering

MuseScore automatically numbers the first measure of each System (except for the first system,
actually except for a measure with the number 1), but more numbering options are possible. From the
main menu, choose Style → General..., in the left pane, choose the "Header, Footer, Numbers"
tab. At the bottom of the right pane is the "Measure Numbers" ("Bar Numbers") section.

Mark the checkbox next to the "Measure Numbers" ("Bar Numbers") to turn on automatic measure
numbers.

Mark "Show first" if you want the first measure numbered.

Mark "All staves" if you want numbers on all staves. Otherwise, only the top staff of each system
shows measure numbers.

Choose to show numbers on "Every system" which numbers the first measure of each line, or show
numbers by "Interval" and specify the size of the interval. For example, an interval of 1 numbers every
measure; an interval of 5 numbers every fifth measure.

Split and join

You may want have to have a longer or shorter measure without changing the time signature. You can
change a measure's duration in Measure Properties, but there is now a new option to split or join
measures. (Beams may be automatically modified.)
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Join

1. Select the measures you want to join
2. Edit → Measure → Join Measures

Note: If you select measures on only one staff in a score with multiple staves, the same measures will
be joined in each staff of the system.

Split

1. Select a note (or chord)
2. Edit → Measure → Split Measures

Note: If you select only one note from one staff, each staff of the system will be split at the same
place.

See also

How to delete measures
How to span a measure over multiple systems
How to get scores without time signature (and clef)

Palettes
A palette is a storage space containing a group of related musical symbols. A collection of palettes is
called a Workspace and is docked, by default, on the left-hand edge of the window. It can be
undocked if desired, resized and dragged to any convenient location. It can also be docked at the
right-hand side: either half or full length, effectively sharing space with the Inspector.

Workspaces can be toggled on or off with View → Palettes or by using the shortcut F9 (Mac: fn+F9).

Using palettes

Click on a palette title to view the contents of the palette. Symbols are applied to the score from a
palette by one of:

Selecting one or more score elements and double clicking the palette symbol.
Dragging and dropping the symbol onto the desired position in the staff.

For example, you can quickly add tenuto marks (—) to a group of notes:

1. Select notes (click on the first note, then Shift+click on the last note)
2. In the Articulations & Ornaments palette, double-click on the tenuto symbol

To add other music symbols to your palette, see Custom palettes.

Workspaces

MuseScore provides two preset workspaces – Advanced and Basic (the latter is a cut-down version
of the former with less palettes and a smaller number of symbols). Select one or the other using the
drop-down menu at the bottom left of the window, below the palettes themselves.
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You can create your own custom workspaces by selecting an existing workspace using the menu in
the bottom left of the window, clicking the plus sign and entering a name for the new workspace. You
are then free to edit the palettes and symbols of this workspace yourself.

Preset palettes

The more fully-featured Advanced workspace contains the following palettes:

Grace Notes
Clefs
Key signatures
Time Signatures
Barlines
Lines
Arpeggios and Glissandos
Breaths and pauses
Brackets
Articulations and ornaments
Accidentals
Dynamics
Fingering
Noteheads
Tremelo
Repeats and Jumps
Tempo
Text
Breaks and Spacers
Bagpipe embellishments
Beam properties
Frames and Bars
Fretboard diagrams

Master palette

Music symbols not part of the palettes in the Advanced workspace can be found in the Master palette
by pressing Z or Shift+F9 (Mac: fn+Shift+F9).
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See also

Custom palettes
Workspace
Master palette

Preferences
You may want to have a general style or folders preselected as you use MuseScore.
You can set this via Edit → Preferences... (Mac: MuseScore → Preferences...):

A preference window will appear with multiple tabs:

Some changes may need a restart (quit and reopen) of MuseScore to take effect. A message box will
tell you when you click either Apply or OK.

Reset All Preferences to Default will reset them to the ones MuseScore had when you installed it.
Cancel will abandon any changes you just made.

General

Here you can define:

Your opening score
The default folder to search for your scores, soundfonts, templates and so on
Your auto save timing
The languages of MuseScore (translations may be updated from here too)
The style of your MuseScore windows and size of icons
The windows to show at startup (Play Panel, Navigator, MuseScore Connect).
Note that language translation updates can also be done via Help → Resource Manager

Canvas
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Use Canvas to set your preferred color and wallpaper for the score background and paper.

Under Miscellaneous, checking Draw antialiased (on by default) makes diagonal lines and edges of
shapes look smoother (less jagged). Proximity for selecting elements controls the distance the
mouse may be from an object and still act on it. Smaller numbers require more precision, making it
harder to click on small objects. Larger numbers are less precise, making it harder not to click on
nearby objects unintentionally. Choose a comfortable working value.

Note input

On this tab there are note input and MIDI remote control preferences. Here the following can be set:
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Enter notes via MIDI
Enable playback on entering a note
Its playback duration
Color notes outside the usable pitch range
MIDI Remote Control settings

Score

Score preferences include

Default instrument list files (two may be selected)
Default style for score and parts
Default zoom

I/O
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Input/Output preferences enable you to set what device will be used for audio playback (e.g., built-in
speakers, USB headset, wireless, etc.), whether to use a MIDI trigger (plugged-in keyboard), and
whether to route audio output through JACK.

Import

These settings determine how files from other sources are imported:

Using either the built in MuseScore style or a style you choose
Guitar Pro and Overture character sets
MusicXML layout options
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Shortest note in MIDI files

Export

These settings determine how MuseScore files are exported:

PNG/SVG image resolution (in DPI) and whether to use transparent background
Whether to expand repeats in exported MIDI files
Digital audio sample rate
Whether to export the layout and how to export system and page breaks to MusicXML

Shortcuts
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Every action possible with MuseScore is listed, with the associated shortcut if it exists. To define a
new shortcut click on the existing entry in the list and press Define (or double click the entry): then
enter the new shortcut using up to four keys. You can reset all the default shortcuts, or clear a shortcut
you select. Shortcuts listed in preferences also appear next to their associated commands in the
menus.

(Note that some shortcuts, including default ones, can't be used with some keyboards. Test well.)

Update

This sets whether MuseScore will check for updates at startup.

45



Updates may be checked manually in Help → Check for updates

See also

Keyboard shortcuts
Language settings and translation updates
Update checking

Save/Export/Print
Under the File menu in MuseScore, you can find options such as Save..., Save As..., Save a
Copy..., Save Selection..., Save Online..., Export..., Export Parts... and Print....

Save

Save..., Save As..., Save a Copy..., and Save Selection... allow you to save native MuseScore files
(.mscz and .mscx).

Save...: Save current score to file.
Save As...: Save current score to new file.
Save a Copy...: Save current score to new file, but continue to edit original file.
Save Selection...: Save selected measures to new file.
Save Online...: Save current score to MuseScore.com (see Share scores online).

Export

Export... and Export Parts... allow you to create non-MuseScore files, such as PDF, MusicXML,
MIDI, and various audio and image formats.

In the Export dialog, you can choose which format to export to:
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Export...: Export current score to format of your choice.
Export Parts...: Export current score and all linked parts to separate files in format of your
choice.

Note: Uncompressed MuseScore format (MSCX) is available in both 'Save' and 'Export'.

Print

Print... allows to print your MuseScore file directly to a printer from MuseScore. Depending on your
printer you will have different options, but generally you can define the page range, number of copies
and collation.

If you have a PDF printer installed, you could also "export" to PDF using that.

See also

File format
Part extraction

Selection modes
There are different selection modes (ways to select objects).

Selection of a single object

Just click on any object.

Selection of a single chord

To select all the notes in a particular voice of a chord:

Make sure you are not in note input mode
Press and hold Shift, then click on a note in the chord.

Range selection

There are several ways to select a continuous range of score elements:

1. Shift + Click selection (notes/rests only)

a) Make sure you are not in note entry mode
b) Click on the first note/rest in the range
c) Press and hold Shift
d) Click on the last desired note/rest.
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The final selected element can be in the same staff or in staffs above or below the initial
note/rest. All selected elements will be enclosed in a blue rectangle, including associated lines
and articulations (but not voltas). You can repeat the operation to extend the selected range as
required.

Measure selection: You can also select a range of whole measures by clicking on a blank
space in the first desired measure, pressing shift, then clicking on a space in the last measure of
the range. As with selecting notes, the range can be vertical as well as horizontal.

2. Drag selection (all elements)

Press and hold Shift and drag the cursor across the desired range. This method can be used to
select notes/rests OR independently to select non-note symbols (e.g. staccato dots, lyrics etc.).

3. Select from note or measure to beginning/end of score

a) Select a measure or note. Extend the selection up or down to adjacent staves, if needed,
using Shift-click.

b) Press Ctrl + Shift + Home to extend the selection to the beginning of the score. OR press Ctrl
+ Shift + End to extend the selection to the end of the score.

4. Select All (notes/rests and elements attached to notes/rests)

Press Ctrl+A (Mac: Cmd+A) to select every music staff in the score:

Note: See Copy and paste: Selection filter to disable certain types of elements from being selected in
a range selection.

List selection

To select multiple individual elements (as opposed to a continuous range):

1. Select (click on) the first element
2. Press Ctrl (Mac: Cmd)
3. Select (click on) additional elements while holding the Ctrl (Mac: Cmd) key.

Select all similar

To select all elements of a specific type (e.g., all barlines, all text elements, all staccato markings):

1. Select an element
2. Right click → Select

3. Several options are available:

All Similar Elements: in the whole score
All Similar Elements in Same Staff: only in the same staff
All Similar Elements in Range Selection: only if a →range selection is active, selects
similar elements only inside that selection
More... : opens a dialog that lets you fine-tune more options.

Example: A flat (accidental) selected
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You can choose from the following selections:

Same subtype: in this example only flats will be selected (not sharps nor naturals); some
elements have a subtype (e.g. articulations, accidentals ...)
Same staff: only elements in the same staff
Same voice: only elements in the same voice
Same system: only elements in the same system
Same selection: if a selection is active, only elements in that selection

Depending on what you had selected before you opened the Select → More... dialog, you may
wish to now instead have all of your specified type of elements selected (the default, "Replace");
keep everything you had selected before still selected, and simply add all of your chosen type of
element ("Add"); or keep everything you had selected before still selected, except without your
specified type of element ("Subtract").

What selections are useful for

Copy and paste
Edit mode
Inspector and object properties
Tools

See also

Basics chapter, esp. Note input
Notation chapter, esp. Accidental
Text chapter, esp. Text editing and Grid-based movement of symbols and staff text

Undo and redo
MuseScore remembers an unlimited number of undo/redo actions.

The standard shortcuts are:

Undo Ctrl+Z (Mac: ⌘+Z)
Redo Ctrl+Shift+Z or Ctrl+Y (Mac: ⌘+Shift+Z)

Or use the toolbar buttons:

View modes
You can view your sheet music in different modes.
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Except for Page View/Continuous View, all the options below can be found under the View menu in
MuseScore.

Page/Continuous View

In Page View, you can see your sheet music formatted as it will appear when printed or exported as a
PDF or image file. In Continuous View, the score will be shown as one unbreaking system.

Note that when switching between Page View and Continuous View, the score is reformatted for the
new view and manual adjustments may require reviewing.

You can switch viewing modes here:

Page View

In Page View, the score is shown as one or more pages of a specific size with margins, and you can
see all lines and page breaks, including those added manually and those automatically calculated by
the software. (Manual page breaks can be helpful to have well-placed page turns in orchestral parts,
for example.)

Continuous View

In Continuous View, the score will be shown as one unbreaking system. If the starting point is not in
view, then a substitute form of measure numbers, instrument names, clefs, time and key signatures
will be displayed.

Before printing a score or uploading it to MuseScore.com, switch to Page View to check line/page
breaks.

Note: Because the layout is simpler, MuseScore may perform faster in Continuous View than Page
View.

Zoom

In Page View or Continuous View, you can set the level of zoom (note: this does not affect printed
size) using the dropdown menu in the standard toolbar.
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Here you can change the view magnification of the score (25–1600 %) or display it using the options
"Page Width", "Whole Page", and "Two Pages" (scales related to the size of the window).

Zoom In and Zoom Out options are available in the View menu; or use the keyboard shortcuts Ctrl +
+ or Ctrl + -. To return to 100% zoom use the shortcut Ctrl + 0.

You can also zoom in and out by scrolling up or down while holding down the Ctrl (Mac: Cmd) key.

View more than one score at once

You may have your documents side by side

or stacked
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You can drag the barrier separating the two scores to adjust the amount of space in the window
devoted to each.

Full screen

Full Screen mode expands MuseScore to fill your screen so more content is visible.

Navigator

If you have a long score and want to see where you are located in it or go to a specific page, use the
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Navigator at the bottom of the screen.

The blue box represents the area of the score that is visible in the main window. You can drag either
the blue box or the scroll bar, or click on an area to immediately go to it.

To enable/disable the Navigator, go to the View menu and select Navigator, or use the shortcut F12
(Mac: fn+F12).

Find

Keyboard shortcut Ctrl + F opens the Find bar. Here you can enter a measure number, page number
– using the format pXX (where XX = a page number) – or the text of a rehearsal mark.

See also

Keyboard shortcuts, Navigation
Save/Export/Print
File format
Layout and formatting

File format
MuseScore supports a wide variety of file formats, which allows you to share and publish scores in the
format that best meets your needs.

You can import files via File → Open... and export via File → Export.... For more details, see
Save/Export/Print.

In addition to the formats detailed below, you can save and share your scores on the web at
MuseScore.com File → Save Online.... See Share scores online.

MuseScore native format

These are the formats used by File → Save or the  button or shortcut (Ctrl+S) and
File → Save as... dialog.

MuseScore format (*.mscz)
MSCZ is the standard MuseScore file format and recommended for most uses. A score saved in
this format takes up very little disk space, but preserves all the necessary information. The
format is a ZIP-compressed version of .mscx files and includes any images.

Uncompressed MuseScore format (*.mscx)
MSCX is the uncompressed version of the MuseScore file format. A score saved in this format
will retain all information, except images. It is recommended for when manually editing the file
format (using a text editor).
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Note about fonts: MuseScore does not embed text fonts in the file, except for the FreeSerif,
FreeSerifBold, FreeSerifItalic, FreeSerifBoldItalic and FreeSans font families. If you want to share a
MuseScore file with other parties, choose either these fonts for your text, or a font that the other
parties have installed too. When a system does not have the fonts specified in the file, MuseScore will
use a fallback one - this may cause your score to appear differently, however.

MuseScore backup file (*.mscz, or *.mscx,)
Backup files are created automatically and saved in the same folder as your normal MuseScore
file. The backup copy contains the previously saved version of the MuseScore file and can be
important if your normal copy becomes corrupted, or for looking at an older version of the score.
The backup file adds a period to the beginning of the file name (.) and a comma (,) to the end
(e.g. if your normal file is called "untitled.mscz", the backup copy will be ".untitled.mscz,"), and
the period and comma need to be removed from the name in order to open the backup file in
MuseScore. As it is stored in the same folder as your normal MuseScore file, you may also need
to give it a unique name (e.g. changing ".untitled.mscz," to "untitled-backup1.mscz"). Note: In
order to see the MuseScore backup files, you may need to change your system settings to
"Show hidden files". See also How to recover a backup copy of a score (MuseScore 2.x).

Graphics—view and print (export only)

MuseScore can export (via the File → Export... command) to the following formats that contain a
visual representation of the score, but cannot be edited or played back:

PDF (*.pdf)
Portable Document Format (PDF) is ideal for sharing your sheet music with others who do not
need to edit the content. Most users have a PDF viewer on their computer, so extra software
won't usually be required to see it.

PNG (*.png)
Portable Network Graphics (PNG) is a bitmap image format widely supported by software on
Windows, Mac OS, and Linux. The image format is particularly popular on the web. Multi-page
scores export a PNG file for every page. MuseScore creates images as they would appear on
the printed page. On the export tab in Edit → Preferences... (Mac: MuseScore →
Preferences...), you can set the resolution and whether to use transparent background.
__Note:__If you want to create images that show only parts of the score (with or without screen-
only items such as frame boxes, invisible notes, and out-of-range note colors), use Image
capture.

SVG (*.svg)
Scalable Vector Graphics (SVG) can be opened by most web browsers (except Internet Explorer
before version 9) and most vector graphics software. However, most SVG software does not
support embedded fonts, so the appropriate MuseScore fonts must be installed to view these
files correctly.

Audio—listen (export only)

MuseScore can export (via the File → Export... command) to the following formats that contain a
synthesized audio recording of the score:

WAV audio (*.wav)
WAV (Waveform Audio Format) is an uncompressed sound format. This was developed by
Microsoft and IBM, and is widely supported by software for Windows, OS X, and Linux. It is an
ideal format for use when creating CDs, as full sound quality is preserved. However, the large
file sizes make it difficult to share via email or the web.

FLAC audio (*.flac)
Free Lossless Audio Codec (FLAC) is compressed audio format. FLAC files are approximately
half the size of uncompressed audio and just as good quality. Windows and OS X do not have
built-in support for FLAC, but software such as the free and open source VLC media player can
play FLAC files on any operating system.

Ogg Vorbis (*.ogg)
Ogg Vorbis (external link) is intended as a patent-free replacement for the popular MP3 audio
format (which MuseScore also supports—see below). Like MP3, Ogg Vorbis files are relatively
small (often a tenth of uncompressed audio), but some sound quality is lost. Windows and OS X
do not have built-in support for Ogg Vorbis. However, software such as VLC media player and
Firefox can play Ogg files on any operating system.
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MP3 (*.mp3)
MP3 files are relatively small (often a tenth of uncompressed audio), but some sound quality is
lost. To be able to create MP3 files, an additional library, lame_enc.dll (Windows) or
libmp3lame.dylib (Mac), needs to be installed. MuseScore will prompt you for its location. You
can get it at http://lame.buanzo.org/. Some Mac users may find MuseScore encounters an error
loading the MP3 library, possibly due to that library being a 32-bit library. A 64-bit build that will
work with MuseScore is available from http://www.thalictrum.com/en/products/lame.html (note
that it is necessary to rename the file to libmp3lame.dylib for MuseScore to recognize it).

Share with other music software

The following are musical score formats (like MuseScore's native format, MSCZ), which allow you to
import files made with other music notation programs or export files that you can open with other
music notation programs.

MusicXML (*.xml)
MusicXML is the universal standard for sheet music. It is the recommended format for sharing
sheet music between different scorewriters, including MuseScore, Sibelius, Finale, and more
than 100 others.

Compressed MusicXML (*.mxl)
Compressed MusicXML creates smaller files than regular MusicXML. This is a newer standard
and isn't as widely supported by older scorewriters, but MuseScore has full import and export
support.

MIDI (*.mid, *.midi, *.kar)
Musical Instrument Digital Interface (MIDI) (external link) is a format widely supported by
sequencers and music notation software. MIDI files are designed for playback purposes and do
not contain score layout information about formatting, pitch spelling, voicing, ornaments,
articulations, repeats, or key signatures, among other things. To share files between
different music notation software, MusicXML is recommended instead. If you are only
interested in playback, use MIDI.

MuseData (*.md) (import only)

MuseData is a format developed by Walter B. Hewlett beginning in 1983 as an early means of sharing
music notation between software. It has since been eclipsed by MusicXML, but several thousand
scores in this format are still available online.

Capella (*.cap, *.capx) (import only)
CAP and CAPX files are created by the score writer, "Capella". MuseScore imports version 2000
(3.0) or later fairly accurately (2.x doesn't work, while the *.all format from 1.x versions is not
supported at all).

Bagpipe Music Writer (*.bww) (import only)
BWW files are created by the niche score writer, "Bagpipe Music Writer".

BB (*.mgu, *.sgu) (import only)
BB files are created by the music arranging software, "Band-in-a-Box". MuseScore's support is
currently experimental.

Overture (*.ove) (import only)
OVE files are created by the score writer "Overture". This format is mainly popular in Chinese-
language environments, such as Mainland China, Hong Kong, and Taiwan. MuseScore's support
is currently experimental.

Guitar Pro (*.GTP, *.GP3, *.GP4, *.GP5, *.GPX) (Import only)
GP files are created by Guitar Pro.

See also

Save/Export/Print

Share scores online
Go to musescore.com/sheetmusic to view other scores from MuseScore.
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You can save and share your scores online at MuseScore.com. You can choose to save a score
privately for personal access from any computer, or share it publicly. MuseScore.com enables the
viewing and playback of scores in your web browser - an additional feature entitled VideoScores allows
synchronization between the score and a YouTube video. For use outside of a web browser, you can
download the score in a variety of formats (including PDF, MIDI, MP3, MusicXML, and the original
MuseScore file).

Create an account

1. Visit MuseScore.com and click on "Create new account". Pick a username and enter a valid
email and press "Create New Account".

2. Wait a few minutes for an email from MuseScore.com support. If no email arrives, check your
spam folder.

3. Click the link in the email and visit your user profile to change your password.

Share a score directly from MuseScore

You can directly save a score online from File → Save Online....

If you don't have a MuseScore account yet, create one first by clicking on the Create an account link.
That will open your browser app and bring you to https://musescore.com/user/register

Next, enter your email address or MuseScore username, and password. Upon successfully logging in,
you'll be able to enter your score information.

56

http://musesore.com
http://musescore.com/?utm_source=handbook
http://musescore.com/user/register
http://musescore.com/user?utm_source=handbook
https://musescore.com/user/register


1. The title is the title of the score.
2. The description will appear next to it.
3. Privacy can be set to Public (visible to everyone), or Private (only visible to you or those you

share a "secret link" with).
4. Choose a license. By using a Creative Commons license, you allow people to use your scores

under certain restrictions.
5. You can add tags to help identify scores on MuseScore.com - these are separated using the

Enter key.
6. In case you already saved the score online earlier, it will automatically update the existing one.

Uncheck Update the existing score to save online as a new score.

Upload a score on MuseScore.com

You can also upload a score directly on MuseScore.com.

1. Click the Upload link on MuseScore.com.
2. You have the same options as with the Save Online menu.
3. You have also access to more information, such as Genre.

Note: Should you reach the five score upload limit, you can still upload score directly from MuseScore,
but only the last five are visible. If you wish more than this amount, upgrade to a Pro Account first.
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Edit a score on MuseScore.com

If you want to make changes to one of your scores on MuseScore.com, edit the MuseScore file on
your own computer and follow the steps below.

1. Go to the score page on MuseScore.com.
2. Click the edit link.
3. In the form, you can change the score file, information and privileges.

See also

How to delete a score saved on MuseScore.com

Notation
In the previous "Basics" chapter you learn how to enter notes and interact with the palette. The
"Notation" chapter describes the different types of notation in more detail, including more advanced
music notation.

See also "Advanced topics"

Accidentals
Accidentals can be set/changed by dragging an accidental symbol from the Accidentals palette to a
note in the score.

If you only want to change the pitch of a note, you can also select the note and press:

↑: Increase the pitch of a note by one semitone (favors sharps).
↓: Decrease the pitch of a note by one semitone (favors flats).
Ctrl+↑ (Mac: Cmd+↑): Increase the pitch of a note by one octave.
Ctrl+↓ (Mac: Cmd+↓): Decrease the pitch of a note by one octave.
J: Change the enharmonic spelling of a note.

To change an existing accidental into a cautionary accidental (enclosed in parentheses), drag the
parentheses from the accidental palette onto the existing accidental (not the note head). To remove
parentheses, select the accidental and press Del.

If you later change the pitch with cursor keys, manual settings to the accidental are removed.

Respell pitches

The menu function Notes → Respell Pitches tries to guess the right accidentals for the whole score.

See also

Key signature: Change

External links

Accidental on Wikipedia

Arpeggio and glissando
Arpeggios and Glissandos are created by selecting a note and double-clicking the desired symbol in
the Arpeggios and Glissandos palette (see illustration below). The Inspector allows you to make
various adjustments to the appearance and playback properties of the symbol.
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To change the length of an arpeggio or strum arrow, double-click the symbol in the score and drag the
handles up or down.

Glissandi are set by double-clicking a glissando symbol from the Arpeggio & Glissando palette to the
first of two consecutive notes on the same staff.

Edit, or delete the text of a glissando by clicking it and making changes in the Inspector. If there isn't
enough room between two notes, MuseScore will not display the text.

Slides for stringed instruments, such as the guitar, can be created by editing the default glissando
line. Normally, only one slide can be created per voice because MuseScore, by default, always uses
the top note of a chord as the destination. However, there is an easy workaround for chord slides:
Build up the destination chord note by note, starting at the bottom, and apply a glissando from the
desired note after each step. For example:

Short up/down slides can be created by editing the existing slide in / slide out lines. These have
handles which allow the user to set the length and angle.

External links

Arpeggio on Wikipedia
Glissando on Wikipedia

Barline
Barline symbols are available in the Barlines palette:
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Change barline type

There are several ways to change existing barlines in the score:

Select a barline, then double click on a symbol in the Barlines palette, OR
Drag a symbol from the Barlines palette onto a barline in the score, OR
Drag a symbol from the Barlines palette onto a measure, OR
Select a measure, then double-click on a symbol in the Barlines palette.

You can also insert new barlines between existing ones:

Drag a symbol from the Barlines palette onto a note or rest, OR
Select a note or rest, then double-click a symbol in the Barlines palette.

To hide a barline entirely, select the line and press V, or uncheck Visible in the Inspector, which can
be enabled from the View menu or by pressing F8 (Mac: fn+F8).

Create grand staff (great stave)

To extend barlines over multiple staves, double-click on a barline (see Edit mode).

Click and drag the blue handle down to the next staff.

The staff barline updates appear after leaving edit mode.

See also

Measure operations

Beam
Beams are set automatically, but they can be altered manually. Drag a beam symbol from the "Beam
Properties" palette to a note in order to change its behavior.
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Alternatively, you can first select a note (or rest), and then double-click the appropriate symbol in the
palette.

 Start a beam at this note.

 Do not end a beam at this note (or rest).

 Do not beam this note.

 Start a second level beam at this note.

 Start a third level beam at this note.

 (back to) Automatic mode: the mode MuseScore chooses on note input, dependent on
current time signature.

 Start feathered beam (slower) at this note.

 Start feathered beam (faster) at this note.

To change the beam angle, or the distance of the beam to the notes (i.e. the length of the stems),
double-click on the beam to put it into edit mode, with the right end handle being selected. Up/down
arrow will now change the angle. Selecting the left end handle and using the up/down arrow keys will
lengthen/shorten the stems. Hit Esc to get out of edit mode, once done with the changes.

To move a beam from above to below the notes, or vice-versa, flip the direction of the stems by using
the button along the second top row (before the voice indicators) that shows a note with stems
attached above and below or use the X key.

See also

Cross staff beaming
Edit mode
Note input
How to add a beam over a rest
How to place a beam between notes

Bracket

Delete

Select the bracket and press Del

Add

Drag a bracket symbol from the bracket palette to an empty space in the first measure of a system.

Change
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Drag a bracket symbol from the bracket palette to a bracket in the score.

Edit

Double-click on a bracket to enter edit mode. In edit mode, you can drag the height of a bracket to
span arbitrary staves of a system.

Horizontal offset

If you need to move a bracket further left or right, then double-click the bracket to enter edit mode,
and press Shift+← or Shift+→.

Breath and pause
To place a breath symbol, drag it from the breath palette (from the Advanced workspace) to a note in
the score. The breath symbol is placed after the note.

Breath symbol in score:

Caesura (informally called tram lines or railroad tracks) work the same way.

Clef
Clefs are located in the Clefs palette in both the Basic and Advanced workspaces. To show or hide
the palettes, select the View menu and check/uncheck Palettes, or use the shortcut F9 (Mac: fn+F9).

Note: The Clefs palette in the Basic workspace only displays treble, bass, alto and tenor clefs. To
access more, switch to the Advanced workspace (see image below) using the menu below the
palettes. You can also create a custom palette containing exactly the clefs you want.

Add a clef

Add clef to beginning of measure

Method 1—add clef to beginning of a measure, whether or not it is the first measure in a system

Select a measure and double-click a clef symbol in the palette, OR
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Drag a clef from the palette into an empty part of a measure.

Method 2—only for changing the clef at the start of a system

Select the existing clef at the beginning of the system and double-click a new clef from the
palette, OR
Drag a new clef from the palette directly onto the existing clef.

Add mid-measure clef

To create a mid-measure clef:

Drag a clef from the palette directly onto a note (make sure that the cursor is over the note,
which should turn blue, before dropping the symbol), OR
Click on a note and then double-click a clef in the palette.

Note: If the measure is not the first in the staff, the clef will be drawn smaller.

In this image, the top staff starts with a treble clef and switches immediately to bass clef, then after a
note and a rest, changes back to treble clef.

Note: Changing a clef does not change the pitch of any note. Instead, the notes move to preserve
pitch. If you want, you can use Transposition in conjunction with a clef change.

Courtesy clefs

When a clef change occurs at the beginning of a system, a courtesy clef will be generated at the end
of the previous system. To show or hide courtesy clefs, go to Style → General... → Page and
check/uncheck the "Create courtesy clef" option.

Remove a clef

Select a clef and press Del.

Hide clefs

Display clef only in the first measure (for all staves)

Go to Style → General... → Page and uncheck "Create clef for all systems."

Display clef only in the first measure (for a particular staff)

1. Right click on the staff, select Staff properties... and uncheck "Show clef."
2. Open the Master Palette and select the "Symbols" section.
3. Drag and drop a clef from the master palette onto the first measure of the staff, OR select the

first note and double-click a clef in the master palette

Note: This option may be useful to TAB users who do not want the clef to repeat on every subsequent
line.

Hide all clefs in a particular staff

Right click on the staff, select Staff properties... and uncheck "Show clef."
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Drum notation

Notation for drumsets often includes simultaneous upstem and downstem notes. If you are unfamiliar
with editing multiple voices in a single staff, see Voices for an overview.

It is recommended to familiarize yourself with Note input before trying percussion notation.

MIDI keyboard

The easiest way to add drum notation to your score is via MIDI keyboard. Some MIDI keyboards have
percussion markings above each key. If you press the key for high hat, then MuseScore will add the
correct notation to the score. MuseScore automatically takes care of the stem direction and type of
note head.

Computer keyboard

To enter notes on a percussion staff using your computer keyboard, first click on the staff and press N
to enter note input mode. By default, seven drum sounds are mapped to a keyboard shortcut (A-G),
just as in regular note input. You can remap those seven shortcuts to other drum instruments via the
Edit Drumset button of the drum input palette (see →below).

If you wish to enter a new drum note at the same position as an existing note—for example, if you
want the snare and hi-hat to sound simultaneously—to enter the new note via the computer keyboard,
hold Shift when entering the new note so as not to overwrite the existing note. This is the same
method as used when entering chords for tuned instruments under MuseScore (see Note input).

Mouse

Note input for unpitched percussion works differently than for other instruments, so here are the
special steps:

1. Select a note or rest in the percussion staff
2. Press N to to enter note input mode

Please note that the drum input palette will only appear at the bottom of the screen when you
have completed this step:

3. Select a note duration from the note input toolbar at the top of the screen as in regular note input
4. Select a type of note (such as bass drum, or snare) on the drum input palette
5. Click on the percussion staff to add the note to the score

Double-click on a note type in the drum input palette will immediately add that note at the current
input-cursor location. Note that all existing notes at the location will be replaced.

Drumset

On a percussion staff, the sounds produced by different pitches depend on the SoundFont installed
and the sound selected for the staff in the Mixer.

Groups of pitches that produce related sounds (eg: for a jazz or rock drum kit) can be brought together
in a drumset. In a drumset definition, each of the related pitches can be assigned a name, an
appearance and location on the staff, a default voice, and optionally a keyboard shortcut that can be
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used in note input mode. To edit the details of a drumset, while in note input mode on a percussion
staff click the Edit Drumset button at the left of the drum input palette. The drumset can also be edited
by right-clicking on the staff and selecting Edit Drumset....

Drumsets are stored as .drm files, but customizations can be saved and loaded into others.

Roll

To create a drum roll, use Tremolo.

External links

How to create jazz drum notation [MuseScore How-To]
Video tutorial: MuseScore in Minutes: Lesson 7 - Tablature and Drum Notation
Drum Parts [video]
Editing the Drum Palette in MuseScore 1.1 [video]
Saving Drumset Changes in MuseScore 1.1 [video]
Guide to Drum and Percussion Notation

Grace note
A grace note is a type of musical ornament, usually printed smaller than regular notes. The Short
grace note, or Acciaccatura, appears as a small note with a stroke through the stem. The Long grace
note, or Appoggiatura, has no stroke. They can occur singly or in groups.

Create grace notes

Grace notes can be found in the "Grace notes" palette in the Basic or Advanced Workspace.

Add a grace note

Select a regular note and double click a grace note in a palette, OR
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Drag a grace note symbol from a palette onto a regular note, OR
Select a note and press / to create an acciaccatura only.

To add a group of grace note to a regular note, simply repeat the above actions as many times as
required.

Add a chord of grace notes

Grace note chords are built up just like regular chords:

1. Enter the first note of the chord as shown above
2. Select this first grace note and enter subsequent notes as you would for any other regular chord

(i.e. Shift+ note names (C, D, E etc...) etc).

If you want to change the duration of a previously created grace note, select it and choose a duration
from the toolbar or enter with one of the keys 1 ... 9 (see Note input).

Grace notes after a note (such as a trill termination) may have to be manually adjusted with Ctrl +
arrow keys.

External links

Grace note at Wikipedia
Appoggiatura at Wikipedia
Acciaccatura at Wikipedia

Hairpin

Add a hairpin

Hairpins are line objects. To create a hairpin, select the range of notes that you want the hairpin to
cover.

< creates a crescendo hairpin
> creates a diminuendo hairpin (decrescendo)

You can also create hairpins by double-clicking a hairpin in the Lines palette while notes are selected.

Edit a hairpin

Once you have a hairpin in your score, you can adjust, extend, or move it. Double-click on the hairpin
to enter edit mode.
Then select (click on) the end point to move:

1. Shift+→ or Shift+← moves the anchor of the selected end point, which determines which notes
the playback will affect and enables the hairpin to extend across line breaks:
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2. → or ← and Ctrl+→ or Ctrl+← (Mac: Cmd+→ or Cmd+←) move the selected end point without
changing where it is anchored. This method is suitable only for small adjustments to the
visual appearance of the hairpin. To extend the hairpin under more or fewer notes, use
Shift+→ or Shift+← to change the anchor (see above). The "Reset" command Ctrl+R (Mac:
Cmd+R) will undo these small adjustments, but will not undo anchor changes.

Hairpin playback

Playback of crescendos and diminuendos is only effective from one note to the next; it currently is not
possible to change the dynamic over the course of a single note. Hairpins will affect playback only if
dynamics are used before and after the hairpin.

Key signature
Key signatures are available in the Key Signatures palette in the Basic or Advanced workspaces:
You can re-order, add or delete key signatures by creating your own workspace. If the desired key
signature is not on display you can create it using the Master key signature palette (press Shift + K
to view), which also allows you to use a wide range of non-standard symbols.

Add a new key signature

Add new key signature to all staves

Drag a key signature from the palette onto an empty part of a measure, OR
Select a measure and double-click a key signature in the palette, OR
Select a note and double-click a key signature in a palette.

Add new key signature to one staff only

If you wish to change the key signature of only one staff line, leaving others unchanged:

Press Ctrl (Mac: ⌘) and hold while you drag a key signature from a palette onto a measure.

Replace an existing key signature

Replace key signature for all staves
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Drag a key signature from the palette onto the key signature to be replaced (or onto the measure
containing the key signature), OR
Select the key signature to be replaced, and double-click a new key signature in a palette.

Replace key signature for one staff only

If you wish to replace the key signature of only one staff, leaving others unchanged:

Press Ctrl (Mac: ⌘) and hold while you drag a key signature from a palette onto the key
signature to be replaced (or onto the measure containing the key signature).

Remove a key signature

Click on an existing key signature and press Del, OR
Drag the empty key signature from the palette (in the advanced workspace) onto the measure.

Courtesy key signature

In the Inspector for a selected key signature, there is an option for "Show courtesy." Additionally, Style
→ General... → Page has on option for "Create courtesy key signatures". The Inspector will affect only
the selected one; the style setting will affect the entire score.

Naturals on key signature changes

You can choose whether to show natural(s) in certain cases when changing the key signature. Under
Style → General... → Accidentals you'll see the options:

You can Apply the changes, or click OK. If you are in a linked part, rather than in the primary score, you
can use the Apply to all parts button.

In this example, the key signature change is showing naturals.

]

Key signature and multimeasure rest

Multimeasure rests are interrupted, if there is change in the key signature.

See Multimeasure rest

Courtesy key signature and section break

A courtesy key signature will not be shown just before a section break.
See Break or spacer: Section break
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Custom key signatures

Press Shift+K to bring up the master key signature palette.

You can even use half-flats, half-sharps, etc.

Note, however, that currently the playback of custom key signatures is not supported.

Lines
The Lines palette of the advanced workspace includes the following types of lines:

Slur

69

https://musescore.org/sites/musescore.org/files/Master_palette-Key_sig_en.png
https://musescore.org/sites/musescore.org/files/Master_palette-Accidentals_en.png


Hairpins (crescendo and diminuendo)
Volta brackets (1st, 2nd, 3rd time endings etc.)
Octave lines (8va, 8vb, 15ma etc)
Keyboard sustain pedal
Various brackets
Extended ornament lines
Guitar barre line
Straight line
Ambitus (early music symbol)

Applying lines to the score

Lines can be applied in the following ways:

Select a note and then double click one of the lines.

Select a range of notes by clicking on the first note and using Shift-click to select the last note.
Then double-click a line in the palette.

Select a range of notes by clicking on the first note and using Ctrl-click to select the last note.
Then double-click a line in the palette. This gives a shorter line than the previous selection.

Drag and drop a line from the palette onto the score.

Slurs can also be created using the hotkey S.

Change length

1. If you are in note input mode then press Esc

2. Double click the line that you want to change to enter edit mode

3. Move the handles using the following shortcuts:

Shift+→ to move the anchor right by one note (or measure)
Shift+← to move the anchor left by one note (or measure)

4. If you need to change the length visually without changing the notes or measures that the
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line is anchored to, then drag the handles with the mouse or use the following shortcuts:

→ to move the handle right by 0.1 sp (1 sp = one staff space = the distance between two
staff lines).
← to move the handle left 0.1 sp.
Ctrl+→ (Mac: Cmd+→) to move the handle right one sp.
Ctrl+← (Mac: Cmd+→) to move the handle right one sp.

Custom lines

You can customize any of the lines, including text if required, by editing them on the score page: right-
click on the line then chose Line Properties.... Save the result by dragging and dropping to a palette
in your custom workspace while holding down Ctrl+Shift (Mac: Cmd+Shift).

Measure rests

Full measure rest

When an entire measure is devoid of notes, a full measure (full bar) rest is used. A full measure rest
looks like a whole note (semi-breve) rest, except it is centered in the middle of a measure, and instead
of always being equal to four quarter beats it represents whatever the length of the measure is in the
current time signature.

To create a full measure rest, select a measure and press Del. All notes and rests in this measure are
then replaced by a full measure rest.

Multimeasure rest

Multimeasure (multi-bar) rests indicate a long duration of silence for an instrument and are frequently
used in ensemble sheet music. They are automatically interrupted at important points, such as double
barlines, rehearsal marks, key- or time signatures, etc.

The number above the multimeasure rest indicates the number of measures that the rest lasts for.

Instructions

1. From the menu, choose Style → General...
2. Click on the "Score" tab, if it is not already selected
3. Add a check mark next to "Create multimeasure rests"

Alternatively, press M on your keyboard to turn multimeasure rests on or off.

Limitations

The style option automatically combines empty measures into multimeasure rests throughout the
score. Therefore, it is recommended that you enter all your notes first and then turn on multimeasure
rests afterward.

Break multimeasure rest

See also: Measure operations: Break multimeasure rest

You may want to have a multimeasure rest divided into two multimeasure rests.

This option should be checked before turning on the "Create multimeasure rests" option in Style →
General..., in the "Score" tab.
Select the first measure where you want the second multimeasure rest to start, and do a right-click
Measure Properties → Break multimeasure rest.
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Note that multimeasure rests are interrupted if there is a rehearsal mark (not a simple text), section
break, key or time signature change, or double barline.

Repeat
The start and end of simple repeats can be defined by setting appropriate barlines. For instructions on
first and second ending measures, see Volta.

Playback

To hear repeats during playback, make sure the "Play Repeats"  button on the toolbar is
selected. Likewise, you can turn off repeats during playback by deselecting the button.

In the last measure of a repeat, you can set the property "Repeat count" to define the number of
played repeats.

Repeat symbols and text

Text and symbols related to repeats are located in the Repeats palette. This palette contains symbols
for measure repeat, segno and coda. It also contains 'D.S.', 'D.C.', 'To Coda', and Fine text:

To add a repeat symbol to the score:

Drag the repeat symbol from the palette onto (not above) the desired measure (so the measure
changes color), then drop, OR
Select a measure, then double-click the desired repeat symbol in the palette.

The object will appear above that measure in your score.

Jumps

Jumps generally consist of three parts:

Jump to tag
Play up to tag
Continue at tag

Tags are names you give to certain measure positions. Two tags ("start", "end") denote the start and
end of the score and don't need to get added explicitly.

Examples:

At the jump instruction Da Capo the playback jumps to the start and plays the entire score again (up
to the implicit end tag).

At the jump instruction Da Capo al Fine the playback jumps to the start and plays the score up to the
tag Fine.

Dal Segno al Fine (or D.S. al Fine) jumps to the Segno tag and then plays up to the tag Fine

Dal Segno al Coda jumps to the Segno tag and then plays up the first Coda tag. Playback then
continues at the second Coda tag. The properties of jumps can get set via a right-click at the D.S. al
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Coda tag.

See also

Volta
How to separate a coda from the rest of the score

External links

Video tutorial: Codas

Slur
A slur is a curved line between two or more notes that indicates they are to be played without
separation. If you mean to join two notes of the same pitch, see Tie.

A slur can be created from the lines palette, but the methods below are recommended.

First method

1. Make sure you are not in note input mode and select the first note that you want the slur to
cover:

2. S creates a slur:

3. Shift+Right extends the slur to the next note:

4. X flips the slur direction:

5. Esc ends edit mode:

Second method

1. Make sure you are not in note input mode
2. Select the note where you want the slur to start
3. Hold down Ctrl (⌘ on a Mac) and select the last note that you want the slur to cover
4. Press S

Note: If you Shift-select the last note, slurs will be added to all voices in the range after step 4.

Third method

1. While in note input mode, type in the first note in the slurred section
2. Hit S to begin the slurred section
3. Type in the remaining notes in the slurred section
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4. Hit S to end the slurred section

Adjustments

You can make fine adjustments to the size and shape of a slur by double-clicking it to enter edit mode,
clicking on any of the handles (displayed in the images for steps 2-4 above) and moving them with the
keyboard arrow keys. Larger adjustments can also be made by dragging the handles with a mouse or
other input device. The two outer handles adjust the start and end of the slur, whilst the two inner
handles adjust the contour. The Tab key can be used to move from handle to handle.

A slur can span several systems and pages. The start and end of a slur is anchored to a note/chord or
rest. If the notes are repositioned due to changes in the layout, stretch or style, the slur also moves
and adjusts in size.

This example shows a slur spanning from the bass to the treble clef. Using the mouse, select the first
note of the slur, hold down Ctrl (Mac: ⌘) and select the last note for the slur, and press S to add the
slur.

X flips the direction of a selected slur.

Dotted line

Dotted slurs are sometimes used in songs where the presence of a slur varies between stanzas.
Dotted slurs are also used to indicate an editor's suggestion (as opposed to the composer's original
markings). To change an existing slur into a dotted or dashed slur, select it and then in Inspector (F8)
change Line type from Continuous to Dotted or Dashed.

See also

Tie
Edit mode
Note input

Tie
A tie is a curved line between two notes of the same pitch, indicating that they are to be played as one
note with a combined duration (see external links, below). Ties are normally created between adjacent
notes in the same voice, but MuseScore also supports ties between non-adjacent notes and between
notes in different voices.

To create a tie:

First method

Select first note:

+ creates a tie:
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(+ or the tie button, , located on the top to the right of the notes in the note input toolbar)

Second method

To create ties during note input, press + or the tie button, , after the first note of the tie.

Flip a tie

X flips the direction of a selected tie, from above the note to below the note, or vice-versa.

Tied chords

To add ties between two chords, first make sure that you are not in Note input mode. Then either (i)
select the stem of the first chord, or (ii) Shift + click on the first chord, or (iii) Ctrl + click the desired

notes: then press + or the tie button, .

Tied unison notes

If the chords to be tied contain unison notes the best way to ensure correct notation is:

1. Assign each note of a unison pair to a separate voice.
2. Ensure that one of the unison pairs is set to "stemless" (to remove the duplicate stem and tail).
3. Apply the ties voice by voice. Make adjustments for position, length as required.

See also

Slur

External links

Ties (music) at Wikipedia

Time signature
Time signatures are available in the main palette sidebar (see Palette for general information on
working with palettes in MuseScore).
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Add a time signature to a score

Add a time signature

Drag and drop a time signature from a palette onto a space in a measure, OR
Select a measure and then double-click a time signature in a palette, OR
Select any note or rest and double-click a time signature in a palette.

The time signature will appear at the beginning of the measure in question.

Replace a time signature

Drag and drop a time signature onto an existing time signature, OR
Select a time signature in the score then double-click a time signature in a palette.

Create your own time signature

If a time signature is needed that is not found in the time signature palette, open the Master Palette
directly to the Time Signature section (Shift+T) to create your own. You can edit the numerator and
the denominator in the Create Time Signature Panel by pressing the Add button. Once added, just
drag and drop the time signature to the score from the window where you created it. Be aware that it
will not appear in the workspace palette. If you want to add it in the palette, read Custom Palette.

Change default beaming

To adjust beams from the automatic offering, you can click the notes you want to modify.

For example: by default 5/8 is beamed 3+2. You can click the third and then fourth note to beam it
2+3. Don't forget to do it for the other two subdivisions. To edit the third one drag an icon from 

 to the right note. In this example, the "beam start" icon got dragged to the 9th note
and the Beam 16th sub icon to the 13th note.
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Delete a time signature

Time signatures you don't need (any longer) can be removed in the above dialog box via right-click →
"Delete Content".

Edit to additive meters

In most cases, you'll only need to edit the first of the upper numbers. The additional upper numbers
are for additive meters, which contain multiple upper numbers separated by a plus sign.
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Different duration from time signature: Pickup measures (Anacrusis) and Cadenzas

There are occasions when the actual duration of a measure is different from the duration specified by
the time signature. Pickup measures and Cadenzas are a common example. To change the actual
duration of a measure without displaying a different time signature, see Measure operations:
Properties, Measure duration.

Local time signatures

Time signatures can be different for different staves. An example here is Bach's 26. Goldberg
Variation:

MuseScore has the concept of a global time signature and an actual (local) time signature. To change
the global time signature drag and drop a palette object to a staff. The global time signature is used to
count beats (as shown in the status line) and is the reference for tempo markings. The global time
signature is the same for all staves and normally identical to the actual time signature.

The actual time signature is set in the time signature property dialog and can deviate from the global
time signature for every staff (left hand 18/16 in the example).
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The text of the time signature can be set independent of the actual values.

A local time signature is set by dropping a time signature symbol while holding the Ctrl key. The local
time signature is set only for one staff. A global time signature is replicated for all staves.

Time signature changes and breaks

Multimeasure rests are interrupted when a time signature change occurs. Also, a section break will
prevent a courtesy time signature being shown at the end of the previous measure.

See also

Key signature

Transposition
Transposition moves a selection of notes higher, or lower on the staff. MuseScore supports several
kinds of transposition, including transposing instruments.

(See below for details)

Chromatic transposition, by key

Chromatic transposition moves selected notes up or down in semitone increments. From the main
menu, choose Notes → Transpose..., select which key signature to transpose - closest, up or down. If
no selection is made, transposition applies to the whole score.

Chromatic transposition, by interval

Chromatic transposition moves selected notes up or down in semitone increments. From the main
menu, choose Notes → Transpose.... Tick "By Interval", select the interval from the popup menus and
whether to transpose up or down. If no selection is made, transposition applies to the whole score.

You can also transpose a selection of notes using the arrow keys (↑ or ↓).

Diatonic transposition
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Diatonic transposition (also known as scalar transposition) moves notes up, or down the current scale
according to the key signature. You can move a single note by dragging it up, or down. You can move
a selection of multiple notes with Ctrl + click and drag.

Transposition shortcuts

F2 (Mac: fn+F2): Transpose score and key signature UP one semitone.
Shift+F2 (Mac: Shift+fn+F2): Transpose score and key signature DOWN one semitone.
Ctrl+↑ (Mac: Cmd+↑): Transpose selection UP one octave.
Ctrl+↓ (Mac: Cmd+↓): Transpose selection DOWN one octave.

You can also use Edit → Preferences → Shortcuts to set a convenient keyboard shortcut to open the
Transpose dialog box.

Transposing instruments

Certain instruments such as B-flat trumpet or E-flat alto sax are known as transposing instruments.
These instruments sound lower, or higher than their written pitch. MuseScore has built-in support for
transposing instruments.

The Concert Pitch button and Notes → Concert Pitch from the main menu lets you switch between
concert pitch and transposing pitch. Concert pitch helps composers and arrangers because it displays
every instrument in the same key, so the notes on the staff match their sounding pitches. When
concert pitch is turned off, the notes on some instrument staves may not match their sounding
pitches, but they are ready for an instrumentalist to play from. If you use concert pitch during your
session, remember to turn off concert pitch before printing the parts.

Change staff transposition

Instrument transpositions are already set up in MuseScore. However, if you want a rare instrument or
transposition that is not available in MuseScore, you may need to edit the instrument transposition
manually. Right-click an empty part of the instrument staff and choose Staff Properties.... At the
bottom of the Staff Properties window, you can select the interval of transposition, any octave shifts,
and whether the interval is "Up" (sounds higher than written) or "Down" (sounds lower than written).

External links

How to transpose (MuseScore How-To)
Concert pitch or not?? (forum discussion)

Tremolo
Tremolo is the rapid repetition of one note, or a rapid alternation between two or more notes. It is
indicated by strokes through the stems of the notes. If the tremolo is between two or more notes, the
bars are drawn between them. Tremolo symbols are also used to notate drum rolls.

The tremolo palette contains separate symbols for one note tremolos (shown with stems below) and
for two note tremolos (shown with no stem below).

To add tremolo to the stem of a single note, select the note head and double-click the desired symbol
in the tremolo palette.

In a two note tremolo, every note has the value of the whole tremolo duration. To enter a tremolo with
the duration of a half note (minim), enter two normal quarter notes (crotchets), and after applying a
tremolo symbol to the first note, the note values automatically double to half notes.

Tuplet
Tuplets are used to write rhythms beyond the beat divisions usually permitted by the time signature.
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For example, triplet eighth notes (quavers) in a 4-4 time signature divide the quarter note (crotchet)
beat into three instead of two.

Instructions

To create a triplet, first select a note on the score that specifies the full duration of the triplet group.
For example, a group of triplet eighth notes (quavers) has a "full duration" of one quarter note
(crotchet).

From the main menu, choose Notes → Tuplets → Triplet. This creates a triplet by dividing the full
duration into three equal parts.

They can be further edited.

Note input mode

Tuplet entry works slightly differently in note input mode than the method outlined above. You must
select the duration first, and enter pitches afterward. Below are step-by-step instructions for making
triplet eighth notes.

1. Switch to note input mode by pressing N
2. Make sure the note input marker is in the place that you want to start the tuplet (use the right

and left arrow keys if necessary)
3. Choose the duration for the whole tuplet group from the note input toolbar. For this example,

click on the quarter note (or press 5 on the keyboard)
4. From the main menu, choose Notes → Tuplets → Triplet, or press Ctrl+3 (Mac: ⌘+3)
5. Notice that an eighth note duration is automatically selected. Click on the staff to add pitches or

enter them via computer or MIDI keyboard

Properties

To change the display properties of a tuplet, select the tuplet number, or bracket, and use the
Inspector (F8).
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If neither the number nor the bracket is shown, select a note from the tuplet, then use the Tuplet
button in Inspector to see the above dialog.

For Direction, choose Auto to place the bracket on the same side of the note heads as the stem, or
beam. Choose Up, or Down to explicitly place the bracket above or below the note heads, respectively,
regardless of the stem, or beam position.

For Number type, choose Number to show an integer, Relation to show a ratio of two integers, or
Nothing to show no number at all.

For Bracket type, choose Automatic to hide the bracket for beamed notes and show the bracket if the
tuplet includes unbeamed notes or rests. Choose Bracket, or Nothing to explicitly show, or hide the
bracket, respectively.

If you move the bracket, or tuplet number, you can see vertical and horizontal offset being updated
(default offsets are 0sp for both).

You can restore default settings with the arrow return button on the right.

Style

Go to Style → General... and select Tuplets. It enables you to change all tuplet properties.
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Two adjustments are possible: Vertical and Horizontal

Vertical adjustment has three options with values in space units and one (un)ticked option
Maximum slope: default value is 0.50; range is from 0.10 to 1.00
Vertical distance from stem (see (2) below): default value is 0.25; range is from -5.00 to
5.00
Vertical distance from note head (see (3) below): default value is 0.50; range is from -5.00
to 5.00
Avoid the staves: by default ticked

Horizontal has four options with values in space units
Distance before the stem of the first note (see (5) below): default value is 0.50; range is
from -5.00 to 5.00
Distance before the head of the first note: default value is 0.00; range is from -5.00 to 5.00
Distance after the stem of the last note (see (6) below): default value is 0.50; range is from
-5.00 to 5.00
Distance after the head of the last note: default value is 0.00; range is from -5.00 to 5.00

See also

How to create triplets and other tuplets

External links
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Tuplet at Wikipedia
How To Create Triplets in MuseScore [video]
The User Guide to Tuplets in MuseScore [video]

Voices
Voices allow you to have notes on a single staff which start at the same time, yet have different
durations. Voices are sometimes called "layers" in other notation software. You can have up to 4
rhythmical independant voices per staff.

Note: The feature called "Voices" should not be confused with "vocal parts," which can be added from
the Instruments dialog (accessed by pressing I).

In a polyphonic measure, voice 1 usually takes the up-stem notes and voice 2 takes the down-stem
notes.

When to use voices

If you need stems pointing in opposite directions within a chord, on a single staff.
If you need notes of different durations within a single staff, played simultaneously.

Instructions

Start by entering the top voice (the up-stem notes in the image above). When inputting, some notes
may have down-stems, but these will flip automatically when the second voice is added.

If you are using a keyboard (computer or MIDI) to enter notes, use the ← key to move your cursor
back to the beginning of the staff (or measure). If you are using the mouse to position notes on the
staff, this is not necessary.

Click on the "Voice 2" button  (at the right in the toolbar).

Enter all the bottom voice notes (all the down-stem notes). When finished, it might look something like
this:

Note that you must be in Note input mode to select another voice.

Hidden spacer rests

Only the rests of voices 2, 3, and 4 can be deleted, but those of the main voice (1 - blue) can be
hidden.

To hide a rest, select it and press V or uncheck the "Visible" checkbox in the Inspector, which can be
enabled from the View menu or with the shortcut F8 (Mac: fn+F8). If you have Show Invisible turned
on in the View menu, the rest still shows in gray on your screen. The hidden rest will not appear if you
print, or export as PDF, PNG, SVG, etc.
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Exchange voices of notes

1. Select range of notes
2. Edit → Voices
3. Exchange any two voices

Note: The selection can encompass content of any voice, but only two will be processed at once.

See also

Shared noteheads

External links

How to merge/combine/implode two staves in one with two voices
Video tutorial: How To Write Two Parts On One Staff: Voices

Volta
Volta brackets, or first and second ending brackets, are used to mark different endings for a repeat.

To place a volta bracket on the score, drag-and-drop the item from the Lines palette, or select the
measure(s) you want the volta to span and double-click the palette icon.

To change the number of measures that a volta covers, double-click to enter edit mode and press
Shift+→ to move the end handle one or more measures to the right. You can also move the end
handle back one measure by pressing Shift+←.

These commands move the "logical" start or end of the volta bracket, which determines correct
playback in MuseScore and layout over multiple systems. Moving the handles using the mouse or
using the left or right arrows keys without Shift allows fine position adjustments, but does not
change how the repeat is played (and may cause playback or layout issues).

If you move the handles, a dashed line appears on the score from the logical position of the handle to
the adjusted position:

Text

You can change the text and many other properties of a volta bracket using the line properties dialog.
Right-click on a volta bracket and choose Line Properties.... The figure below shows the volta text
as "1.-5."
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You can also right-click on the volta and bring up the volta properties dialog. From here, you can
change both the displayed Volta text (the same from the line properties above) and the repeat list. If
you want one volta to be played only on certain repeats and another volta on other repeats, enter the
repeat times in a comma separated list. In the example below, this volta will be played during repeat
1, 2, 4, 5 and 7. Another volta will have the other ending, like 3, 6 and possibly other higher numbers
like 8, 9, etc.

Playback

Sometimes a repeat plays more than two times. In the figure above, the volta text indicates that it
should play five times before it continues. If you want to change the number of times MuseScore plays
a repeat, go to the measure containing the end repeat barline and change its Repeat count (see
Measure operations: Other properties for details).
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External links

MuseScore in Minutes, Lesson 8: Repeats and Endings, Part 1

Sound and playback
MuseScore has "Sound and playback" capabilities built-in. This chapter covers the playback controls
and ways to extend the instrument sounds.

MIDI import
MIDI import is tweakable via the MIDI import panel that appears at the bottom of the window every
time .mid/.midi/.kar files are opened in MuseScore. With this panel, the user gains finer control of the
processing by selecting tracks and applying operations to them (e.g. quantization, dots/ties usage,
etc.). The “Apply” button (at the top) submits any changes with immediate effect. The "Cancel" button
immediately cancels any unsaved changes.

Use Shift+Wheel or Ctrl+Wheel to scroll track options horizontally; scroll tracks vertically without those
modifiers.

The result should be a better quality score reproduction of the file.

The MIDI import panel shows a list of tracks (only tracks with note events are shown) and operations
available for each track.

If there are multiple tracks, then one more track is added at the top of the list to select all tracks at
once.

In the panel, one can select tracks for import and reorder them. Also some meta information is
displayed here (sound, staff name, and lyrics - if any). The presence of the lyric column is an
indication that the file contains a lyric track - assignable to different tracks through the drop-down list
available upon click.

Operations (at the right) are present as a pair: “name” - “value”. Each value is changeable and
clickable. It may be a combo or checkbox (list of available choices). A set of available options may
change from track-to-track, depending on its type (pitched or drum track).

The MIDI import panel updates the relevant information of whatever file is in view, if the user has
several open. If the MIDI import panel is no longer required, it can be closed by clicking the close
button in the top-left corner. The panel will re-appear after clicking on the button "Show MIDI import
panel" which appears right after the panel is closed.

Available operations

MuseScore instrument
Assign a MuseScore instrument (listed in instruments.xml or in specified custom xml file in
Preferences) that defines staff name, clef, transposition, articulations, etc.

Quantization

Quantize MIDI notes by some regular grid. The grid MAX resolution can be set via the drop-
down menu:

Value from preferences (default) - quantization value is taken from the main Preferences
dialog of MuseScore (in the “Import” tab)
Quarter, Eighth, 16th, 32nd, 64th, 128th - user-defined values
Actual quantization grid size is adaptive and reduces when the note length is small.

Max. voices
Sets maximum count of allowed musical voices.

87

https://www.youtube.com/watch?v=mHGZ47pwuB8
https://musescore.org/sites/musescore.org/files/MIDI_Import_Panel_en_1.png


Search tuplets
When enabled, this option attempts to detect tuplets and applies the corresponding quantization
grid to the tuplet chords.

Is human performance
If enabled, this option reduces the accuracy of MIDI-to-score conversion in favor of readability. It
is useful for unaligned MIDI files, when no regular quantization grid is provided. For such files the
automatic beat tracking algorithm is used which tries to detect the bar positions throughout the
piece.

2x less measure count
The option is active for unaligned MIDI files (when "Is human performance" is checked by
default). It halves measure count obtained in the internal beat tracking operation. It may be
convenient when the beat tracking gives 2x more frequent bar subdivision than necessary.

Time signature
The option is active for unaligned MIDI files. The user can choose an appropriate time signature
for the whole piece if the default detected value is wrong. The option is useful because it handles
imported tuplets correctly unlike the direct time signature setting from the palette.

Split staff
This option is suited mainly for piano tracks - to assign notes to the left or right hand of the
performer. It uses constant pitch separation (the user may choose the pitch via sub-options) or
floating pitch separation (depending on the hand width - sort of a guess from the program point
of view).
For drum tracks (“Percussion” sound in the track list) it splits the staff into multiple staves, each
of which gets only one drum pitch (i.e. drum sound). There is also a sub-option to allow/disallow
the application of the square bracket for the newly created set of drum tracks.

Clef changes
Small clefs can be inserted within a staff to keep chords closer to the 5 staff lines. Clef changes
depend on the average pitch of the chord. Tied groups of notes are not broken by the clef
insertion (if it occurs, one can report a bug for algorithm in importmidi_clef.cpp). This option is
available for non-drum tracks only.

Simplify durations
Reduces number of rests to form more "simple" note durations. For drum tracks this option can
remove rests and lengthen notes as well.

Show staccato
Option to show/hide staccato markings in the score.

Dotted notes
Controls whether MuseScore will use dotted notes or ties.

Show tempo text
Shows/hides tempo text markings in the score.

Show chord names
Shows/hides chord names in the score, if any, for XF MIDI file format.

Recognize pickup measure
When enabled, this option doesn't change the time signature of the first bar that is shorter than
the second bar. It is also called anacrusis. This option is applicable for all tracks at once only.

Detect swing
MuseScore tries to detect swing - to replace the triplet [4th + 8th] by two straight 8ths (for usual
swing, 2:1) or dotted 8th + 16th by two straight 8ths as well (for shuffle, 3:1). It also prints
“Swing” or “Shuffle” at the beginning of the staff with swung notes.

Mid-staff instrument change
Instrument change text (known as "Instrument" in the Text palette) can be used to indicate a change
in the instrument that plays on a specified staff, and the change is accurately reflected in the playback.
A current limitation, however, is that transposition is not affected.

Insert a mid-staff instrument change

1. Select the start point of the change

2. Apply "Instrument" from the Text palette
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3. Double-click the newly added text to edit it

Note that you can also format your text

or edit the Text Properties with a right-click after leaving text edit mode (your text should be black and
not brilliant blue) or apply a Text Style (which will apply the same changes to all Change Instrument
text globally).

1. Right-click the text and choose "Instrument Change…"

2. Choose the instrument, then click OK

89



See also

Change instrument
Mid-staff sound change

Play mode
MuseScore has an integrated sequencer and Synthesizer to play your score.

By pressing the Play  button, you enter Play mode. In Play mode, the following commands are
available:

Seek to previous chord ←
Seek to next chord →
Seek to previous measure Ctrl+← (Mac: Cmd+←)
Seek to next measure Ctrl+→ (Mac: Cmd+→)
Rewind to start of score Home (Mac: ⌘+Home)
Toggle show play panel F11 (Mac: ⌥+⌘+P)

Press the play button again to stop and exit Play mode.

MuseScore starts playback from the place it last left off. If you select a note, MuseScore plays from
there instead. The toolbar also has a rewind button to quickly return to the beginning of the score for
playback.

To include playback of repeats, activate the  Enable/Disable Repeats-Button.

Play panel

The Play Panel offers more controls over playback, including tempo, starting-ending position, and
general volume for the current session (none of this is saved into the score). From the main menu,
choose View → Play Panel to open it.

Note: You can set the default volume via the Synthesizer (View → Synthesizer).

Count in

You can switch on and off a count-in to be played each time the playback starts. The count-in plays
beats for a full measure (according to nominal time signature at playback starting point); if the starting
point is mid-measure or at a 'short' measure (anacrusis), it also plays enough beats to fill that
measure. The conductor icon in the play panel enables, or disables count-in.

Metronome playback

You can also switch on/off the accompanying metronome as the score is played (see the metronome
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icon on the play panel).

Loop

You can repeat playback of a passage. Use the three buttons at the bottom of the play panel to set
start and ending position first, then play the loop. The loop can also be toggled with a button in the
main toolbar of MuseScore.
Loop start and end will show a blue flag pointing right and left, respectively.

SoundFont

Overview

A SoundFont file is a special type of file that contains many samples of different instruments playing
different notes, enabling MuseScore to play each instrument sound. Some SoundFonts are custom
designed for classical music, others are designed for jazz, pop, etc. Many SoundFonts are available
on the web. Look for one that covers the 128 sounds of General MIDI (GM). If you use a SoundFont
that does not conform to the General MIDI standard, others may not hear the correct instruments
when you share the score or export a MIDI file. MuseScore 0.9.6 – 1.3 featured a very light-weight
SoundFont called TimGM6mb.sf2, while MuseScore 2 comes with the much more realistic
FluidR3Mono_GM.sf3.

The file size and sound quality of SoundFonts available on the web varies. Larger SoundFonts often
sound better but take up a lot of memory and may be too large to run on your computer. If you find
MuseScore runs slowly after installing a large SoundFont, or your computer can't keep up during
playback, then look for a smaller SoundFont.

Once a SoundFont has been installed, you can use it for playback in MuseScore (and control other
aspects of the sound output) with the Synthesizer. To display the Synthesizer, go to View →
Synthesizer.

Install a SoundFont

After finding and decompressing a SoundFont (see →below), double-click to open it. In most cases,
the SoundFont file type will already be associated with MuseScore, and MuseScore will start and a
dialog will appear asking if you want to install the SoundFont. Occasionally an application other than
MuseScore will be associated with the SoundFont file type; if this is the case, you will need to right-
click or control-click on the file, so as to display a menu from which you can choose to open the file in
MuseScore. In either case, when the dialog appears asking if you want to install the SoundFont, click
"Yes" to place a copy of the SoundFont file in MuseScore's SoundFonts directory. This directory can
be viewed or changed in MuseScore's Preferences, but the default location is:

Windows: %HOMEPATH%\Documents\MuseScore2\Soundfonts

Mac OS X and Linux: ~/Documents/MuseScore2/Soundfonts

In contrast to user-added SoundFonts, the initial default SoundFont installed with MuseScore is
located in a system directory, meant only for that purpose, which should not be modified. This
directory and its default SoundFont file is:

Windows (32-bit): %ProgramFiles%\MuseScore 2\sound\FluidR3Mono_GM.sf3

Windows (64-bit): %ProgramFiles(x86)%\MuseScore 2\sound\FluidR3Mono_GM.sf3

Mac OS X: /Applications/MuseScore 2.app/Contents/Resources/sound/FluidR3Mono_GM.sf3

Linux (Ubuntu): usr/share/sounds/sf2/FluidR3Mono_GM.sf3

Uninstall

To uninstall a SoundFont, simply open the folder where the SoundFont is installed and delete it.

Synthesizer

The Synthesizer is MuseScore's central control panel for sound output. Once a SoundFont has been
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installed, it needs to be loaded into the Synthesizer in order for MuseScore to use it for playback. To
display the Synthesizer, go to View → Synthesizer. For more details, see Synthesizer.

List of SoundFonts

Below are some popular GM SoundFonts of different sizes.

Fluid R3 GM (141 MB uncompressed)
License: released under the MIT license (included in the archive)
GeneralUser GS (29.8 MB uncompressed)
Courtesy of S. Christian Collins
Magic Sound Font, version 2.0 (67.8 MB uncompressed)
Arachno SoundFont, version 1.0 (148MB uncompressed)
Courtesy of Maxime Abbey
MuseScore version 1.x shipped with TimGM6mb (5.7 MB uncompressed)
License: GNU GPL, version 2
Courtesy of Tim Brechbill
MuseScore version 2.0 is shipped with the SoundFont FluidR3Mono_GM.sf3 (12.6 MB).
License: released under the MIT license
Timbres of Heaven, version 3.2 (369 MB uncompressed)
Courtesy of Don Allen

In addition to SoundFont files, MuseScore also has some support for the SFZ format, thanks to the
new synthesizer Zerberus. Here are some SFZ sound banks:

Sonatina Symphonic Orchestra (503 MB uncompressed)
Downloads: SoundFont | SFZ format
License: Creative Commons Sampling Plus 1.0
Salamander Grand Piano, version 3 (between 80 MB and 1.9 GB uncompressed)
License: Creative Commons Attribution 3.0
Salamander Grand Piano, version 2 (between 80 MB and 1.9 GB uncompressed)
License: Creative Commons Attribution 3.0
Detuned Piano (244 MB uncompressed)
License: Creative Commons Attribution-ShareAlike 3.0
Plucked Piano Strings (168 MB uncompressed)
License: Creative Commons Attribution-ShareAlike 3.0

Specialized SoundFonts

Acoustic grand piano, release 2008-09-10 (132 MB uncompressed)
Description: Yamaha Disklavier Pro piano, sf2 format, 116 samples, 44100Hz, 16bit
More information: http://zenvoid.org/audio/
License: Creative Commons Attribution 3.0
Courtesy of Roberto Gordo Saez
Acoustic grand piano, old version (37.5 MB uncompressed)
Description: Steinway & Sons, sf2 format, 13 samples, stereo, 44100Hz, 16bit (based on the
University of Iowa Musical Instrument Samples)
More information: http://zenvoid.org/audio/
License: Public domain
Courtesy of Roberto Gordo Saez

Note: Since SoundFont files are large, they often are compressed into a variety of formats, including
.zip, .sfArk, and .tar.gz. You need to decompress these files before they can be used.

92

https://musescore.org/en/handbook/synthesizer
https://musescore.org/sites/musescore.org/files/Synthesizer_en_2.png
http://www.musescore.org/download/fluid-soundfont.tar.gz
http://schristiancollins.com/soundfonts/GeneralUser_GS_1.442-MuseScore.zip
http://schristiancollins.com/generaluser.php
http://www.personalcopy.com/sfarkfonts1.htm
http://www.arachnosoft.com/main/download.php?id=soundfont-sf2
http://www.arachnosoft.com
http://sourceforge.net/p/mscore/code/HEAD/tree/trunk/mscore/share/sound/TimGM6mb.sf2?format=raw
http://ocmnet.com/saxguru/Timidity.htm#sf2
https://github.com/musescore/MuseScore/raw/master/share/sound/FluidR3Mono_GM.sf3
https://github.com/musescore/MuseScore/blob/master/share/sound/FluidR3Mono_License.md
http://midkar.com/soundfonts/
https://musescore.org/en/node/20818
http://prereleases.musescore.org/soundfont/Sonatina_Symphonic_Orchestra_SF2.zip
http://sso.mattiaswestlund.net
http://freepats.zenvoid.org/Piano/
http://download.linuxaudio.org/lau/SalamanderGrandPianoV2/
http://download.linuxaudio.org/musical-instrument-libraries/sfz/detuned_piano.tar.7z
http://download.linuxaudio.org/musical-instrument-libraries/sfz/plucked_piano_strings.tar.7z
http://freepats.zenvoid.org/Piano/YamahaDisklavierPro-GrandPiano.tar.bz2
http://zenvoid.org/audio/
http://freepats.zenvoid.org/sf2/acoustic_grand_piano_ydp_20080910.txt
http://freepats.zenvoid.org/sf2/acoustic_piano_imis_1.sf2
http://theremin.music.uiowa.edu/MIS.html
http://zenvoid.org/audio/
http://freepats.zenvoid.org/sf2/acoustic_piano_imis_1.txt


ZIP is standard compression format supported by most operating systems.

sfArk is a compression format designed especially for compressing SoundFont files. Use the
special sfArk software to decompress it.

.tar.gz is a popular compression format for Linux. Windows users can use 7-Zip; Mac users can
use The Unarchiver, or Mac OS X's built-in Archive Utility. Note that if using 7-Zip, you will need
to apply decompression twice—once for GZip and once for TAR.

Troubleshooting

If the toolbar play panel is greyed out, or not visible, follow the instructions below to get your sound
working again:

Do a right-click on the menu bar and make sure there is a check mark next to the Transport
Tools menu item. You can add or remove the check mark by clicking on the corresponding menu
item. If this step does not solve your problem, continue below.
If the play panel disappears after changing the SoundFont, go to Edit → Preferences... → I/O
tab and click OK without making any changes. After restarting MuseScore, the play panel should
reappear.

If you are setting up a SoundFont for the first time, please use one of the recommended SoundFonts
listed above.

If playback stutters, then your computer is not able to handle the SoundFont being used. Two
solutions:

1. Reduce the amount of RAM (memory) used by MuseScore by using a smaller SoundFont. See
list above for suggestions.

2. Increase the amount of RAM available for MuseScore by quitting all applications except
MuseScore. If you still have problems and a large SoundFont is important to you, consider more
RAM for your computer.

See also

Synthesizer
Change and adjust sounds

External links

How to change the SoundFont or add another

Swing
MuseScore is capable of playing back a score using swung eighth notes or swung sixteenth notes.

Set up swing

The recommended way to inform MuseScore (and the humans who will read your music) that a swing
feel is intended is to create a Swing System Text element.

1. Click the first note

2. Double-click Swing in the Text palette

The Swing text can be edited, like any other text element, by double-clicking it (see Text editing), and
it can be made invisible using the Inspector.
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Return to straight rhythm

If you have a score containing both "swing" and "straight" sections, and want this reflected in
playback:

1. Insert a Swing text item as explained above, attached to the first note or rest of the "straight"
section.

2. Change the text as desired—double-click on the item you just inserted and change it to "Straight"
(see Text editing).

3. Turn swing off via right-click → System Text Properties… → Swing Settings → off

Swing settings

Swing text settings

Swing settings for an individual Swing text marking are available via right-click → System Text
Properties… → Swing Settings. This allows you to define how heavily to swing (i.e., the ratio of the
downbeat to upbeat), and whether it's the eighth note or the sixteenth note that is swung.

Global swing settings

By default, in the absence of a Swing text element, swing playback is turned off. To turn on swing
playback without adding a text element, use the general (score-wide) swing settings in Style →
General... → Score.

Synthesizer

Overview

The Synthesizer is MuseScore's central control panel for sound output. Among other things, it lets
you load SoundFonts with different-sounding instruments to use for playback, control equalization and
volume levels, and change other aspects of the sound output.

To display the Synthesizer, go to View → Synthesizer.

Only one set of Synthesizer settings can be in effect at a time—i.e., if multiple scores are open at
once, it is not possible to make changes to the Synthesizer in one score and leave other scores'
settings untouched. Additionally, changes to the Synthesizer's settings apply to the current
session only—the next time MuseScore is opened the Synthesizer will revert to its default
settings. Those defaults can be changed, however, at any time—click the Set as Default button in
the Synthesizer to make the current settings the new default for subsequent sessions.

It is also possible to save settings to an individual score and recall those settings later, with the Save
to Score and Load from Score buttons. Synthesizer settings saved to a score will not be recalled
automatically upon opening that score; it is necessary to manually indicate that the score's
settings should be loaded with the Load from Score button.

Changes made in the Synthesizer will not be heard in exported audio files unless the
Synthesizer settings have been saved to the score with the Save to Score button.

A precise breakdown of the options is given a closer look with the example of Tuning (below).

SoundFont

A SoundFont is a file containing a set of sounds that MuseScore can use for playback. MuseScore
comes with a SoundFont called FluidR3Mono_GM.sf3; other SoundFonts can be downloaded from the
internet (see this list of SoundFonts). Once a SoundFont has been installed, you can select it to be
used for playback and control other aspects of the sound output with the Synthesizer.

By default, the SoundFont FluidR3Mono_GM.sf3 should be loaded in the Synthesizer:
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Click the Add button to load another installed SoundFont from the SoundFonts directory.

Note: If you have not installed any other SoundFonts, then there will not be any SoundFonts available
to load. To use a SoundFont for playback, it needs to be first installed (which is a one-time action) and
then loaded in the Synthesizer (which can be done on a case-by-case basis, or set up permanently).

A loaded SoundFont can be removed from the Synthesizer (but not uninstalled) by selecting it in the
list and clicking Delete, and if multiple SoundFonts are loaded their order can be rearranged with the
Up and Down buttons.

If you have not changed any sounds in the Mixer, then the SoundFont at the top of the list is the one
that will be used for playback. However, if you are using the Mixer to play different instruments with
sounds from different SoundFonts, playback will only work correctly if you have the same SoundFonts
loaded in the same order in the Synthesizer. Therefore, if you are using multiple SoundFonts, it is
advised to click the Save to Score button in the Synthesizer, so that the next time you open that score
you can recall the list of SoundFonts loaded (and other Synthesizer settings) with the Load from Score
button.

Optionally, you can use the Set as Default button to change the default Synthesizer settings so you
won't have to load the settings from a score the next time. Otherwise, the Synthesizer will be in its
original default settings in your next session with MuseScore.

Volume

At the right in the Synthesizer are two sliders. One controls the playback volume, the other controls
the volume of the optional built-in metronome. As with all the rest of the Synthesizer controls, any
changes made here are temporary unless saved to the score or set as the new default.

Effects

In the Master Effects tab of the Synthesizer it is possible to access advanced playback options such
as reverb and equalization controls. By default, an effect called "Zita1" is turned on, which aims to
increase the realism of the sound output. It can be disabled by setting "Effect A" to "NoEffect". To
permanently turn off the effect (and permanently apply all other current Synthesizer settings), click Set
as Default.
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Tuning

For Concert Pitch instruments, MuseScore uses the A4 = 440Hz pitch standard by default. To change
it, simply enter a new value in the Tuning tab of the Synthesizer.

Like all other Synthesizer settings, the master tuning affects playback within MuseScore but does not
affect exported audio files (WAV, OGG, MP3) unless the Save to Score option is selected.

Change master tuning

Notes: Applies to all scores. Current session only (tuning resets to default on MuseScore exit). Affects
playback but doesn't affect exported audio files (WAV, OGG, MP3, and MIDI).

1. View → Synthesizer.
2. Click the Tuning tab.
3. Enter a new Master Tuning value (Default 440Hz).
4. Click Change Tuning.

Set default tuning

Note: Applies to all scores. Current session and all subsequent sessions (until you change it again).
Affects playback but doesn't affect exported audio files (WAV, OGG, MP3, and MIDI).

1. Change the Master Tuning as shown above for the current session.
2. Select Set as Default.

Change tuning for an individual score

Note: Applies to current score for current session, and settings can be recovered in subsequent
sessions with Load from Score. Affects playback and exported audio files (WAV, OGG, MP3).

1. Change the Master Tuning as shown above for the current session.
2. Click Save to Score.
3. You will now get this new tuning in exported audio files of the current score, but other scores will

export with the default tuning as expected. However, due to a limitation in MuseScore, you need
to click Load from Score to get the correct tuning on playback.

See also
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SoundFont
Mixer

Tempo
Tempo markings can be added to a score in the form of tempo text. Playback tempo can also be
manually overridden temporarily through the Play Panel.

Tempo text

Tempo markings are used to indicate the pace of the music to the person reading the score, and they
are also reflected in playback. It is possible to have multiple tempo markings at different points
throughout a score.

To add a tempo marking:

1. Select the note or rest where the tempo should be added.
2. Open the Tempo palette and double-click a tempo marking style to add it to the selected note or

rest. Alternatively, you can drag-and-drop a tempo from the palette directly onto a note or rest.
You can also add a tempo from the main menu with Add → Text... → Tempo Marking, but you will
not be able to choose what note value the tempo will be created with.

Existing tempo markings can be changed by double-clicking the text to enter text edit mode.

A tempo marking's beats per minute can be changed by directly editing the text, if "Follow text" is
selected in the Inspector and the tempo text is expressed in the form "note duration = number", as in
this example, which includes the information "quarter note = 75":

If a tempo marking has been edited and no longer includes that information (for example, simply the
word "Andante" with no number associated with it), click once on the marking to select it. Uncheck the
"Follow text" checkbox in the Inspector, and you can manually set the number of quarter note beats
per minute that the tempo marking represents.

Note: Playback may be faster or slower if the tempo setting in the play panel is at a percentage other
than 100%.

Gradual tempo changes like ritardando ("rit.") and accelerando ("accel.") can be added to the score
as system text, but currently don't have any effect on playback.

Play panel

Display the play panel: View → Play Panel or F11 (Mac: fn+F11)
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Change the percentage of the score's actual tempo using the Tempo slider

This setting is not saved in the score and will proportionally override all tempo markings set in the
score. If you have multiple tempo markings in the score, the BPM (Beats per Minute) number
displayed above the slider will depend on where in the score you are. For example, if you have a
tempo of 80 BPM set, and the Play Panel is set to 120% of tempo, the actual tempo of the playback
will be 96 BPM, which you can tell by the number displayed above the percentage in the Play Panel.

Dynamics
Playback volume can be changed for the entire piece by the play panel, or locally by Dynamics text in
the score.

Dynamics text

From the Dynamics palette, drag a dynamic onto a note in the score. Alternatively, you can
select a note in the score and double-click a dynamic in the palette.

To mark crescendo and decrescendo, see Hairpin.

For additional dynamics use the Master Palette (ShiftF9). You can also create a custom palette
for future use.

Adjusting playback volume for a dynamic

Click on the dynamic to select it and adjust the "Velocity" number in the Inspector—higher for louder,
lower for softer. If the Inspector is not present, go to View-> Inspector or press F8 (Mac: fn+F8).

Play Panel

Display the Play Panel: View → Play Panel
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Change the Volume using the slider

External links

Video tutorial: Lesson 10 - Articulations, Dynamics and Text

Change and adjust sounds

Mixer

The Mixer allows you to change instrument sounds and adjust the volume, panning, reverberation,
and chorus for each staff. From the main menu, choose View → Mixer or hit F10 (Mac: fn+F10) to show
the mixer.

Mute and Solo

Use the Mute check box to quickly silence certain staves. Alternatively, use the Solo check box to
silence all staves, except the staff you mark as "solo".

Dials

To turn a dial clockwise, click and drag upwards. To turn a dial counter-clockwise, click and drag
downwards.

Sound
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The sound drop-down menu lists every instrument supported by your current SoundFont. If you have
multiple SoundFonts loaded in the Synthesizer, all the patches from all the SoundFonts will appear in
a single long list—all the sounds available from the second SoundFont appearing after all the sounds
from the first SoundFont, and so on.

Change instrument

You can change a staff to be a different instrument. The following method updates instrument sound,
staff name, and staff transposition all at once.

1. Right-click on an empty part of the measure OR on the instrument name and choose Staff
Properties...

2. Click on Change Instrument (button on the right)
3. Choose your new instrument and click OK to return to the Staff Properties dialog
4. Click OK again to return to the score

Not to be confused with Mid-staff instrument change.

Mid-staff sound change (pizz., con sordino, etc.)

Some instruments can change sounds midway in a score. For example, strings may utilize pizzicato,
or tremolo, whilst trumpet can switch to muted trumpet.

The following instructions use pizzicato strings as an example, but the same principles apply to
tremolo strings or muted trumpet.

1. Select the first note of the section you want to be pizzicato
2. From the main menu, choose Add → Text → Staff Text
3. Type Pizz. At this point, this text is a visual reference only and not applied during playback
4. Right-click on the staff text and select Staff Text Properties...
5. In the Staff Text Properties dialog, select one or more voices on the left (in the Change

Channel tab)

6. From the dropdown menu, select pizzicato

7. Click OK to return to the score

Every note after the staff text you added now sounds pizzicato. To return to a normal strings sound
later in the piece, follow the same guidelines as above except type Arco in step 3 and select normal in
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step 6.

See also

SoundFont
Synthesizer
How to change instrument sound (e.g. pizz., con sordino) midway through score

Text
There are many types of text available in MuseScore: Lyrics, Chord symbols, Dynamic markings,
Fingerings, Figured bass, Tempo, Rehearsal marks, and many more. Many of these are accessible
from the main menu via Add → Text; others can be found in the Palettes.

For short generic text, use Staff Text or System Text. The difference between these two types of text
is whether you want it to apply to a single staff, or the whole system. This matters when extracting
parts: staff text will only appear in a part that contains the specific instrument the text is attached to,
while system text will appear in all parts. Additionally, if you choose to hide empty staves, any staff text
belonging to an empty stave will also be hidden. System text is never hidden by the "hide empty
staves" feature.

Staff text

Staff text is general purpose text associated with a particular staff at a particular location in the score.
To apply, choose a location by selecting a note or rest and then use the menu option Add → Text →
Staff Text, or use the shortcut Ctrl+T (Mac: ⌘+T). A small text box appears and you can immediately
start typing. You can exit the text box at any time (even without typing anything) by pressing Esc.

Staff text can, for example, be used to apply indications such as "Solo" or "Pizzicato" to one staff in a
score. Depending on what the instructions of the staff text are, MIDI playback of that staff at the text
location can be altered to match the instructions by right-clicking on the staff text and selecting Staff
Text Properties…. See How to change instrument sound (e.g. pizz., con sordino) midway through
score.

System text

System text is used when you wish to apply text indications to a whole system rather than just to one
staff line. This makes a difference when extracting parts, or if you choose to hide empty staves. To
apply, chose a location by selecting a note or rest and then use the menu option Add → Text → System
Text, or use the shortcut Ctrl+Shift+T (Mac: ⌘+Shift+T). A small text box appears and you can
immediately start typing. You can exit the text box at any time (even without typing anything) by
pressing Esc.

See also

Text style
Text editing
Text Frame
Mid-staff instrument change
Header/Footer

Grid-based movement of symbols and staff text
When selecting and dragging an element, pressing either Shift or Ctrl will move the selected
element only in one direction. Pressing Ctrl moves an element horizontally, whereas Shift moves it
vertically.

Also in Inspector you can toggle the 'Enable snap to grid' buttons, resulting in the moves being in
steps of a certain space fraction (the same steps as if using the scroll button in Inspector)

Rehearsal marks
Rehearsal marks are often used in scores, especially new ones. They enable musicians to start at the
same place, not having to count measures (rehearsal marks could point to measure numbers though),
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and are generally more visible. They are typically a set of consecutive letters or numbers: A, B, C, or
1, 2, 3...

How to create them

1. Click on the first note or rest at the start of a rehearsal section, on the top staff generally
2. Add → Text → Rehearsal Mark or Ctrl+M or Palette → Text → Rehearsal marks
3. Type the text of your Rehearsal Mark
4. Click elsewhere

Properties

Rehearsal marks are by default system text. They will appear on every part and on the score.
They also automatically break multimeasure rests before and after the rehearsal marks.
Text style is specific by default (Rehearsal marks), and they are framed by default.

Automatic next rehearsal mark

A rehearsal mark added from the text palette will automatically be labeled with the next letter or
number.

Search for a rehearsal mark

You can navigate to a given rehearsal mark with Ctrl+F and the name of the rehearsal mark.

See also

Text properties

Text editing

Text edit mode

Double-click on a piece of text to enter text edit mode:

In text edit mode, the following commands are available:

Ctrl+B (Mac: ⌘+B) toggles bold face
Ctrl+I (Mac: ⌘+I) toggles italic
Ctrl+U (Mac: ⌘+U) toggles underline
Home End ← → ↑ ↓ moves cursor
Backspace (Mac: Delete) remove character to the left of the cursor
Delete (Mac: → Delete or fn+Delete) remove character to the right of the cursor
Return start new line
F2 (Mac: fn+F2) Insert special characters (see below)

Symbols and special characters

You can use Special Characters to insert quarter notes, fractions, and many other kinds of special

symbols or characters into your text. In the text toolbar, click on the keyboard icon, , or hit F2
(Mac: fn+F2) to open the Special Characters dialog.
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Double-clicking an item in the Special Characters dialog immediately adds it to the text where the
cursor is positioned. Multiple items can be applied without closing the dialog box, and the user can
even continue to type normally, delete characters, enter numerical character codes etc., with it open.

Note that it is not possible to display the Special Characters dialog when not in text editing mode, and
this should not be confused with the menu item of the same name in the Mac OS X version of
MuseScore.

See also

Chord symbol
Lyrics
Frame
Edit mode

Text style

Text styles and text properties

Every piece of text has a basic style. Title text, for example, is centered and uses a large font size;
Composer text is smaller and aligned to the right within the top vertical frame. To edit text styles, go to
Style → Text..., or right-click on some text and select Text Style...

Changes to a text style will affect all text that uses that style within a score.

You can also edit the same parameters as are available with a text style by right-clicking on a piece of
text and selecting Text Properties...

Unlike changes to a text style, changes to text properties only apply to the single specific piece
of text you right-clicked on. The text style for the rest of the score remains unchanged, and
other text using the same style is unaffected.

During text editing you can make changes that depart from the basic style and may also differ from the
specific text properties of a given piece of text. You can revert changes made through text editing
(such as font size and italics) with the reset text to style option.
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The available options are divided into categories:

Text
Font: name of the font such as "Times New Roman" or "Arial"
Size: size of the font in points
Style: style of the font, italic, bold, underline
Color: click on the color demonstrated to change
Size follows "Staff space" setting: whether size follows the distance between two lines in
a 5-lines standard staff
System flag: text applies to all staves of a system.

Offset
Horizontal
Vertical
Offset Unit: in mm or Staff space units

Alignment
Horizontal: left, right, center
Vertical: align top edge of text to reference point, center text vertical to reference point,
center text vertical to text baseline or align bottom edge of text to reference point

Frame

Frame: add a frame around the text
Frame Type: Circle or Box
Border thickness: thickness of the line of the frame in space units
Border radius: for box frame, radius of rounded corner
Text margin : inner frame margin in space units
Foreground color: of the frame border
Background color: of the background within the frame.

Note: Opacity is set by the parameter "Alpha channel" in the colors dialog: a value between 0,
transparent, and 255, opaque.

Text types

Title, Subtitle, Composer, Poet: anchored to page
Fingering: Fingerings are anchored to note heads.
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Lyrics: Lyrics are anchored to a time position (a note/chord, but not a rest).
Chord symbol: Chord symbols are anchored to a time position.
System text: Applies to all staves in a system. Anchored to a time position.
Staff text: Applies to a single staff in a system. Anchored to a time position.

The distinction between system text and staff text matters for part extraction in ensemble scores.
System text will extract to all parts. Staff text will only extract to the part to which it is anchored. For
details, see Text.

Create a new text style

1. Go to Style → Text... or right-click on some text and select Text Style...
2. Click on New
3. Set a name
4. Set all properties

This will be saved along with the score, which also means it won't be available in another score.

Apply options

You can apply to either the score or part you are seeing, if you hit Apply and then OK.
If you are in one of the parts of your score, you also have the option to use the Apply to all parts
button before OK, so you don't have to manipulate all parts individually.

Reset text to style

If you have made changes to an individual piece of text and you want to return it to the defined text
style for the score, or if you changed the style with an old version of MuseScore and you want the
style to correspond to the default text style in MuseScore 2, you can use the Reset Text to Style
option.

Select the text you want to reset to style and click on Reset Text to Style in the Inspector. If you need
all text from a given style to be "reset", right-click on one, then from the context menu choose
Select → All Similar Elements first.

See also

Text editing
Header/Footer

Chord symbols
Chord symbols can be entered by first selecting a note and then pressing Ctrl+K (Mac: ⌘+K). This
creates a chord symbol text object for the selected chord.

Space moves to the next note or beat.
Shift+Space moves to the previous note or beat.
Ctrl+Space (Mac: ⌘+Space) adds a space to the chord name.
; moves to the next beat.
Shift+; moves to the previous beat.
Tab moves to the next measure.
Shift+Tab moves to the previous measure.
Esc exits chord symbol edit mode

Chord symbols can be edited as normal text. To add a sharp, type #. To add a flat, type b. To add a
double-sharp type x or ##, and to add a double-flat type bb. These characters will automatically turn
into proper sharp or flat signs when you complete entry. Do not try to use actual flat and sharp signs,
MuseScore will not understand those properly.
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Chord symbol syntax

MuseScore understands most of the abbreviations used in chord symbols:

major: M, Ma, Maj, ma, maj, Δ (type t or ̂ )
minor: m, mi, min, -
diminished: dim, o (the lower case letter)
half-diminished: ø (type 0, zero)
augmented: aug, +

Note that for half-diminished chords, you can of course also enter abbreviations like mi7b5 and they
will be rendered that way instead of using the ø.

You can also use extensions and alterations like b9 or #5, sus, alt, and no3. You can indicate
inversions and slash chords using notations like C7/E. You can use parentheses and commas within
chord symbols, and you can also enclose an entire chord symbol in parentheses.

Chords symbol style

The chord symbols use the Chord Symbols text style, so you can change font using the controls
described in Text style. There are also style settings found in Style → General... → Chord Symbols,
Fretboard Diagrams. These options are described in this section.

Appearance

MuseScore supports two primary styles of chords symbols: Standard and Jazz. You can select
between these using the radio buttons.

In the Standard style, chords are rendered simply, with the font determined by your chord symbol text
style.

In the Jazz style, the MuseJazz font is used for a handwritten look, and superscript and other
formatting techniques are used as well.

The Jazz style is selected by default if you use any of the Jazz templates.

The third radio button is mostly for compatibility with older scores. You can also use it to specify your
own custom chord descriptions files. These can be created by copying one of the standard files and
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reading the documentation within them on their structure. However, this is for advanced users only,
and there is no guarantee these files will be supported in the future.

Note spelling

By default, MuseScore uses letter names for chord symbols. For users in regions where other note
naming schemes are used, MuseScore provides the following controls:

Standard: A, Bb, B, C, C#,...
German: A, Bb, H, C, C#,...
Full German: A, B, H, C, Cis,...
Solfeggio: Do, Do#, Reb, Re,...
French: Do, Do#, Réb, Ré,...

In addition, there are options to control capitalization. By default, MuseScore automatically capitalizes
all note names as shown above, whether you originally enter those using capital or lower case letters.
However, you can also choose other automatic capitalization options:

Lower case minor chords: c, cm, cm7,...
Lower case bass notes: C/e,...
All caps note names: DO, RE, MI,...

You can also turn off the automatic capitalization completely, in which case note names are simply
rendered the way you type them.

Positioning

The positioning information in the text style is honored normally, so you can have text alignment and
horizontal/vertical offset there if desired. However, there are also positioning controls here in this
dialog:

Default vertical position: height above staff (use negative values)
Distance to fretboard diagram: if fretboard diagram present, height above the diagram
Minimum chord spacing: space to leave between chord symbols
Maximum barline distance: space to allow before barline
Capo: specify capo setting; correspond chords are automatically displayed in parentheses

See also

How to create stacked chord symbols

Fingering
Fingering can be added to notes by dragging a fingering character from the fingering palette to a note
head in the score. When a note head is selected first, the fingering character can be added using a
double-click. Fingerings are normal text, which can be edited like any other text.

See also

How to position the fingering

Lyrics
1. First enter notes
2. Select first note
3. From the main menu, choose Add → Text → Lyrics or type Ctrl+L (Mac: ⌘+L) and type the

syllable for the first note
4. Continue entering lyrics:

107

https://musescore.org/en/node/30501
https://musescore.org/en/node/27051


Type Space at end of a word to go to the next note
Type a hyphen - at end of syllable to go to next note. The syllables are connected with a
dash
Shift+Space moves to the previous syllable
↵ moves down to the next lyric line (Note: not the Enter key from the numeric keypad!)
Press Up to return to the above lyric line

5. PressingEsc ends lyrics entry
6. To type a second or further lyric line repeat steps 2 and 3 above, or double-click the first syllable,

hit ↵ and type the syllable for the first note, then continue at step 4

Some examples:

The last syllable of a word can be extended by underlines Shift+_ to notate a melisma:

Entered with: soul, Shift+___ To Esc.

For non-last syllables to extend, just use additional dashes -, only one of them will show, and the
syllable will right-align to the first note, similar to last syllables that got notated with a melisma, see
above.

Two syllables under a note can be joined with an elision character, also known as a "lyric slur" or
"synalepha".

In the text toolbar, click on the keyboard icon , or hit F2 to open the Text Symbols palette. The
synalepha is the 4th from the end (U+203F ‿ "undertie"). The synalepha will be evenly centered
separating the syllables with two spaces and by inserting it after the first. For the "e ͜A" example
shown above:

1. Type e
2. Insert the synalepha using the F2 palette
3. Type Ctrl+Space (Mac: ⌥+Space)
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4. Type A

Not all fonts include the synalepha character. To find out which fonts on your computer support the
synalepha, see "fontlist" (look for any font that shows a tie between "e" and "A" instead of a blank
rectangle). The alignment of the character also varies between fonts.

Special characters

Lyrics can be edited as normal text with the exception of a few characters: If you want to add a space,
hyphen, or underscore to a single syllable, use the following shortcuts:

Ctrl+Space (Mac: ⌥+Space) enters a space ( ) into the lyrics text
Ctrl+- (Mac: ⌥+-) or AltGr+- enters a hyphen (-) into the lyrics text
Ctrl+Shift+_ (Mac: ⌥+_) enters an underscore (_) into the lyrics text
Ctrl+↵ (Mac: ⌥+Return) or Enter (from the numeric keypad) enters a line feed into the lyrics text

Adjusting individual lyric lines

The top margin and line height of all lyric lines can be adjusted globally from the menu, Style →
General... → Page.

However, the horizontal (and vertical) offset of individual lyric lines can be finely adjusted by right-
clicking on a word in the desired line, and using the various selection options available to select all the
words that you wish to change. Then adjust using the offset option in the Inspector.

For example, to change the horizontal position of the lyrics in one staff only of one particular system:
right click on a word in that line, choose Select → More..., then tick the boxes labelled "Same Stave"
and "Same System". Now use "horizontal offset" in the Inspector to fine tune the line position.

See also

Text
Chord symbol
How to insert Lyrics
How to move lyrics
How to add a block of text to a score

External links

Video tutorial: MuseScore in Minutes: Lesson 6 - Text, Lyrics and Chords

Formatting
Layout and formatting
You've finished your score and you want to print it out. However, you want to improve how it looks.
This page describes many different ways, and how they work together.

Ways to affect layout

Layout → Page Settings...: Change global settings such as page size, how big a "Staff space"
is (under "Scaling"), and how big page margins are. Staff space is used in other settings
(example: "5.0sp"), so changing "Staff space" will change most other settings.
Layout → Increase Stretch, Decrease Stretch: Adjust spacing—stretch or squash measures
you specifically select.
Style → General... → Page: Change global settings that affect how close staves are and
systems are, how much margin lyrics have, and so on.
Style → General... → System: Adjust System bracket thickness and distance, or the Brace
thickness and distance.
Edit → Tools → Add/Remove line breaks: Fix the number of measures per system.
Style → General... → Score: Change score details, such as whether there are multimeasure
rests or hidden empty staves.
Style → General... → Measure: Set measure spacing, key to controlling number of measures
per line.
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Palette → Breaks & Spacers: Break a line at a particular measure, a page at a particular line, or
add space between measures.
Style → General... → Sizes: Set the proportional size of "small" and grace notes. Changing this
would be unusual.

Note: Here, options will almost always apply to all objects you refer to in your score, some options
may be individually done with inspector and other object properties for one, or a selection of objects...

Layout → Page Settings...

Here you can set page margins and scaling (in mm or inch units). This is the principal way to affect
layout.

Scaling → Staff space

Staff space is the size of the space between 2 lines of a staff. Since notes fit in that space, it also
controls the size of note heads, and, in turn, proportionally, the size of note stems, accidentals, clefs
etc. Since a change in the value of "Staff space" has a proportional affect on many other settings it is
also sometimes called scaling.

Staff space, abbreviated to sp, is used as a unit of measure in setting the values of numerous objects
in MuseScore: click on a notehead for example and notice the number of times that sp occurs in the
Inspector – and that is just for one item!

Note: Changing the scaling does not always change the number of systems per page because
system distance can vary between limits set under "Min system distance" and "Max system distance"
(see Style → General... → Page).

Printable Area → Margins

Here you can set page margins. To display page margins in your score on screen go to View → Page
Margin and select (tick) it. You can set different margins for odd and even pages. And you can preview
them with the navigator on the right of the window.

Page size

Here you can select the paper format, either by name (Letter, A4 etc.) or with height and width
specified in mm or inch(es): the default one depends on your country.

You also have two tick-boxes: Landscape (untick this for Potrait format) and Two sided (i.e. a book
format with even and odd pages). Note that if Two sided isn't ticked, only one set of margins can be
modified but these apply to all pages.
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First page number
Sets the number of the first page of the particular score.
Page numbers below 1 won't get printed, so e.g. a -1 would result in the first and second page to show
no page number and the third page to show as page number 1.

Apply to all Parts
When modifying a part of the score (that means being in a part tab when accessing this dialog, rather
than in the score tab, which is the left most one), this button allows to apply the change to all parts in
one go.

Layout → Increase Stretch, Decrease Stretch

To increase or decrease the horizontal spacing of notes within a measure or measures, you can
select the measures you want to affect, then use the "Increase Stretch" command (}) to widen them
so that fewer are on a line, or "Decrease Stretch" ({) to squash them to fit more on a line. You can
also access the exact same property from Measure Properties, where you can precisely edit the exact
percentage of additional space (or negative stretch). To reset a measure's stretch to the default
spacing of 1, use the "Reset Stretch" menu command.

Style → General... → Score
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Here you can cause the creation of multi-measure rests and hide empty staves. This can affect score
size greatly. You can also affect size and minimal duration for multimeasure rests.
"Hide instrument name if there is only 1" can also be a good space saver in your parts (or in solo
score), as it won't write the instrument name at the beginning of the line.

You can also change the musical font for text and symbols. There are 3 musical fonts available (for
symbols used in the staves): Emmentaler, Gonville, and Bravura. There are 4 musical text fonts
available (for use in texts like dynamics, tempo markings, etc.): Emmentaler, Gonville, Bravura and
MuseJazz. Of these Emmentaler is the default and Bravura the most complete one.

(To change text font and properties see Text style)

Some options are specific to early music, and swing playback.

Style → General... → Page
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Here are a lot of options that may affect your layout. Tick-boxes that may affect your layout are about
whether to show or not courtesy elements (key signatures, time signature and clef). You can also
influence the presence of these three elements in each system.

Music interaction with Pages Margin

Music top margin / Music bottom margin: Margin between the music (the top line of the top staff
of the top system and the bottom line of the bottom staff of the bottom system, respectively) and
the corresponding margins set in →Layout → Page settings.

Other music distance

Staff distance: Space between staves within a system
Grand staff distance: Space between the staves of a multi-staff instrument like piano and organ
Min. and max. system distance: Allows you to set the minimal and maximal distance from one
system to another. If both are the same, system distance will be set to that.

Lyrics Margin

Top and Bottom margin: Distance between staff and lyrics and between lyrics and next staff.
Lyrics height: this is a proportion from lyrics text style.

Vertical frame margin

Top and bottom vertical frame margin: Space above and below vertical frames.

Last system fill threshold

If the last system is longer than this percentage of the page width, it gets stretched to fill that
width.

Style → General... → Header, Footer, Numbers
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You can show the content of a score's meta tags (see Score information) or show page numbers in a
header or footer for your score. To create a header or footer for a score with linked parts, make sure
the main score is in the active tab. To create a header or footer for an individual part, that part needs
to be the active tab.

If you hover with your mouse over the Header or Footer text region, a list of macros will appear,
showing their meaning, as well as the existing meta tags and their content.

You can create different Headers and Footers for even and odd pages, such as putting page numbers
on the right for odd-numbered pages and on the left for even-numbered pages.

You can also edit whether and how often measure numbers appear.

Style → General... → System
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Bracket and Braces
See Bracket

Distances
You can set distance between the system and the Brackets and Brace
Width
You can set the width of Bracket and Brace.

Style → General... → Measure
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Sets measure spacing as well as margins. The measure spacing and minimum measure width are
keys to controlling the number of measures per line. Changing the other settings would be unusual.

Style → General... → Barlines
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Control whether to show barlines at the beginning of a staff or multiple staves.
Scale barlines to staff size affects "small" staves only. See Barline adjustment possibilities
(external link) for details.
Control proportion of thickness and distance within double barlines, including repeat barlines.

Palette → Breaks & Spacers

Using this palette, you can choose where you want page breaks, line or section breaks or increase the
distance between 2 individual staves or systems using the spacers. Some people do this first, and
some save it until the end, after modifying the global settings.

To insert a page break, drag and drop it to a measure. To insert a line break, drag and drop it to the
last measure you want on a line. If you want the same number of measures for several systems,
select them and use Edit → Tools → Add/Remove line breaks. If some measures end up alone on the
line or page, reduce the scaling, or use Layout → Add More Stretch, Add Less Stretch.

See also Break or spacer.

Style → General... → Notes
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Distance and thickness of note relative objects (stem, ledger line, accidental dot). Changing this would
be unusual.

Style → General... → Clefs
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You can choose between Serif and Standard clef for your tablature sheet.

Style → General... → Arpeggios
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Distance to note, line thickness and hook height proportions are here.
Changing this would be unusual.

Style → General... → Beams
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Style → General... → Slurs/Ties
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Style → General... → Sizes
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Sets the proportional size of "small" and grace notes, as well as small staves and clefs. Changing this
would be unusual.

Style → General... → Hairpins, Volta, Ottava
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The  button returns the setting to the original value.

Style → General... → Pedal, Trill

124

https://musescore.org/sites/musescore.org/files/Style-General-Hairpins%2CVolta%2COttava_en.png


Style → General... → Chord Symbols, Fretboard Diagrams
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Enables you to change appearance and other features.
See also Fretboard diagrams

Style → General... → Figured Bass
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Options about figured bass font, style and alignment.
See also Figured bass

Style → General... → Articulations, Ornaments
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Position of articulation with respect to the notes and staves

Style → General... → Accidentals
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Options about naturals at key signature changes

Style → General... → Tuplets
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Apply and OK buttons

With the Apply button you can see (without closing the window) what the changes you make are like.
OK will save the changes you made in your sheet and close the window.

Apply to all parts in one go

When in a part tab while changing layout and formatting, you can use the Apply to all Parts button
to apply all changes (either in Layout → Page Settings.... or Style → General...) to apply the new
settings to all parts in just one click.

Save and Load style

You can save a customized style, to apply it easily to all your scores.

1. Go to Style / Save Style
2. Select a folder and name it (the default folder will be the one set in your preferences)

Styles are stored in *.mss format

Note: you can also define a preferred style for scores and parts in Preferences score section

See also

To edit spacing between notes
Tutorial – How to create large-print stave notation (MSN)
Upgrading from MuseScore 1.x, local relayout

External links

Layout and Formatting, part 1 (a video tutorial)
Layout and Formatting, part 2 (a video tutorial)
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Breaks and spacers
Page breaks, line breaks (system breaks) or section breaks are applied by dragging the
corresponding symbol from the breaks palette to an empty space of a measure or on a horizontal
frame in the score. The break happens after the marked measure or frame. The blue break symbols
are visible on the screen, but do not appear on printouts.

Mid-measure system breaks are sometimes needed (especially for strophic hymns or lieder). For
example, if you want three beats on one system and a one beat pickup on the next system, then you
need to create two measures with a shortened duration. For details, see Measure operations: Split
and join.

Spacers are used to increase the space between two adjacent staves or systems. Drag and drop a
spacer to a measure above the area that needs more vertical space. Double-click on the spacer and
drag the handle using the mouse to adjust the height of the spacer.

If you want to adjust the space between staves score-wide, use the style settings. Spacers are
designed for local adjustments.

Adding a break or spacer

To add a break or spacer:

1. Use the Breaks & Spacers palette (see above)
2. Drag the desired break or spacer from there
3. Drop the break or spacer onto the measure you wish to affect

Deleting a break or spacer

There are times that you may want to remove a break or spacer. To delete a break or spacer:

1. Single click the break or spacer (it will turn into a darker blue to indicate that it is selected)
2. Press the Delete key

Section break

Section Break can be used to separate movements in a concerto for example.
It can be used with either line or page break. It also resets the measure number to 1. Thus, just as on
the first measure of the score, no number appears on the first measure after the break if configured
that way (see Measure Properties).

If you change Time signature or Key signature at the beginning of the new section, there will be no
courtesy signature at the end of the last measure before. See example below:

See also

Add/Remove Line Breaks tool
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Frame
Frames provide empty space outside of normal measures. They can also contain text or pictures.
MuseScore uses three types of frames: Horizontal, Vertical and Text:

Horizontal frame

Horizontal frames are used to create a break in a system. The width of the inserted frame is adjustable
and the height equals the system height. Their uses include:

Creating a coda, with an adjustable gap separating it from the rest of the score (as in the above
illustration).
Creating an offset at the beginning of the score where there is no staff name to perform the
same function.
Creating an adjustable right margin at the end of the score.
Creating space for some text or image

A horizontal frame can also be inserted in a Vertical frame or Text frame by right clicking on the frame
and selecting Add → Insert Horizontal Frame. It is automatically left-aligned and fills the entire
vertical frame. Double clicking the frame allows you to adjust the width using the editing handle. To
right align, drag it across the vertical frame using the mouse, having made it smaller first. Single
clicking on the frame allows you to edit several parameters in the Inspector:

Left Gap: ?
Right Gap: ?
Width: Adjusts the width of the frame.

Vertical frame

Vertical frames provide empty space between, before or after systems. The height is adjustable and
the width equals the system width. A vertical frame is automatically created at the beginning of a
score – showing the title, subtitle, composer, lyricist etc. – when you fill in information fields provided
in the Create New Score Wizard.

Selecting a frame allows you to adjust various parameters in the Inspector:
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Top Gap: Adjusts distance between frame and element above (negative values not currently
supported).
Bottom Gap: Adjusts distance between frame and element below (Negative values can be entered).
Height: Adjusts height of the frame.
Left Margin: Moves left-aligned text objects to the right.
Right Margin: Moves right-aligned text objects to the left.
Top margin: Moves top-aligned text objects downwards.
Bottom Margin: Moves bottom-aligned text objects upwards.

Double-clicking the vertical frame allows you to change the height property using the editing handle.
This is useful for adjusting space between particular systems.

Right-clicking the frame brings up a menu allowing you to create an object within the frame: this can
be text (Text, Title, Subtitle, Composer, Lyricist, and Part name), a picture or a horizontal frame. You
can create as many objects as you like within a frame. Each object can be moved and styled
independently of the others. Text objects can be positioned inside or outside the frame boundaries.

Each text object created within the frame can be moved by left-clicking and dragging (use the Ctrl or
Shift buttons to constrain movement in the horizontal or vertical). You can also click on the text object
and make adjustments to color, visibility, horizontal offset and vertical offset in the Inspector. Right-
clicking on a text object opens a menu allowing you to apply a unique style to the text ("Text
Properties") or to alter the overall style for that class of objects ("Text Style").

Text frame

A text frame looks like a vertical frame – and shares some of its features – but is specifically designed
to allow the user to enter text quickly and easily: as soon as the frame is created the user can start
typing. Unlike the vertical frame, only one text object is allowed per frame, the height automatically
expands to fit the content and there is no height adjustment handle. Selecting the frame (not the text
object) allows you to edit various parameters in the Inspector:

Top Gap: Adjusts distance between frame and element above (negative values not currently
supported).
Bottom Gap: Adjusts distance between frame and element below (negative values can be entered).
Height: Not applicable to text frames.
Left Margin: Moves left-aligned text objects to the right.
Right Margin: Moves right-aligned text objects to the left.
Top margin: Moves top-aligned text objects downwards.
Bottom Margin: Moves bottom-aligned text upwards.

You can also click on the text object and make adjustments to color, visibility, horizontal offset and
vertical offset in the Inspector

Create a frame

Frames are inserted into or appended to the score from the Add Menu.

To insert a frame, select a measure, and make your choice from the Add → Frames menu. The frame is
inserted before the selected measure. To append a frame to the end of the score, no measure
selection is required. Chose the desired frame to append from the Add → Frames menu.
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Delete a frame

Select the frame and press Del.

See also

How to add a block of text to a score
Text Properties—put a visual frame (border) around text

External links

Page Formatting in MuseScore 1.1 - 1. Frames, Text & Line Breaks [video]

Image
You can use Images to illustrate scores, or add symbols that are not included in the standard palettes.

To add an image, drag-and-drop an image file either into a frame or onto a note or rest of the score.
Alternatively, right-click into a frame, choose Add → Image, then pick an image from the file selector.

MuseScore supports the following image formats:

PNG (*.png)
JPEG files (*.jpg and *.jpeg)
SVG files (*.svg) (MuseScore currently does not support SVG shading, blurring, clipping or
masking.)

See also

Image capture
Create an ossia with image capture

Image capture
Image capture allows to create image snippets out of scores. It can be toggled on/off with the Image

capture button, .

In image capture mode, a selection rectangle can be spawned with Shift + mouse drag.

The selection rectangle can be moved with the mouse, or resized by moving one of the eight handles.

Once you specify the bounding box of the image snippet you want to create, right-click into the
rectangle to popup the context menu:
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Saving as a PNG file results in this file:

If you save your snippet in "print mode", it will appear as a cut out of the score as it would be printed.
In "Image capture mode", the image will look like the score on your screen (including line break
markers, etc.), which are not printed (100dpi example):

See also

Image
Create an ossia with image capture

Advanced topics
Accessibility
MuseScore comes with support for the free and open source NVDA screen reader for Windows. There
is no support at the moment for other screen readers such as Jaws for Windows, or VoiceOver for
Mac OS X.
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Introduction

This document is written for blind and visually impaired users of MuseScore 2.0. It is not intended to
provide a full description of all of the features of MuseScore; you should read this in conjunction with
the regular MuseScore documentation. However, it should be noted that MuseScore 2.0 is not yet
released, so documentation is still very incomplete.

This document applies to any recent nightly builds (since November 1, 2014). The accessibility
features were introduced with the Beta 1 release from August 2014, but there have been a large
number of fixes and improvements since then, both in accessibility and core functionality. The features
in this document have been tested on Windows with NVDA. Other screen readers and other operating
systems may work differently, or not at all.

At this point in time, MuseScore 2.0 is mostly accessible as a score reader, not so much as a score
editor. This document will focus on the score reading features, with only a brief description of score
editing.

Initial setup

When you run MuseScore for the first time, you may want to permanently disable the Start Center
window. To do so, go close the Start Center window first, then the Edit menu (Alt+E), choose
Preferences, and in there, uncheck Show Start Center. Save and close the preferences window.

Finding your way around

The user interface in MuseScore works much like other notation programs, or other document-
oriented programs in general. It has a single main document window in which you can work with a
score. MuseScore supports multiple document tabs within this window. It also supports a split-screen
view to let you work with two documents at once, and you can have multiple tabs in each window.
In addition to the score window, MuseScore has a menu bar that you can access via the shortcuts for
the individual menus:

File: Alt+F
Edit: Alt+E
View: Alt+V
Add: Alt+A
Notes: Alt+N
Layout: Alt+L
Style: Alt+S
Plugins: Alt+P
Help: Alt+H

Of these, only the File menu is of much interest when using MuseScore as a score reader. Once
opening a menu, it may take several presses of the Up or Down keys before everything is read properly.

There are also a number of toolbars, palettes, and subwindows within MuseScore, and you can cycle
through the controls in these using Tab (or Shift+Tab to move backwards through this same cycle).
When you first start MuseScore, or load a score, focus should be in the main score window. Pressing
Tab takes you to a toolbar containing a series of buttons for operations like New, Open, Play, and so
forth. Tab will skip any buttons that aren't currently active. The names and shortcuts (where
applicable) for these buttons should be read by your screen reader.

Once you have cycled through the buttons on the toolbar, the next window Tab will visit is the Palette.
This would be used to add various elements to a score, but it is not currently accessible except for two
buttons that are visited by Tab: a drop down to select between different workspaces (a saved
arrangement of palettes), and a button to create a new workspace.

If you have opened one of the optional windows, such as the Inspector, or the Selection Filter, the Tab
key will also visit these. You can close windows you do not need by going to the View menu and
making sure none of the first set of checkboxes are selected (the windows that appear before the
Zoom settings). By default, only the Palette, Navigator and MuseScore Connect should be selected,
and the latter two are not included in the Tab order.

To return focus to the score window after visiting the toolbar, or a subwindow, press Esc. This also
clears any selection you may have made in the score window.

The score window
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When you first start MuseScore 2.0, an empty example score entitled “My First Score” is loaded by
default. If you wish to experiment with editing features, this would be a good place to begin.
Otherwise, you will probably want to start by loading a score. MuseScore uses the standard shortcuts
to access system commands like Ctrl+O (Mac: Cmd+O) to open a file, Ctrl+S (Mac: Cmd+S) to save,
Ctrl+W (Mac: Cmd+W) to close, etc.

If you press Ctrl+O (Mac: Cmd+O) to load a score, you are presented with a fairly standard file dialog
(actually provided by Qt). MuseScore can open scores in its own format (MSCZ or MSCX) as well as
import scores in the standard MusicXML format, in MIDI format, or from a few other programs such as
Guitar Pro, Capella, and Band-in-a-Box. Once you have loaded a score, it is displayed in a new tab
within the score window. You can move between the tabs in the score window using Ctrl+Tab (does
not apply for Mac).

There are a few interesting things you can do with a loaded score besides reading it note by note. You
can press Space to have MuseScore play the score for you. You can use File / Export to convert to
another format, including PDF, PNG, WAV, MP3, MIDI, MusicXML, etc. And of course, you can print it
via File / Print or Ctrl+P (Mac: Cmd+P).

If a score contains multiple instruments, it may already have linked parts generated. Linked parts are
presented as part tabs within score tabs, but currently, there is no way to navigate these part tabs
using the keyboard. The parts would not normally contain information different from the score; they
would just be displayed differently (each part on its own page). If a score does not already have parts
generated, you can do so through File / Parts, and that dialog is accessible. If you wish to print the
parts, you can work around the inability of accessing part tabs individually by using the File / Export
Parts dialog, which automatically exports PDF’s (or other formats) for all parts in one step.

Score reading

When you first load a score, the score window has the keyboard focus, but there will be nothing
selected. The first step to reading a score is to select something, and the most natural place to begin
is with the first element of the score. Ctrl+Home (Mac: Cmd+Home) will do this. You will probably also
want to use this, should you ever clear your selection by pressing Esc.

As you navigate between elements, your screen reader should give the name of the selected element
(most likely the clef at the beginning of the top staff of your score). You will hear it read the name of
the element (for example, “Treble clef”) and also give position information (for example, “Measure 1;
Beat 1; Staff 1”). The amount of information read is not currently customizable, but we tried to place
the most important first so you can quickly move on to the next element before it has finished reading,
or just ignore the rest of what is read. Pressing Shift currently interrupts the reading, which might also
be useful.

Most navigation in MuseScore is centered around notes and rests only – it will skip clefs, key
signatures, time signatures, barlines, and other elements. So if you just use the standard Right and
Left keys to move through your score, you will only hear about notes and rests (and the elements
attached to them). However, there are two special navigation commands that you will find useful to
gain a more complete summarization of the score:

Next element: Ctrl+Alt+Shift+Right (Mac: Cmd+Option+Shift+Right)
Previous element: Ctrl+Alt+Shift+Left (Mac: Cmd+Option+Shift+Left

These commands include clefs and other elements that the other navigation commands skip, and also
navigate through all voices within the current staff, whereas other navigation commands such as Right
and Left only navigate through the currently selected voice until you explicitly change voices. For
instance, if you are on a quarter note on beat 1 of measure 1, and there are two voices in that
measure, then pressing Right will move on to the next note of voice 1—which will be on beat 2—
whereas pressing Ctrl+Alt+Shift+Right (Mac: Cmd+Option+Shift+Right) will stay on beat 1 but move
to the note on voice 2. Only once you have moved through all notes on the current beat on the current
staff will the shortcut move you on to the next beat. The intent is that this shortcut should be useful for
navigating through a score if you don’t already know what the contents are.

When you navigate to an element, your screen reader should read information about it. For notes and
rests, it will also read information about elements attached to them, such as lyrics, articulations, chord
symbols, etc. For the time being, there is no way to navigate directly to these elements.
One important note: Up and Down by themselves, with Shift, or with Ctrl / Cmd are not useful shortcuts
for navigation! Instead, they change the pitch of the currently selected note or notes. Be careful not to
inadvertently edit a score you are trying to read. Up and Down should only be used with Alt/Option if
your intent is navigation only. See the list of navigation shortcuts below.
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Moving forwards or backwards in time

The following shortcuts are useful for moving “horizontally” through a score:

Next element: Ctrl+Alt+Shift+Right
Previous element: Ctrl+Alt+Shift+Left
Next chord or rest: Right
Previous chord or rest: Left
Next measure: Ctrl+Right
Previous measure: Ctrl+Left
Go to measure: Ctrl+F
First element: Ctrl+Home
Last element: Ctrl+End

Moving between notes at a given point in time

The following shortcuts are useful for moving “vertically” through a score:

Next element: Ctrl+Alt+Shift+Right

Previous element: Ctrl+Alt+Shift+Left
Next higher note in voice, previous voice, or staff above: Alt+Up
Next lower note in voice, next voice, or staff below: Alt+Down
Top note in chord: Ctrl+Alt+Up
Bottom note in chord: Ctrl+Alt+Down

The Alt+Up and Alt+Down commands are similar to the Ctrl+Alt+Shift+Right and
Ctrl+Alt+Shift+Left commands in that they are designed to help you discover the content of a score.
You do not need to know how many notes are in a chord, how many voices are in a staff, or how
many staves are in a score in order to move vertically through the score using these commands.

Filtering score reading

Excluding certain elements like lyrics, or chord names while reading the score is possible by using the
Selection filter (F6). Uncheck those elements you don't want to read.

Score playback

The Space bar serves both to start and stop playback. Playback will start with the currently selected
note if one is selected; where playback was last stopped if no note is selected; or at the beginning of
the score on first playback.

MuseScore supports looped playback so you can repeat a section of a piece for practice purposes. To
set the “in” and “out” points for the loop playback via the Play Panel (F11):

1. First select the note in the score window where the loop should start
2. Go to the Play Panel and press the Set loop In position toggle button
3. Back to the score window, navigate to the note where you want the loop to end
4. Switch again to Play Panel, and press the Set loop Out position toggle button
5. To enable or disable the loop, press the Loop Playback toggle button

You can also control the loop playback and control other playback parameters, such as overriding the
basic tempo of a score, using the View / Play Panel (F11).

Score editing

Score editing is currently not very accessible – too many score elements require intervention of the
mouse in order to place objects onto a score. Additionally, visual reference and manual adjustment of
the position of various elements is sometimes necessary due to MuseScore's limited support for
conflict avoidance of elements.

In contrast, MuseScore does often provide ample default, and a platform to experiment with the basics
of note input.
To enter note input mode, first navigate to the measure in which you would like to enter notes, then
press “N”. Almost everything about note input is designed to be keyboard accessible, and the standard
documentation should be good to help you through the process. Bear in mind that MuseScore can
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either be in note input or normal mode, and it won’t always be clear which mode of these you are in.
When in doubt, press Esc. If you were in note input mode, this will take you out. If you were in normal
mode, you will stay there, although you will also lose your selection.

Customization

You can customize the keyboard shortcuts using Edit / Preferences / Shortcuts. At some point, we
may provide a set of special accessibility-optimized shortcuts and/or a way of saving and loading sets
of shortcut definitions.

Album
The Album Manager allows to prepare a list of multiple scores and save the list as an album file
("*.album"), print all the scores as one long print job with consistent page numbers, or even join the
scores into a single new score. This is ideal for preparing an exercise book or combining multiple
movements of an orchestration.

To open the Album Manager, go to File → Album…

Create Album

1. To create a new album, click the New button. Fill in a title in the "Album Name:" box at the top.

2. To add scores to the album, click Add Score. A file selection dialog will appear and let you
choose one or multiple scores from your file system. Click OK.

3. The scores you add will appear in a list in the Album Manager. You can rearrange their order by
selecting a score and clicking the Up or Down button.

Load Album

If you have previously created an album, you can open it through the Album Manager by clicking the
Load button. A file selection dialog will appear to let you load the .album file from your file system.

Print Album

To print an album as if it were a single document, click Print Album. The scores loaded into the Album
Manager are printed in the order they are listed in with the correct page numbers, ignoring the page
number offset values in Layout → Page Settings... → First page number for all but the first score. As
the album is printed in one print job, double-sided printing (duplex printing) also works as expected.

Join Scores

To combine multiple scores into a single .mscz file, click Join Scores. The scores are combined in the
selected order into one single score. If not already present, line- and section breaks are added to the
last measure or frame of each score in the combined file.
All style settings are taken from the first score, different style settings from subsequent score are
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ignored.

All the scores should have the same number of parts and staves for this to work correctly, ideally with
the same instruments in the same order. If the scores have the same total number of instruments but
not the same ones, or not in the same order, then the instrument names from the first score will
overwrite ones from subsequent scores. If some of the scores have fewer instruments than the first
score, then empty staves will be created for those sections. Any part or staff that is not present in
the first score will be lost in the joined score.

Save Album

Upon clicking the Close button, you will be prompted to save your album as a .album file. This file is
not the same as a joined score; it simply consists of the list of scores. Album files can be loaded into
the Album Manager as described above.

Cross staff beaming
In piano scores, it is common to use both staves (bass and treble clef) to write a musical phrase.

This can be entered in MuseScore as follows:

Enter all notes in one staff:

Ctrl+Shift+↓ moves the selected note, or chord to the next staff (Mac: ⌘+Shift+↓.)

If you want to move the beam, double-click the beam to show the handles. Drag the handles to adjust
the layout.

See also

Barline for cross-staff barlines (i.e. grand staff).

Custom palette
Palettes are highly customizable. You can create/delete single palettes and populate them with
arbitrary elements from the master palette or from elements of a score. A set of palettes is called a
"workspace". You can maintain several workspaces and easily switch between them.
Only palettes in a custom workspace allow access to their context menu. So first you must create your
own workspace.

Palette menu
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Right-clicking on a palette title shows the palette menu.

The menu offers the following operations:

Palette Properties: Selecting this entry opens the palette property dialog:

You also have a 'Show more elements' tick box there.

Insert New Palette: Creates a new empty palette which can be filled with elements from the
master palette, other palettes, or with elements from the score (see below).

Move Palette Up: Moves the palette up in the list of palettes.
Move Palette Down: Moves the palette down in the list of palettes.
Enable Editing: Tick this to change the content of a palette. To avoid accidental changes,
editing is off by default.
Save Palette: Opens a file dialog and saves the palette into a file.
Load Palette: Opens a file dialog and reads a palette from a file.
Delete Palette

Right-clicking the header of the list of palettes opens the palette context menu. The menu allows you
to change the palette behavior.

Single Palette Mode: If ticked allows only one palette to be open.

You can also right-click on an empty field in a palette and be able to add one with "Show More...".

(Enabled if the corresponding item is ticked in the palette's properties)

Creating and saving custom palette symbols

Provided you have created a new workspace, some palette symbols, such as lines, can be customized
to your liking on the score and then saved back to any palette. Press Ctrl+Shift and drag the symbol
from the score into the desired palette.

See also

Palette
Master palette
Workspace

Early music features
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MuseScore 2.0 offers several new functions to create engravings of early music (particularly medieval
and renaissance) akin to commercial editions from the 20th century onwards.

Unbarred notation

Since most renaissance music was unbarred (i.e. not divided into measures), having long notes
divided up and tied over barlines significantly changes the look of the score. Recognizing large
melodic lines and repeated motives could become more difficult. Therefore, MuseScore provides an
experimental display method where the note values stay intact. This method can be activated by
ticking a checkbox in the Score section of the Style dialog, found under Style → General...

Apply and the display is adjusted immediately.

Original notation (De Profundis Clamavi for 4 voices by Nicolas Champion)

Before style Change
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After style Change

Note that the feature is still experimental and may contain bugs. The longest supported note value is
the longa (a dotted longa is still broken up and tied over).
To get rid of the barlines, just untick the “Show barlines” box in the Staff properties dialog. However,
there is another option.

Mensurstrich

Since a complete lack of barlines could make performing the music more difficult for current
musicians, many modern engravers settled on a compromise called Mensurstrich, where barlines are
drawn between, but not across, staves. This is also possible now: double click a barline, drag the
lower end to the top of the staff below it, and drag the upper end to the bottom of the current staff. Do
this in precision mode (hold down Shift). Then deselect the barline and the changes should be
applied to the entire staff.

It may be easier to use the Inspector to change the numbers manually. To open the Inspector, press
F8 and select a barline. The correct values are:

 Default Mensurstrich
Spanned
staves 1 2

Span from 0 8
Span to 8 0

You may want to set the barlines back to the default values at the end of the score or a section, but
remember to hold down Ctrl, or else the entire staff will be reset.

Ambitus

Before there was the concept of an absolute pitch, performers were required to transpose vocal music
to a singable range for their ensemble on the fly. To aid them, an ambitus was sometimes included,
marking the entire range of a voice at the beginning of the piece. The ambitus is located in the palette
at the bottom of the Lines section, from there drag it onto a clef. It will automatically detect the range.
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The ambitus will consider all measures of music up until the next section break, beyond which a new
ambitus may be applied. It can be adjusted manually or automatically in the Inspector. First select the
ambitus to adjust. For manual adjustments edit the top and bottom note values. For automatic
adjustment click the Update Range button in the inspector.

Mensural time signatures

In the mensural notation system, time signatures did not define the length of a measure, but the length
of breves and semibreves. MuseScore supports mensural time symbols as a display method in the
Time signature properties dialog rather than as symbols, but they are just for show, as the proportion
of e.g. half notes per whole notes cannot be modified.
One way to make use of these symbols is to replicate when composers of the renaissance had
multiple voices in different time signatures simultaneously without using tuplets. Edit the time
signature on a per-staff basis, as long as the beginning and end of a measure in all staves match up. If
they do not, then consider increasing the size of the measures to the lowest common denominator.

De Profundis Clamavi for 5 voices by Josquin Des Prez

See also

Measure Operations: Split and join

Figured bass

Adding a new figured bass indication

1. Select the note to which the figured bass applies
2. Press the Figured Bass shortcut (default Ctrl+G; can be changed in Preferences)
3. Enter the text in the editor 'blue box' as required (see below)
4. Press Space to move to the next note ready for another figured bass indication (or click outside

the editor box to exit it)

With Space, the editor advances to the next note, or rest of the staff to which figured bass is being
added. To move to a point in between, or to extend a figured bass group for a longer duration, see
below Group Duration.

Tab advances the editing box to the beginning of the next measure.

Shift+Space moves the editing box to the previous staff note or rest.

144



Shift+Tab moves the editing box to the beginning of the previous measure.

Text format

Digits

Digits are entered directly. Groups of several digits stacked one above the other are also entered
directly in a single text, stacking them with Enter:

Accidentals

Accidentals can be entered using regular keys:

To enter: type:
double flat bb
flat b
natural h
sharp #
double sharp ##

These characters will automatically turn into the proper signs when you leave the editor. Accidentals
can be entered before, or after a digit (and of course, in place of a digit, for altered thirds), according to
the required style; both styles are properly aligned, with the accidental 'hanging' at the left, or the right.

Combined shapes

Slashed digits or digits with a cross can be entered by adding \, / or + after the digit (combining
suffixes); the proper combined shape will be substituted when leaving the editor:

The built-in font can manage combination equivalence, favoring the more common substitution:

1+, 2+, 3+, 4+ result in  (or )
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and 5\, 6\, 7\, 8\, 9\ result in  (or )

Please remember that / can only by combined with 5; any other 'slashed' figure is rendered with a
question mark.

+ can also be used before a digit; in this case it is not combined, but it is properly aligned ('+' hanging
at the left side).

Parentheses

Open and closed parentheses, both round: '(', ')' and square: '[', ']', can be inserted before and after
accidentals, before and after a digit, before and after a continuation line; added parentheses will not
disturb the proper alignment of the main character.

Notes:

The editor does not check that parentheses, open and closed, round or square, are properly
balanced.
Several parentheses in a row are non-syntactical and prevent proper recognition of the entered
text.
A parenthesis between a digit and a combining suffix ('+', '\', '/') is accepted, but prevents shape
combination.

Continuation lines

Continuation lines are input by adding an '_' (underscore) at the end of the line. Each digit of a group
can have its own continuation line:

Continuation lines are drawn for the whole duration of the figured bass group (but currently are not
continued on following systems, the same as for lyric continuation lines).

'Extended' continuation lines

Occasionally, a continuation line has to connect with the continuation line of a following group, when a
chord degree has to be kept across two groups. Examples (both from J. Boismortier, Pièces de viole,
op. 31, Paris 1730):

In the first case, each group has its own continuation line; in the second, the continuation line of the
first group is carried 'into' the second.

This can be obtained by entering several (two or more) underscores "__" at the end of the text line of
the first group.

Duration

Each figured bass group has a duration, which is indicated by a light gray line above it (of course, this
line is for information only and it is not printed or exported to PDF).

Initially, a group has the same duration of the note to which it is attached. A different duration may be
required to fit several groups under a single note or to extend a group to span several notes.

To achieve this, the key combinations listed below can be used; each of them

146



advances the editing box by the indicated duration
AND
sets the duration of the previous group up to the new editing box position.

Pressing several of them in sequence without entering any figured bass text repeatedly extends the
previous group.

Type: to get:
Ctrl+1 1/64
Ctrl+2 1/32
Ctrl+3 1/16
Ctrl+4 1/8 (quaver)
Ctrl+5 1/4 (crochet)
Ctrl+6 half note (minim)

Ctrl+7
whole note
(semibreve)

Ctrl+8 2 whole notes (breve)

(The digits are the same as are used to set the note durations)

Setting the exact figured bass group duration is only mandatory in two cases:

1. When several groups are fit under a single staff note (there is no other way).
2. When continuation lines are used, as line length depends on the group duration.

However, it is a good practice to always set the duration to the intended value for the purposes of
plugins and MusicXML.

Editing existing figured basses

To edit a figured bass indication already entered:

Select it, or the note it belongs to and press the same Figured Bass shortcut used to create a
new one
or
Double-click it

The usual text editor box will open with the text converted back to plain characters ('b', '#' and 'h' for
accidentals, separate combining suffixes, underscores, etc.) for simpler editing.

Once done, press Space to move to a next note, or click outside the editor box to exit it, as for newly
created figured basses.

Style

The Style → General... menu command allows to configure how figured bass is rendered. Select
"Figured Bass" in the list on the left side to display the following dialogue box:
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The Font drop list contains all the fonts which have been configured for figured bass. A standard
installation contains only one font, "MuseScore Figured Bass", which is also the default font.

The Size is the size of the font (in points). It is linked to the spatium value: for the default spatium, the
entered value is used; for smaller or larger spatium values, a size value proportionally smaller or larger
is used.

Vertical Position is the distance (in spatia) from the top of the staff to the top margin of the figured
bass text. Negative values go up (figured bass above the staff) and positive values go down (figured
bass below the staff: a value greater than 4 is needed to step over the staff itself).

Line Height is the distance between the base line of each figured bass line; it is expressed in percent
of the font size.

The following picture visualizes each numeric parameter:

The Top / Bottom radio buttons select the vertical alignment: with Top, the top line of each group is
aligned with the main vertical position and the group 'hangs' from it (this is normally used with figured
bass notation and is the default); with Bottom, the bottom line is aligned with the main vertical position
and the group 'sits' on it (this is sometimes used in some kinds of harmonic analysis notations):
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The Modern / Historic radio buttons select the typographic style of the combined shapes. The
difference between the two styles is shown below:

Proper syntax

For the relevant substitutions and shape combinations to take effect and for proper alignment, the
figured bass mechanism expects input texts to follow some rules (which are in any case, the rules for
a syntactical figured bass indication):

There can be only one accidental (before or after), or only one combining suffix per figure;
There cannot be both an accidental and a combining suffix;
There can be an accidental without a digit (altered third), but not a combining suffix without a
digit.
Any other character not listed above is not expected.

If a text entered does not follow these rules, it will not be processed: it will be stored and displayed as
it is, without any layout.

Summary of keys

Type: to get:
Ctrl+G Adds a new figured bass group to the selected note.
Space Advances the editing box to the next note.
Shift+Space Moves the editing box to the previous note.
Tab Advances the editing box to the next measure.
Shift+Tab Moves the editing box to the previous measure.
Ctrl+1 Advances the editing box by 1/64, setting the duration of the previous group.
Ctrl+2 Advances the editing box by 1/32, setting the duration of the previous group.
Ctrl+3 Advances the editing box by 1/16, setting the duration of the previous group.
Ctrl+4 Advances the editing box by 1/8 (quaver), setting the duration of the previous group.
Ctrl+5 Advances the editing box by 1/4 (crochet), setting the duration of the previous group.

Ctrl+6
Advances the editing box by a half note (minim), setting the duration of the previous
group.

Ctrl+7
Advances the editing box by a whole note (semibreve), setting the duration of the
previous group.

Ctrl+8
Advances the editing box by two whole notes (breve), setting the duration of the
previous group.

Ctrl+Space Enters an actual space; useful when figure appears "on the second line" (e.g., 5 4 -> 3).
B B Enters a double flat.

B Enters a flat.
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H Enters a natural.
# Enters a sharp.
# # Enters a double sharp.
_ Enters a continuation line.
_ _ Enters an extended continuation line.

Type: to get:

Fretboard diagram

Adding a Fretboard diagram, barré and position number

1. Drag and drop on the score the fretboard diagram from symbols palette (in the advanced
workspace)

2. Right-click on the diagram → Fretboard Diagram Properties...

3. For example, to get an F chord, first set up this configuration (you may see the number 6 for
strings in the spin box at the bottom of this window)

4. Press the Shift, then click on the first fret of the 6th string, like this:

First result:

Final result on the score for the F chord:
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You can change the width of the barré line at your convenience by going to Style → General...
→ Chords symbols → Barré line thickness

Note that the principle is the same if you want a four strings barré (or other). In this case of an
A7 chord: Press Shift, then click on the 4th string, second fret. This then results in:

5. To add a position/fret number to the fretboard, use the scrollbars on the right-hand side of the
window.

Inspector and object properties
Most elements have advanced options available via right-click (also known as secondary-click), and
properties that can be viewed and changed in the Inspector.

Inspector

The Inspector is shown by default on the right of your screen. To show or hide, open the View menu
and check/uncheck Inspector or use the shortcut F8 (Mac: fn+F8).

When an object is selected, its properties are displayed, and can be edited, in the Inspector. Virtually
every single element on the page can be selected and edited this way – notes, text, barlines,
articulations etc. Groups of elements can be selected and edited simultaneously: if the objects are of
different types then the Inspector displays only those properties common to all of them that are
editable.

Categories

There are different options in each of the categories in the Inspector.

Element offers the following controls: Visible, Color, and Horizontal/Vertical offset.

Visible is a commonly used control that allows you to make almost any element invisible. If the
box for Visible is unchecked, the selected elements will turn gray in MuseScore to show that
they are invisible, and will not be printed out or shown when exported as a PDF or image. (Note:
using View → Show Invisible, it is possible to make invisible elements completely invisible on
screen as well as in print.) You can also toggle the visibility of selected elements (i.e., switch
between visible and invisible) with the keyboard shortcut V.

Color lets you choose the color of the element. The element will remain in this color when the
score is printed or exported.

Horizontal offset and Vertical offset allow you to fine-tune the placement of an individual
element by inputting exact values for its offset from default position on an X/Y coordinate plane.

Other categories may be only shown in specific targeted cases, such as Barline, which is only present
when a barline is selected.
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Some elements may be related to other types of elements. An example would be to select a note that
has a dot and a beam, such as the E selected here:
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Several different categories of options related to the note will show in the Inspector, including Chord,
Note, and Segment. But notice that at the bottom, you also have access to options for related
elements, including Stem, and in this example Beam and Dot.

If you select a measure, the Inspector will only show those options common to each note in the
measure: Visible and Color. To edit the properties of the measure itself, right-click an empty part of
the measure and select "Measure Properties" as shown below.

When several elements are selected, if they have a different value for a given property, the property
will be displayed in blue. If you change this property, it will change for all selected elements.

Properties (accessed via right-click)

Measure properties

To edit the properties of a measure, right-click an empty part of the measure and select "Measure
Properties."
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From within an open Measure Properties window, you can move to edit the previous or next measure
via these buttons, at the bottom left of the window:  (note that while the window changes,
the measure shown as selected in your score does not. Be careful). For more details, see Measure
Properties.

Staff properties
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Staff Properties are also accessed by right-clicking a measure, or by right-clicking the name of an
instrument.

Staff Properties actually includes both a Staff Properties section and a Part Properties section:

Staff options include color, number of lines, space between lines, hiding options, staff size and so on.

Part options include instrument name, part name (used for part extraction), playback transposition,
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and pitch range.

See also

Measure operations
Note input
Layout and formatting
Staff type properties
Part extraction

Master palette
The Master Palette enables you to access all the possible elements that could be added to custom
palettes, and, in the case of Time Signatures and Key Signatures, make your own.

Go to View → Master Palette or use the shortcut Shift+F9 (Mac: fn+Shift+F9).

Hovering over an item with the mouse shows a tool tip (a short definition in black on yellow
background).

Symbols
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The Symbol palette is a large repository of hundreds of musical symbols in addition to those found in
the default palettes. You can open it from the Master palette, or directly from the score by using the
shortcut Z.

The symbols are listed under their respective musical font types: use the font menu on the bottom
right of the box to specify Emmentaler, Gonville or Bravura. You can search for a particular symbol by
entering a keyword in the search box.

Symbols are applied to the score by dragging and dropping, or by selecting a note or rest and double-
clicking the symbol. The position can then be adjusted by dragging or by changing the horizontal /
vertical offsets in the Inspector. Color and visibility can also be adjusted in the Inspector.

See also

Palettes
Custom palette
Workspace

Part extraction
If you have written a full ensemble score, MuseScore can create sheet music that shows only the
individual part for each musician in the ensemble.

Setting up the parts

You can define the parts at any point after creating a new score. You only need to define the parts
once for each score, but you can make changes if needed. The following instructions use a string
quartet as an example, but the same principles apply for any other ensemble.

1. From the main menu, choose File → Parts...
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2. In the Parts window click New to create a "part definition"

3. In the right pane, type the words you want to use for the "Part title" (this also serves for the
corresponding part of the filename when exporting)

4. Pick the instrument that you want to appear in your part by marking the relevant box in the right-
hand pane. Usually, you only want one instrument per part, but sometimes you might need a
part that includes more than one instrument (such as multiple percussion staves). MuseScore
allows you to mark as many instruments per part as you need

5. Repeat steps two through four (above) for each part as needed
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6. Once you're done, press OK to dismiss the Parts window

You have now finished setting up the parts. You do not need to do this again, unless you add or
remove an instrument from your full score. In the current version of MuseScore, it is not possible to
split a single staff (that contains two or more voices) into separate parts. So, any instrument that you
want to print out a separate part for also needs to have its own staff in the full score.

Setup all parts in one go

If you have an orchestral score in which each instrument should be extracted, you can create the parts
more easily:

1. Go to File → Parts...

2. Press the New All button (parts are named with the instrument name, and if needed with an
appended "-<number>")

3. Hit OK

Now you will see a tab for each part with your score.

Exporting the parts

1. Go to File → Export Parts...

2. Navigate to the place you want them to be exported to and select the file format (PDF is the
default)

3. For filename just enter whatever prefix is useful for all parts, or leave the default (the filename of
your score)

4. Hit OK

This will generate files with the names "<title>" + "-" + "<part name>.<extension>". In addition, when
exporting as PDF, this will also generate "<title>" + "-Score_And_Parts.pdf".
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Saving

Parts and score are "linked", which means that any change to the content in one will affect the other,
but changes to the layout will not. When you have the parts created, they are saved along with the
score (if you open the score you have tabs for the score and every part you created).
You can, however, save each part individually by selecting its tab and use File → Save As...

Plugins

Overview

Plugins are small pieces of code that add a particular feature to MuseScore. By enabling a plugin, a
new menu option will be appended to the Plugins menu in MuseScore to accomplish a given action on
the score or a part of it.

Some plugins come pre-installed with MuseScore—see →below. You can find many more plugins in
the plugin repository. Some plugins there work with MuseScore 2; others will only work with older
versions of MuseScore.

Installation

Note that some plugins may require the installation of other components (fonts, e.g.) to work. Check
the plugin's documentation for more information.

Most plugins are provided as ZIP archives, so download the plugin's .zip file and uncompress it to one
of the directories mentioned below.

Some may be provided directly as a .qml file, download and place into one of these directories.

Windows

MuseScore looks for plugins in %ProgramFiles%\MuseScore 2\Plugins (or
%ProgramFiles(x86)%\MuseScore 2\Plugins for the 64-bit versions) and in
%LOCALAPPDATA%\MuseScore\MuseScore 2\plugins on Vista and Seven or C:\Documents and
Settings\USERNAME\Local Settings\Application Data\MuseScore\MuseScore 2\plugins (adjusted to
your language version) on XP.

Mac OS X

On Mac OS X, MuseScore looks for plugins in the MuseScore bundle in /Applications/MuseScore
2.app/Contents/Resources/plugins and in ~/Library/Application Support/MuseScore/MuseScore
2/plugins. To be able to move files in the app bundle, right click (Control-click) on MuseScore.app and
choose "Show package contents" to reveal the Contents directory. Be careful to use
Contents/Resources/plugins and not Contents/plugins.

Linux

In Linux, MuseScore looks for plugins in /usr/share/mscore-2.0/plugins and in
~/.local/share/data/MuseScore/MuseScore 2/plugins.

Enable/disable plugins

To be able to access the installed plugins from the Plugins menu, they need to be enabled in the
Plugin Manager:
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Create/edit/run plugins

It is possible to create new or edit existing plugins and run them via the Plugin Creator:

Here also the documentation of all available elements can be found

Plugins installed by default
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Some plugins come pre-installed with MuseScore, but they are not enabled by default. See →above
to enable plugins.

ABC Import

This plugin imports ABC text from a file or the clipboard. Internet connection is required, because it
uses an external web-service for the conversion, which uses abc2xml and gets send the ABC data,
returns MusicXML and imports that into MuseScore.

Break Every X Measures

This plugin enters line breaks in the interval you select on the selected measures or, if no measures
are selected, the entire score. It is no longer being distributed and has been replaced by Edit → Tools
→ Add/Remove Line Breaks. If you ever used an early beta version of MuseScore 2, though, you may
still see the plugin left over.

Notes → Color Notes

This demo plugin colors notes in the selection depending on pitch. It colors the note head of all notes
in all staves and voices according to the BoomWhackers convention. Each pitch has a different color.
C and C♯ have a different color. C♯ and D♭ have the same color.
To color all the notes in black, just run that plugin again (on the same selection). You could also use
the 'Remove Notes Color' plugin for this.

Create Score

This demo plugin creates a new score. It creates a new piano score with 4 quarters C D E F. It's a
good start to learn how to make a new score and add notes from a plugin.

helloQml

This demo plugin shows some basic tasks.

Notes → Note Names

This plugin names notes. It displays the English names of the notes (as a staff text), for voices 1 and 3
above the staff, for voices 2 and 4 below the staff, and for chords in a comma separated list, starting
with the top note.
A translated version, which uses note names as per your language settings, is available from the
plugin repository.

panel

This demo plugin creates a GUI panel.

random

Creates a random score.

random2

Creates a random score too

run

This demo plugin runs an external command. Probably this will only work on Linux.

scorelist

This test plugin iterates through the score list.

ScoreView
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Demo plugin to demonstrate the use of a ScoreView

Walk

This test plugin walks through all elements in a score

See also

Tools

Replace pitches without changing rhythms
If you have a passage where you want a change in notes but not in rhythm, but that is more
complicated than a simple transposition of notes, re-pitch mode is highly useful. In essence, when in
re-pitch mode, new pitches will replace the old ones, following the original rhythm.

Not to be confused with Accidental: Respell pitches

To activate re-pitch mode, use the re-pitch button, , next to the Note input button, , or use the
shortcut Shift+Ctrl+I (Mac: Shift+Cmd+I).

To reproduce a rhythmical passage with different pitches, select the passage, copy it, and paste it
where you want. (If you are in a situation of having written the wrong notes but correct rhythm, no
copy and paste is necessary.)

Then click on the first note you want to re-pitch, enter note input mode, and activate re-pitch mode.
Begin typing the new pitches. Unlike normal circumstances, where the length of the notes you are
entering are based on what length you have selected in the toolbar, in re-pitch mode the rhythm (the
notes' length) will stay the same.

See also

Note input
Copy and paste
Transposition
Introduction to the new re-pitch mode

Score information
Several meta tags are generated automatically on creation of a score, and more may be created later.
These may be used in the Footer / Header of your score.

File → Info shows the values of the existing meta tags (some may be empty).
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Preexisting meta tags

Every score has the following meta tags. Some are automatically filled in on score creation, as the
following list details:

MuseScore Version: The version of MuseScore the score was last saved with.
Revision: The revision of MuseScore the score was last saved with.
API-Level: The file format version.
arranger: (empty)
composer: As entered in the New Score Wizard (which is also used to fill the composer text in
the top vertical frame—be aware that later changes to one are not reflected in the other).
copyright: As entered in the New Score Wizard. Copyright info appears as seemingly uneditable
text at the bottom of every page of a score, but it can be edited or removed by changing the
value here.
creationDate: Date of the score creation. This could be empty, if the score was saved in test
mode (see Command line options).
lyricist: As entered in the New Score Wizard (which is also used to fill the corresponding lyricist
text in the top vertical frame—be aware that later changes to one are not reflected in the
other).
movementNumber: (empty)
movementTitle: (empty)
platform: The platform the score was created on: "Microsoft Windows", "Apple Macintosh",
"Linux" or "Unknown". This might be empty if the score was saved in test mode.
poet: (empty)
source: (empty)
translator: (empty)
workNumber: (empty)
workTitle: As entered in the New Score Wizard (which is also used to fill the corresponding title
text in the top vertical frame—be aware that later changes to one are not reflected in the
other).

The first three items in the above list cannot be used in the Header or Footer (there are not really
meta tags).
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Every part additionally has the following meta tag, generated and filled on part creation:

partName: Name of the part as given on part creation (which is also used to fill the
corresponding part name text in the top vertical frame—be aware that later changes to one
are not reflected in the other).

Modify a meta tag

To modify a meta tag of a score with linked parts, make sure the score is in the active tab. To modify
a meta tag for an individual part, that part needs to be the active tab.
Go to File → Info and change the current text or fill in the empty field for any of the tags listed.

Add a new meta tag

To add a meta tag to a score with linked parts, make sure the score is in the active tab. To add a meta
tag to an individual part, that part needs to be the active tab.

Go to File → Info → New

Fill in the name of your new meta tag and click OK (or Cancel). The meta tag will be added to your tag
list. You can then fill in the content of the tag.

Header/Footer

You can show the content of meta tags in a header or footer for your score. To create a header or
footer for a score with linked parts, make sure the score is in the active tab. To create a header or
footer for an individual part, that part needs to be the active tab.

Go to Style → General... to open the Edit Style window and choose Header, Footer, Numbers  from
the sidebar on the left.

If you hover with your mouse over the Header or Footer text region, a list of macros will appear,
showing their meaning, as well as the existing meta tags and their content.
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You can use these tags (e.g. $:workTitle:) and macros (e.g. $M) in the appropriate boxes to add them
to headers or footers.

Click Apply to see how the header or footer looks in the score. Click OK to assign the header or footer
to the score or the active part. If a part is in the active tab, you can also click Apply to all parts if you
want that and then OK to leave the dialog. Cancel allows you to exit without applying the changes.

See also

Layout and formatting: Header and footer
Command line options: Test mode

Shared noteheads
It is common in classical and fingerstyle guitar music for notes in different voices that fall on the same
beat to share noteheads. MusScore allows notehead sharing by default if both or neither of the two
notes are a quarter note (crotchet) or less, and if both or neither is dotted—no further adjustment is
needed:

In cases where one of the notes, but not the other, is dotted and/or larger than a quarter note (e.g.
dotted eighth note, dotted quarter note, half note, dotted half note, etc.), then MuseScore offsets the
two notes:
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This offsetting can be easily overridden by making the smaller-value notehead invisible by selecting it
and using the keyboard shortcut V, or unchecking the "Visible" option in the Inspector; or by altering
the notehead type to match the longer one (in the "Note" section of the Inspector, switch "Head type"
from "Auto" to "Half").

Shared noteheads in a regular staff translate to two separate notes in a linked tablature staff. To
correct this, simply hide one of the notes in the tablature staff using the keyboard shortcut V or by
unchecking the "visible" option in the Inspector.

Staff properties

Overview

In MuseScore, each instrument’s staff has a number of properties which can be modified. Every staff
belongs to one of three groups:

Standard
Tablature
Percussion

Some of the properties of a staff depend on which group it belongs to. The Edit Staff/Part Properties
dialog box allows you to examine and modify the group-specific properties of a staff.

The staff groups to which a staff can belong depend on the instrument: any staff can be a standard
staff, but only staves of percussion instruments can be (or can be turned into) percussion staves, and
only staves of stringed instruments can be (or can be turned into) tablature staves.

Each score is initially created with 17 pre-defined staff "templates" (not to be confused with
Templates): one standard, three percussion and 13 tablature templates. Each template addresses a
specific need, common enough or standardized enough to deserve a specific template; each template
can be modified (independently for each score staff) and new templates can be created to
accommodate specialized needs.

Edit staff properties

The Edit Staff/Part Properties dialog box is accessed by right-clicking on the instrument name, or on
an empty spot of a staff, and selecting Staff Properties...
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There are different options depending on the group of the selected staff: standard, tablature or
percussion. Some options, however, are common to all staves:

Name
A human-readable name

Lines
The number of lines making up the staff

Line Distance
The distance between two staff lines, expressed in spaces (abbr.: sp), i.e. the default distance
between two staff lines; 1.0 is (rather obviously) the default, a higher value will generate lines
spaced more widely apart, a lower value generates then more tightly spaced. It is not
recommended to change this value for the standard group (although it is possible); other groups
may have different default values, for instance tablatures usually have a line distance of 1.5 sp.

Extra distance above staff
Use this to increase the distance between the selected staff and the one above.

Show clef
Whether the staff clef will be shown.

Show time signature
Whether the staff time signature(s) will be shown or not.

Show barlines
Whether the staff barlines will be shown.

Advanced style properties

Clicking the Advanced Style Properties... button will open up a new set of advanced options. For a
standard staff, it looks like this:
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For a percussion staff it looks like this:

And for a tablature staff it looks like this
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and this:
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There are also some buttons:

Template

Displays the list of all the staff templates available in the score and which can be applied to the
current staff.

< Reset to Template

Resets all the staff properties to the properties of the selected template.

Add to Templates

Adds the current property set to the score as a new template (not yet implemented).

OK

Closes the dialog box, accepting the changes.

Cancel

Closes the dialog box, rejecting the changes.

Standard and Percussion staff specific items
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Show key signature
Whether the staff key signature will be shown.

Show ledger lines
Whether the staff ledger lines will be shown.

Stemless
If checked, staff notes will have no stem, hook or beam.

Tablature staff specific items

Upside down
If not checked, the top tablature line will refer to the highest string and the bottom tablature line
will refer to the lowest string (most common case). If checked, the top tablature line will refer to
the lowest string and the bottom tablature line will refer to the highest line (used in Italian style
lute tablatures).

Fret marks

This group of properties defines the appearance of fret marks.

Font
The font used to draw the marks. Currently 4 fonts are provided supporting all the necessary
symbols in 4 different styles (modern serif, modern sans, Renaissance, Late Renaissance).
More fonts (or the possibility to use custom fonts) may be available in the future.

Size
The font size to use, in typographic points. Built-in fonts look usually good at a size of 9-10pt.

Vertical offset
MuseScore tries to place symbols in a sensible way and this value is usually not needed (set to
0) for built-in fonts. If the font has symbols not aligned on the base line (or in some other way
MuseScore does not expect), this value allows to move mark symbols up (negative offsets) or
down (positive offsets) for better vertical positioning. Values are in sp.

Numbers / Letters
Whether to use numbers (‘1’, ‘2’...) or letters (‘a’, ‘b’...) as fret marks. When letters are used, ‘j’ is
skipped and ‘k’ is used for the 9th fret.

On lines / Above lines
Whether marks should be placed on the string lines or above them.

Continuous / Broken

Whether string lines should pass ‘through’ fret marks or should stop at them.
Example of numbers on broken lines:

Example of letters above continuous lines:

Example of 'upside down' tablature (same contents as number example above):
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Note values

This group of properties defines the appearance of the symbols indicating note values.

Font
The font used to draw the value symbols. Currently 3 fonts are provided supporting all the
necessary symbols in 3 different styles (modern, Italian tablature, French tablature). More fonts
(or the possibility to use custom fonts) may be available in the future. Used only with the Note
symbols option.

Size
The font size to use, in typographic points. Built-in fonts look usually good at a size of 15pt.
Used only with the Note symbols option.

Vertical offset
As for Fret Marks above, but referring to value symbols instead. Used only with the Note
symbols option.

Shown as: None
No note value will be drawn (as in the examples above)

Shown as: Note symbols

Symbols in the shape of notes will be drawn above the staff. When this option is selected,
symbols are drawn only when the note value changes, without being repeated (by default) for a
sequence of notes all of the same value.
Example of values indicated by note symbols:

Shown as: Stems and beams

Note stems and beams (or hooks) will be drawn. Values are indicated for each note, using the
same typographic devices as for a regular staff; all commands of the standard Beam Palette can
be applied to these beams too.
Example of values indicated by note stems:

Repeat: Never / At new system / At new measure / Always
Whether and when to repeat the same note symbol, if several notes in sequence have the same
value (only available with the Note symbols option).

Beside staff / Through staff
Whether stems are drawn as fixed height lines above/below the staff or run through the staff to
reach the fret marks each refers to (only available with the Stems and Beams option).

Above / Below staff
Whether stems and beams are drawn above or below the staff (only available with the Stems
and Beams option / Beside staff sub-option).

None / As short stems / As slashed stems
To select three different styles to draw stems for half notes (only available with the Stems and
Beams option / Beside staff sub-option).

Show rests
Whether note symbols should be used to indicate also the rests; when used for rests, note
symbols are drawn at a slightly lower position. Used only with the Note symbols option.

Preview

Displays a short score in tablature format with all the current parameters applied.
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Tablature
Music for fretted, stringed instruments is commonly notated using tablature (Tab), which provides a
visual representation of the strings and fret numbers:

Tablature can also be combined with traditional staff notation:

Creating a tablature staff

With the 'New Score' wizard

Select File → New or use the shortcut Ctrl + N (Mac: Cmd+N) to open the New Score wizard. At the
Chose Instruments step, select one (or more) of the tablature options under "Plucked strings" in the
left column and press Add.

Use the dropdown list above the Instrument list to change the category displayed. Alternately you can
search for the instrument using the "Search" field below the Instrument list.

If the desired instrument/tablature combination is not available in the Instrument list:

1. Select an existing "Plucked strings" tablature staff
2. Press Add to move it to the right-hand column
3. Check the drop-down menu to the right of the newly-added instrument for the most suitable Tab

option, if any
4. Complete the rest of the New Score wizard and exit.
5. Modify the number of strings and tuning of the tablature, if needed, in the Staff properties

window (see Changing instrument string data).
6. Change Instrument and Instrument name in "Staff properties," if required (see Change

instrument).

This allows you to create tablature for any chromatically-fretted instrument.

Note: To create paired staff/tablature see Combining pitched staff with tab staff.

By changing staff type

To convert an existing standard staff to tablature, or tablature to a standard staff:

1. Right click on the staff and select Staff Properties…
2. If the Instrument displayed is not in the "Plucked strings" category then press Change instrument

and select an appropriate instrument from "Plucked strings" that supports tablature. If the staff is
already set up as a plucked string instrument then go to step 4.

3. Click on OK, exit the "Staff properties" box," then select "Staff properties" again
4. Press the Advanced Style Properties button
5. In the Template box, select one of the templates in the drop-down list and press the Reset to

Template button.
6. Adjust the number of strings, as required, in the "Lines" box near the top of the window
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7. Press OK to close the Advanced Styles properties dialog box.
8. Press Edit string data to adjust string number and tuning. Click on OK to exit
9. Press OK to close the Staff Properties dialog box.

Changing instrument string data (tuning)

Tablatures 'notes' (or "fret marks") do not refer to pitches but to strings and fret positions. You will
need to set the tablature to the correct Instrument string tuning so that it plays back correctly and can
generate the correct pitch notation if required.

The plucked-string instruments available in the Instrument list (press Ctrl + I to view) are set to the
most commonly-used string tunings. You can view the tuning by right-clicking on a staff in the score,
selecting Staff Properties, and pressing Edit String Data.

You will need to adjust this if you are working in a non-standard string tuning (scordatura). And you
may also need to adjust string tuning if the desired Instrument is not in the current Instrument list and
you are having to adapt an existing staff.

It is a good idea to check the tuning of the Staff before starting to enter notation.

To view / edit the string tuning:

The following applies only to plucked string instrument staves (standard or tablature):

1. Right-click on an empty spot in a measure of a staff whose tuning you want to change

2. Select Staff Properties...

3. Press the Edit String Data... button at the bottom of the dialog box (this button is only shown
if the instrument has been defined as a stringed instrument). The "String Data" dialog box
opens: review the current string data and make any needed changes via the New String..., Edit
String..., Delete String buttons
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Notes: The check boxes in the Open column are used to mark individual strings as always open
(unfretted) – as in the lute.

If tuning is changed when the tablature for that instrument already contains some notes, fret
marks will be adjusted to produce the same notes with the new tuning (if possible).

The number of frets (either physical frets or 'virtual' positions) determines the maximum fret
number a string can receive.

Any change you make to the string tuning will only affect that particular instrument for that
particular score, and will not alter any program default or built-in definition.

4. Check the "Number of frets" is correct or adjust it (if not)

5. Press OK to close the "Edit String Data" dialog box
6. In the case of a tablature staff, press Advanced style properties and check that "Lines" equals

the number of strings. Adjust as necessary. Click on OK
7. Press OK to close the "Staff/Part Edit Properties" dialog box

Configuring tablature

The default properties of tablature are those of a guitar in standard tuning (E2, A2, D3, G3, B3, E4).
For other fretted instruments, change the number and tuning of the strings as required.

Tablature properties, as well as those of other types of staves, can be accessed and adjusted in the
staff properties dialog.

Combining pitched staff with tab staff

With certain instruments – e.g. the guitar and other stringed instruments – it is common to show both a
pitched staff and a tablature (TAB) staff. The pitched staff displays conventional music notation while
the associated tablature shows the strings and fret numbers corresponding to the notes.

There are two ways to do this:

Create a linked staff/TAB pair

MuseScore allows you to "link" staves so that changes in one staff are also applied to the linked one
(mutual translation). You may use either staff for note input.

1. Open the instrument editor (menu Edit → Instruments... or I key)
2. Select the staff you want to link to
3. Press the Add linked Staff button to create a new staff linked to the selected one
4. Press OK

Once the new linked staff is created, you will usually want to change its type (e.g. to tablature) and/or
change its type properties, as described above.
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If chords are entered in the pitched staff (or copied from another staff with Ctrl+C / Ctrl+V), in the
tablature MuseScore tries to distribute the note across the strings to avoid fretting conflicts (multiple
notes on the same string); if this is not possible, conflicting notes are drawn in the tablature with a red
background and have to be adjusted by hand (see below Editing Notes).

Create a non-linked staff/TAB pair

If you want to associate a pitched staff with a TAB staff, but without mutual translation of notes:

1. Open the instrument editor (menu Edit → Instruments... or I key)
2. Select the staff you want to link to
3. Press the Add Staff button to create a new staff associated with the selected one.
4. Press OK

Another option is to create an unlinked Tab line as a separate instrument from the pitched staff:

1. Open the instrument editor (menu Edit → Instruments... or I key)
2. Select a tablature option from the left column.
3. Press the Add button.
4. Press OK

You can enter notes into either of the staffs without affecting the notes in the other, using selection
then copy and paste to transfer music between staffs.

Inputting new notes

Keyboard:

Switch to note input mode (N): a short 'blue rectangle' appears around one tablature string: this is
the current string
Select note/rest duration (see below)
Press ↑ or ↓ to select the needed string
Press 0 to 9 to enter a fret mark from 0 to 9 on the current string; to enter numbers with several
digits press each digit in sequence (the program will anyway refuse to enter a number higher
than the maximum fret defined for the instrument). Keys A to L (skipping I) can also be used,
which is convenient when working on a French tablature
It is also possible to correct the fret number with Shift+↑ or Shift+↓

Mouse:

Enter note input mode and select the note duration (see below)
Click on a string to create a note there
Notes are initially created on fret 0 (or a for French tablatures): press Shift+↑ several times until
the right fret is reached

MuseScore refuses to place a second note on a string which already contains one; for this reason, it is
usually better to fill chords from the highest string to the lowest.

Selecting the note value to enter
While in TAB entry mode, the default shortcuts for selecting note values (0 to 9) are re-used to enter
fret numbers. To select the value for the next entered notes, four different methods can be used:

Shift+1 to Shift+9 (availability of these shortcuts may depend on platforms and/or keyboard
layout)
NumPad 1 to Numpad 9 (if a numeric keypad exists and NumLock is on)
the input tool bar at the top of the screen
Q to decrease the selected value and W to increase it

Editing existing notes

While NOT in entry mode, three key combinations can be used to change a fret mark:

Shift+↑ / ↓ changes the note pitch. MuseScore selects the string and the fret: always the highest
possible string is selected.
↑ / ↓ changes the fret up/down without changing the string (ranging from 0 to the number of frets
defined in the "Edit String Data" dialog box).
Ctrl+↑ / ↓ moves the selected note to upper/lower string (if the string is free and can produce
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that note).
Shift+X toggles the ghost note head on/off.

Summary of keys

Note input mode

Type: to get:
↑ Select above string as current.
↓ Select below string as current.
Shift+1 to Shift+9 Select a duration
NumPad 1 to NumPad
9

Select a duration

Q Decrease current input duration.
W Increase current input duration.
0 to 9 Enter a fret digit / letter.

A to K Enter a fret digit / letter (I
excluded).

Shift+↑ Increase current fret mark.
Shift+↓ Decrease current fret mark.

Normal mode

Type: to get:
Shift+↑ Increase the pitch of the selected note (MuseScore chooses the string).
↑ Increase the pitch without changing string.

Shift+↓ Decrease the pitch of the selected note (MuseScore chooses the
string).

↓ Decrease the pitch without changing string.
Ctrl+↑ Move note to above string, keeping the pitch.
Ctrl+↓ Move note to below string, keeping the pitch.
Shift+X Toggle the ghost note head on/off.

External links

Video tutorial: MuseScore in Minutes: Lesson 7 - Tablature and Drum Notation

Tools
Some tools have been developed. They are found in Edit → Tools

Add / Remove line breaks

This tool automatically adds or deletes line breaks:

Add line breaks
every X measures
explicitly at the end of each current system

Remove
all current line breaks

This command operates on a selection of measures, or if no measures are selected then on the entire
score.

Optionally select the measures to apply this to
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Edit → Tools → Add/Remove Line Breaks...

Press OK.

Explode / Implode

These commands allow you to explode the contents of a staff containing a series of chords into
individual melodic lines on subsequent staves, or to implode staves containing individual melodic lines
into a series of chords on a single staff.

Explode

Select a range. Its topmost (or only) staff, referred to here as the "source staff", should contain chords
with multiple notes. Run Edit → Tools → Explode. The top note of each chord in the source staff will
remain where it is, and the under voices will be placed ("exploded") into subsequent staves below the
source staff, one note per staff.

If your selection occupies a single staff only, MuseScore will use as many destination staves as it
needs to accommodate the largest chord. For example, if the largest chord has four notes, the
explosion uses four staves: the source staff plus the three staves below it.

However, if your selection includes multiple staves, then the selection itself is considered to be the
destination region, and its topmost staff is considered to be the source staff. MuseScore will discard
the lowest note(s) of any chord that contains more notes than the number of staves in the selection.

In either case, if a given chord has fewer notes than the number of destination staves, then notes will
be duplicated as needed so that every staff receives a note.

Note: beware that if your selected range includes partial measures, it will be silently enlarged to the
nearest whole measure in each direction. It is not currently possible to explode a partial measure.

Implode

Select a range of measures across staves that have substantially similar rhythms, run Edit → Tools →
Implode. MuseScore will combine the contents of the staves into chords on the top staff - the opposite
of explode. There is a special case if you select only a single staff - MuseScore will do essentially the
same thing but combine the contents of multiples voices on that staff into chords in voice 1.

Fill with slashes

This command fills the selection with slashes, one per beat. For normal (empty) measures, the
slashes are added in voice 1.

If there are already notes in a measure in the selection, the command will put the slashes into the first
empty voice it finds. If a measure contains notes in all 4 voices, voice 1 will be filled with slashes, over-
writing any existing notes. In voices 1 and 2 the slashes will be centered on the middle line of the staff,
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in voices 3 and 4 they appear small and above or below the staff. All slashes are set to not transpose
or playback.

Toggle rhythmic slash notation

This command toggles selected notes between normal notes and rhythmic slash notation: notes with
slash heads, set to not transpose or playback. For notes in voices one or two, the notes are fixed to
the middle staff line.

For notes in voices three or four, the notes are fixed above or below the staff and are also marked
small (also known as "accent" notation). You may find it helpful to use the selection filter to exclude
voices one and two from your selection before running this command, so only the notes in voices
three and four are affected.

In percussion staves, the notes in voices 3 and 4 are not converted to small slashes but to small
notes above or below the staff.

Resequence rehearsal marks

This command resequences rehearsal marks in the selection range:

1. Add rehearsal marks
2. Select a range
3. Edit → Tools → Resequence Rehearsal Marks

MuseScore automatically detects the sequence based on the first rehearsal mark in the selection - all
rehearsal marks in the selection are then altered accordingly.

The sequence can be:

a, b, c,
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A, B, C,
numerically simple sequence - 1, 2, 3,
numerically corresponding to measure numbers

See also

Rehearsal marks
Plugins

Workspace
Workspaces are sets of palettes.
You can create your own or just flip between Advanced and Basic in the menu: Edit → Workspace or
at the end of the palette you have a pop-up menu to switch between workspaces.

Create a new workspace

1. Edit → Workspace → New.... (or use the + button at the bottom of the Palettes)

2. Name it

Note: The new workspace will be based on the workspace you were using when clicking +, or Create
a new Workspace.

Edit a workspace

1. Right-click on a palette name

2. Enable Editing (for that palette)

3. Click on a cell of the palette (after having developed it) to do anything of the following:

clear it
see cell properties
show more elements (if box is ticked in Palette Properties)

Other possibilities to modify a workspace include:

organize palette order by moving it up, or down via the right-click menu (see above)
save, or load a palette
insert, or delete a palette
see palette properties (here you can tick the "Show 'More Elements...'" box)
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See also

Custom palette

New features in MuseScore 2
For an overview of the new features, see What's New in MuseScore 2, Release notes for MuseScore
2.0, Release notes for MuseScore 2.0.1, MuseScore 2.0.2 Release Notes, MuseScore 2.0.2 is
released, and Changes in MuseScore 2.0.
Documentation of new features are available in the chapter they belong to logically (except the one
that is referring to upgrading from 1.x) , but for users coming from 1.x here's a collection of links to be
able to see at a glance what can be done now...

See also

Album (→Advanced topics)
View modes: Continuous view and Navigator (→Basics)
Copy and paste: Selection filter (→Basics)
Custom palette (→Advanced topics)
Early music features (→Advanced topics)
Figured bass (→Advanced topics)
Grid-based movement of symbols and staff text (→Text)
Image capture (→Formatting)
Inspector and object properties (→Advanced topics)
Measure operations: Split and join (→Basics)
MIDI import (→Sound and playback)
Mid-staff instrument change (→Sound and playback)
Part extraction (new options available) (→Advanced Topic)
Rehearsal marks: Automatic next rehearsal mark and Search for a rehearsal mark (→Text)
Save/Export (→Basics)
Staff type properties (→Advanced topics)
Swing (→Sound and playback)
Tablature (→Advanced topics)
Workspace (→Advanced topics)
Master palette (→Advanced topics)
Layout and formatting (some options have changed, and there is a new "apply to all parts"
feature) (→Formatting)
Break and spacer: Section break (→Formatting)
Selection modes: Select all similar new options (same subtype) (→Basics)
Create a new score: start center (→Basics)
Languages settings and translation updates (→Basics)
Helping and improve translation (→Support)
Accidentals: Respell pitches (→Notation)
Re-pitch mode (→Advanced topics)
Tools (→Advanced topics)
Score Information (→Advanced topics)

Upgrading from MuseScore 1.x

How to upgrade MuseScore

Download and install the latest version from the download page as described at Installation. If you
want to remove 1.x, check the installation page of the 1.x handbook.

Installing MuseScore 2 won't uninstall 1.x—both versions can coexist peacefully and can even be used
in parallel. So this isn't really an upgrade but an installation of a new and different program.

Opening 1.x scores in MuseScore 2

MuseScore 2 significantly improved the typesetting quality to make scores attractive and easier to
read. Improvements cover many items such as beam slope, stem height, layout of accidentals in
chords and general note spacing. However, this means that sheet music made with MuseScore 1.x
looks slightly different from sheet music made with 2.x.

It also means that scores saved with 2.x won't open with 1.x.
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To prevent you from accidentally overwrite your 1.x scores, 2.x treats them as an import, which
means:

the score gets marked as being modified, even if you haven't change anything
on exiting MuseScore you're asked to save the score (as a result from the above)
MuseScore uses the 'Save As" dialog to save it, not the "Save" dialog
MuseScore uses the score's title to create a default filename rather than taking the old filename

Local relayout

If you did not manually adjust the layout of a 1.x score, then MuseScore uses the 2.x typesetting
engine to layout the score. If you did touch the layout of the 1.x score, the individual adjustments you
may have made should remain after opening it in MuseScore 2.x, but due to slight changes in the
surrounding layout they may still not appear correct in context. If you wish to reset even manual
adjustments to use the 2.x typesetting engine throughout, select the complete score with the shortcut
Ctrl+A (Mac: Cmd+A) and reset the layout with Ctrl+R (Mac: Cmd+R).

Getting the sound from MuseScore 1.x

While the sound in 2.x has been much improved, you may still prefer the sound from MuseScore 1.x.
In that case, you can get the 1.x sound in 2.x by downloading the 1.3 SoundFont and add it in 2.x. You
can do this in two steps:

1. Download the 1.3 SoundFont named TimGM6mb
2. Install and use the TimGM6mb SoundFont in 2.0

Support
This chapter describes how to find help using MuseScore: the best places to look, the best way to ask
a question on the forums, and tips for reporting a bug.

Helping and improve translation
Do you have a translation to add? That can be done easily via the web, as mentioned in Development
/ Translating ...

Software translation

1. Ask in the forum to improve translation
2. Connect to Transifex/MuseScore http://translate.musescore.org, which will redirect you to

https://www.transifex.com/projects/p/musescore
3. Select the language and then the section you want to help with (musescore or instruments)
4. Click on the "translate" button (the button text will depend on your language...)
5. Search for "strings" (informational meaning) you want to translate (you could filter "already

translated items")

Here is a technical explanation: Continuous translation for MuseScore 2.0

Website and handbook translation

See Translation instructions

See also

Language Settings and Update Translation, Update Translation

How to ask for support or file reports
Before submitting your support request in the forum:

Look for a solution in the Handbook (search the Handbook)
Check the How Tos, FAQ and Tutorials
Search the forums of the website to see if someone has already encountered the same problem
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If posting in either the issue tracker (for established reports), or forum (for inquiries/discussions):

Try to reproduce the issue with the latest nightly. You may also view the older and new version
history to check whether it has been fixed/implemented already.

Please include as much of the following information as you know and limit each issue to one
report:

Version/revision of MuseScore you are using (e.g. version 2.0, revision 2902cf6). Check
Help → About... (Mac: MuseScore → About MuseScore...).
Operating system being used (e.g. Windows XP SP3, Mac OS 10.7.5 or Ubuntu 10.10)
If reporting a bug, describe the precise steps that lead to the problem (where do you click,
what keys do you press, what do you see, etc.).
If you are not able to reproduce the problem with the steps, it is probably not worth
reporting it as the developers will not be able to reproduce (and solve) it either. Remember
that the goal of a bug report is not only to show the problem, but to allow others to
reproduce it easily.
Remember to attach the score that shows the problem—use the "File attachments"
option at the bottom of the page, just above the Save and Preview buttons when you're
typing your post.

See also

How to write a good bug report: step-by-step instructions

Revert to factory settings
Recent versions of MuseScore have the option to revert back to the standard built-in presets or
"factory-settings". This can be helpful if your settings are corrupted. This is not a normal occurrence,
so it is best to consult the forums first, as there may be a way to solve your problem without resetting
everything.

Warning: Reverting to "factory settings" removes any changes you have made to the preferences,
palettes, or window settings.

Instructions for Windows

1. If you have MuseScore open, you need to close it first (File → Quit)
2. Type Windows key+R to open the Run dialog (The Windows key is the one with the logo for

Microsoft Windows). Alternatively select Start using your mouse.
3. Click Browse...
4. Look for MuseScore.exe on your computer. The location may vary depending on your

installation, but it is probably something similar to My Computer → Local Disk → Program Files
(or Program Files (x86)) → MuseScore2 → bin → MuseScore.exe

5. Click Open to leave the Browse dialog and return to the Run dialog. The following text (or
something similar) should display in the Run dialog

"C:\Program Files\MuseScore2\bin\MuseScore.exe"

For 64-bit Windows, the location is

"C:\Program Files (x86)\MuseScore2\bin\MuseScore.exe"

6. Click after the quote and add a space followed by a hyphen and a capital F: -F

7. Press OK

After a few seconds, MuseScore should start and all the settings reverted to "factory settings".

For advanced users, the main preference file is located at:

Windows Vista or later: C:\Users\<USERNAME>\AppData\Roaming\MuseScore\MuseScore2.ini
Windows XP or earlier: C:\Documents and Settings\USERNAME\Application
Data\MuseScore\MuseScore2.ini

The other preferences (palette, session...) are in:
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Windows Vista or later: C:\Users\<USERNAME>\AppData\Local\MuseScore\MuseScore2\
Windows XP or earlier: C:\Documents and Settings\USERNAME\Local Settings\Application
Data\MuseScore\MuseScore2\

Instructions for Mac OS X

1. If you have MuseScore open, you need to quit the application first (File → Quit)
2. Open Terminal (in Applications/Utilities) and a session window should appear

3. Type (or copy/paste) the following command into your terminal line (include the '/' at the front):

/Applications/MuseScore\ 2.app/Contents/MacOS/mscore -F

This resets all MuseScore preferences to factory settings and immediately launches the MuseScore
application. You can now quit Terminal, and continue using MuseScore.

For advanced users, the main MuseScore preference file is located at
~/Library/Preferences/org.musescore.MuseScore2.plist.

The other preferences (palette, session...) are in ~/Library/Application\
Support/MuseScore/MuseScore2/

Instructions for Linux (please adapt for flavors other than Ubuntu)

1. If you have MuseScore open, you need to quit the application first (File → Quit)
2. From the Ubuntu main menu, choose Applications → Accessories → Terminal. A Terminal

session window should appear

3. Type, (or just copy/paste) the following command into your terminal line:

mscore -F

This resets all MuseScore preferences to factory settings and immediately launches the MuseScore
application. You can now quit Terminal, and continue using MuseScore.

For advanced users, the main MuseScore preference file is located at
~/.config/MuseScore/MuseScore2.ini. The other preferences (palette, session...) are in
~/.local/share/data/MuseScore/MuseScore2/

See also

Command line options

Known incompatibilities

Hardware incompatibilities

The following software is known to crash MuseScore on startup:

Samson USB Microphone, driver name "Samson ASIO Driver", samsonasiodriver.dll. More info
Digidesign MME Refresh Service. More info
Windows XP SP3 + Realtek Azalia Audio Driver. More info
Wacom tablet. More info and QTBUG-6127

Software incompatibilities

Maple virtual cable is known to prevent MuseScore from closing properly.
KDE (Linux) window settings can cause the whole window to move when dragging a note.
Changing the window settings of the operating system avoids the problem.

AVG Internet Security hangs MuseScore

MuseScore requires access to your internet connection with AVG. MuseScore doesn't need an
internet connection to function, but if AVG blocks it, MuseScore hangs.
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If AVG prompts you, Allow MuseScore and check "Save my answer as a permanent rule and do not
ask me next time."

If it doesn't prompt you anymore,

1. Open the AVG user interface (right-click on the AVG icon, close to your clock -> Open AVG User
Interface

2. Click on Firewall
3. Click Advanced Settings
4. Click Applications
5. Find MSCORE.EXE in the list and double click it
6. Change Application Action to Allow for All

Font problem on Mac OS X

MuseScore is known to display notes as square when some fonts are damaged on Mac OS X.
To troubleshoot this issue:

1. Go to Applications -> Font Book
2. Select a font and press ⌘+A to select them all
3. Go to File -> Validate Fonts
4. If any font is reported as damaged or with minor problems, select it and delete it
5. Restart MuseScore if necessary

In this forum article, a user believes to have found the font "Adobe Jenson Pro (ajenson)" to be the
culprit, regardless of not being reported as broken, or problematic as per the above validation, and
solved the problem by deleting that font, so this is worth checking too.

Font problem on Linux

If the default desktop environment application font is set to bold, MuseScore will not display the notes
properly.
To troubleshoot this issue (gnome 2.*/MATE users):

1. Right-click on your desktop and select Change Desktop background
2. Click on Fonts tab
3. Set Regular style for Application font
4. Restart MuseScore if necessary

For GNOME 3/SHELL users

1. Open the shell and open "Advanced Settings"
2. Click on the Fonts option in the list
3. Set the default font to something non-bold
4. Restart MuseScore if necessary

Save As dialog empty on Linux

Some users reported that the Save As dialog is empty on Debian 6.0 and Lubuntu 10.10.
To troubleshoot this issue:

1. Type the following in a terminal

which mscore

2. The command will answer with the path of mscore. Edit it with your preferred text editor and add
the following line at the beginning

export QT_NO_GLIB=1

Launch MuseScore and the problem should be solved.

Appendix
Keyboard shortcuts
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Most keyboard shortcuts can be customized via Edit → Preferences... → Shortcuts tab (Mac:
MuseScore → Preferences... → Shortcuts tab). Below is a list of some of the initial shortcut settings.

Navigation

Beginning of score: Home
Last page of score: End
Find (measure number, rehearsal mark, or pXX when XX is a page number): Ctrl+F (Mac: ⌘+F)

Next score: Ctrl+Tab
Previous score: Shift+Ctrl+Tab

Zoom in: Ctrl++ (doesn't work on some systems) (Mac: ⌘l++) or Ctrl (Mac: ⌘) + scroll up
Zoom out: Ctrl+- (Mac: ⌘+-) or Ctrl (Mac: ⌘) + scroll down

Next page: Pg Dn or Shift + scroll down
Previous page: Pg Up or Shift + scroll up

Next measure: Ctrl+→ (Mac: ⌘+→)
Previous measure: Ctrl+← (Mac: ⌘+←)

Next note: →
Previous note: ←

Note below (within a chord or on lower staff): Alt+↓
Note above (within a chord or on higher staff): Alt+↑

Top note in chord: Ctrl+Alt+↑ (Ubuntu uses this shortcut for Workspaces instead)
Bottom note in chord: Ctrl+Alt+↓ (Ubuntu uses this shortcut for Workspaces instead)

Note input

Begin note input mode: N
Leave note input mode: N or Esc

Duration

1 ... 9 selects a duration. See also Note input.

Half duration of previous note: Q
Double duration of previous note: W

Voices

Voice 1: Ctrl+I Ctrl+1 (Mac ⌘+I ⌘+1)
Voice 2: Ctrl+I Ctrl+2 (Mac ⌘+I ⌘+2)
Voice 3: Ctrl+I Ctrl+3 (Mac ⌘+I ⌘+3)
Voice 4: Ctrl+I Ctrl+4 (Mac ⌘+I ⌘+4)

Pitch

Pitches can be entered by their letter name (A-G), or via MIDI keyboard. See Note input for full details.

Repeat previous note or chord: R (the repeat can be of a different note value by selecting duration
beforehand)

Repeat selection: R (The selection will be repeated from the first note position after the end of the
selection)

Raise pitch by octave: Ctrl+↑ (Mac: ⌘+↑)
Lower pitch by octave: Ctrl+↓ (Mac: ⌘+↓)

Raise pitch by semi-tone (prefer sharp): ↑
Lower pitch by semi-tone (prefer flat): ↓
Raise pitch diatonically: Alt+Shift+↑
Lower pitch diatonically: Alt+Shift+↓
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Circle through enharmonic notes: J

Rest: 0 (zero)

Interval

Add interval above current note: Alt+[Number]

Direction

Flip direction (stem, slur, tie, tuplet bracket, etc.): X
Mirror note head: Shift+X

Articulations

Staccato: Shift+S
Crescendo: <
Decrescendo: >

Text entry

Staff text: Ctrl+T (Mac:⌘+T)
System text: Ctrl+Shift+T (Mac: Ctrl+Shift+T)
Tempo text: Alt+T
Rehearsal Mark: Ctrl+M (Mac: ⌘+M)

Lyrics entry

Enter lyrics on a note: Ctrl+L (Mac: ⌘+L)
Previous lyric syllable: Shift+Space
Next lyric syllable: if the current and the next syllables are separated by a '-': -, else Space
Move lyric syllable left by 1sp: ←
Move lyric syllable right by 1sp: →
Move lyric syllable left by 0.1sp: Ctrl+← (Mac: ⌘+←)
Move lyric syllable right by 0.1sp: Ctrl+→ (Mac: ⌘+→)
Move lyric syllable left by 0.01sp: Alt+←
Move lyric syllable right by 0.01sp: Alt+→

Up to previous stanza: Ctrl+↑ (Mac: ⌘+↑)
Down to next stanza: Ctrl+↓ (Mac: ⌘+↓)

For more lyric shortcuts, see Lyrics.

Display

Navigator: F12 (Mac: fn+F12)
Play Panel: F11 (Mac: fn+F11)
Mixer: F10 (Mac: fn+F10)
Palette: F9 (Mac: fn+F9)
Inspector: F8 (Mac: fn+F8)
Piano Keyboard: P

See also

Preferences: Shortcuts

Known limitations of MuseScore 2.0
While all members of the development team did their best to make the software easy to use and bug-
free, there are some known issues and limitations in MuseScore 2.0.

Basics
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Save Selection

'Save Selection...' is currently pretty limited: If the selection doesn't contain a clef, time or key
signature, the saved score will be in treble clef, 4/4 time signature, and C major key signature,
although all pitches are kept, accidentals added as needed, and even irregular measures are kept.

Local Time Signatures

The local time signature feature, which allows you to have different time signatures in different staves
at the same time, is very limited. You can only add a local time signature to measures that are empty,
and only if there are no linked parts. When adding notes to measures with local time signatures, you
can enter notes normally via note input mode, but copy and paste does not work correctly and may
lead to corruption or even crashes. The join and split commands are disabled for measures with local
time signatures.

Note input

Tablature staff linked with Standard staff

With linked Standard and Tablature staves, if multiple note chords are entered in the Standard staff,
each chord should be entered from its top note to the bottom, otherwise the fretting automatically
assigned note by note in the Tablature staff may be unexpected (Note: This does not apply to a) note
input directly in the Tablature staff nor to b) note input in a Standard staff not linked to a Tablature: in
both cases entry order is indifferent).

Sound and playback

Instrument change

An instrument change does not change transposition, should any of the instruments involved require
that. If this is needed, it is necessary to use different staves and the 'Hide empty staves' option.
Actually there is no real instrument change, just a change of the sound on playback, so not only
transposition is not taken into account but also the instrument's range, and the part's name is left
unchanged.

Mixer

Changing values in the mixer does not mark the score 'dirty'. That means if you close a score you may
not get the warning "Save changes to the score before closing?". Changing mixer values are also not
undoable.

Layout

Header & Footer

There is no way to edit Header and Footer in a WYSIWYG manner. The fields in Style → General →
Header, Footer, Numbers are plain text. They can contain "HTML like" syntax, but the text style,
layout, etc. can't be edited with a WYSIWYG editor.

Command line options
You can launch MuseScore from the command line by typing

mscore [options] [filename] (Mac and Linux)
MuseScore.exe [options] [filename] (Windows)

[options] and [filename] are optional.

See also Revert to factory settings for detailed instructions on how and where to find and execute the
MuseScore executable from the command line on the various supported platforms.

The following options are available

-?, -h, --help
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Display help (doesn't work on Windows)
-v, --version

Displays MuseScore's current version in the command line without starting the graphical
interface (doesn't work on Windows)

--long-version
Displays MuseScore's current version and revision in the command line without starting the
graphical interface (doesn't work on Windows)

-d, --debug
Starts MuseScore in debug mode

-L, --layout-debug
Starts MuseScore in layout debug mode

-s, --no-synthesizer
Disables the integrated software synthesizer

-m, --no-midi
Disables MIDI input

-a, --use-audio <driver>
Use audio driver: jack, alsa, pulse, portaudio

-n, --new-score
Starts with the new score wizard regardless of preference setting for start mode

-I, --dump-midi-in
Displays all MIDI input on the console

-O, --dump-midi-out
Displays all MIDI output on the console

-o, --export-to <filename>
Exports the currently opened file to the specified <filename>. The file type depends on the
filename extension. This option switches to the "converter" mode and avoids any graphical
interface. You can also add a filename before the -o if you want to import and export files from
the command line. For example mscore -o "My Score.pdf" "My Score.mscz"

-r, --image-resolution <dpi>
Determines the output resolution for the output to "*.png" files in the converter mode. The default
resolution is 300 dpi.

-T, --trim-margin <margin>
Trims exported PNG and SVG images to remove surrounding whitespace around the score. The
specified number of pixels of whitespace will be added as a margin; use 0 for a tightly cropped
image. For SVG, this option works only with single-page scores.

-x, --gui-scaling <factor>
Scales the score display and other GUI elements by the specified factor, for use with high
resolution displays.

-S, --style <style>
Loads a style file; useful when you convert with the -o option

-p, --plugin <name>
Execute the named plugin

--template-mode
Save template mode, no page size

-F, --factory-settings
Use only the standard built-in presets or "factory-settings" and delete preferences. For details,
see Revert to factory settings

-R, --revert-settings
Use only the standard built-in presets or "factory-settings", but do not delete preferences

-i, --load-icons
Load icons from the file system. Useful if you want to edit the MuseScore icons and preview the
changes

-e, --experimental
Enable experimental features. See e.g. Layer (experimental)

-c, --config-folder <pathname>
Set config path

-t, --test-mode
Enable Test Mode

-M, --midi-operations <file>
Specify MIDI import operations file

-w, --no-webview
No web view in Start Center

-P, --export-score-parts
Used with -o .pdf, export score and parts

Qt Toolkit Options

-style= <style>
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-style <style>
Determines the style of the GUI application. Possible values are "motif", "windows" and
"platinum". Depending on the platform other styles may be available

-stylesheet= <stylesheet>
-stylesheet <stylesheet>

Sets the application stylesheet. The value of "stylesheet" is a path to a file that contains the
stylesheet

-platform <platformname[:options]>
Specifies the Qt Platform Abstraction (QPA) plugin.
Example: MuseScore.exe -platform windows:fontengine=freetype

See also

Revert to factory settings
Layer (experimental)

External links

http://doc.qt.io/qt-5/qapplication.html#QApplication
http://doc.qt.io/qt-5/qguiapplication.html#QGuiApplication

Glossary
The glossary is a work in progress, please help if you can. You can discuss about this page on
the documentation forum
The list below is a glossary of frequently used terms in MuseScore as well as their meaning.
The differences between American English and British English are marked with "(AE)" and "(BE)",
respectively.

Acciaccatura
A short →grace note.

Accidental
Accidentals appear in front of notes and shift their pitch.
Accidentals are used to alter the pitch of a note within a piece. The same symbols as in the
→key signature are used, but they are placed before a particular note. Accidentals are for
example →sharps, →flats and →naturals. Accidentals affect all notes on the same →staff
position only for the remainder of the measure in which they occur, but they can be canceled by
another accidental. In notes tied across a →barline, the accidental continues across the
→barline to the tied note, but not to later untied notes on the same →staff position in that
measure.

Anacrusis (BE)
See →Pickup Measure

Appoggiatura
A long →grace note.

Bar (BE)
See →Measure

Barline
Vertical line through a →staff or the →system that separates →measures.

Beam
Notes with a duration of an →eighth or shorter either carry a →flag or a beam. Beams are used
for grouping notes.

BPM
Beats Per Minute is the unit for measuring tempo. See →Metronome mark

Breve
Brevis

A double whole note or breve is a note that has the duration of two whole notes.
Chord

The minimal definition of a chord is a minimum of two different notes played together. Chords
are based on the choices made by a composer between harmonics of one, two or three (and
more) fundamental sounds. E.g. in the chord of C, G is the second harmonic, E the fourth of the
fundamental C. Now in C7, the B flat is the 6th harmonic of C and in C Maj7 B is the second
harmonic of E and the fourth harmonic of G...

Clef
Sign at the beginning of a →staff, used to tell which are the musical notes on the lines and
between the lines.
There are 2 F clefs, 4 C clefs and 2 G clefs: F third, F fourth, C first, C second, C third, C fourth,
G first, G second (known as treble clef too).
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G first and F fourth are equivalent.
Clefs are very useful for →transposition.

Concert Pitch
Enables you to switch between concert pitch and transposing pitch (see Concert pitch and
Transposition)

Crotchet (BE)
A crotchet is the British English term for what is called a quarter note in American English. It's a
quarter of the duration of a whole note (semibreve).

Demisemiquaver (BE)
Thirty-second note

Duplet
See →Tuplet

Eighth note
A note whose duration is an eighth of a whole note (semibreve). Same as British →quaver.

Endings
See →Volta

Enharmonic notes
Notes that sound the same pitch but are written differently. Example: G# and Ab are enharmonic
notes.

Flag
See →Beam

Flat
Sign that indicates that the pitch of a note has to be lowered one semitone.

Grace note
Grace notes appear as small notes in front of a normal-sized main note. A short grace note
(→acciaccatura) has a stroke through the stem; a long grace note (→appoggiatura) does not.

Half Note
A note whose duration is half of a whole note (semibreve). Same as British →minim.

Hemidemisemiquaver (BE)
Sixty-fourth note

Key Signature
Set of →sharps or →flats at the beginning of the →staves. It gives an idea about the tonality and
avoids repeating those signs all along the →staff.
A key signature with B flat means F major or D minor tonality.

Koron
An Iranian →accidental which means lower in pitch and it lowers a note by a quarter tone (in
comparison to the →flat which lowers a note by a semitone). It is possible to use this accidental
in a →key signature.
See also →Sori

Longa
A longa is a quadruple whole note.

Ledger Line
Line(s) that are added above or below the staff

Measure (AE)
A segment of time defined by a given number of beats. Dividing music into bars provides regular
reference points to pinpoint locations within a piece of music.

Metronome mark
Metronome marks are usually given by a note length equaling a certain playback speed in
→BPM. In MuseScore, metronome marks are used in tempo texts.

Minim (BE)
A minim is the British term for a half note. It has half the duration of a whole note
(→semibreve).

Natural
A natural is a sign that cancels a previous alteration on notes of the same pitch.

Operating System
OS

Set of programs written in the aim to set up a computer from a lot of electronic components.
Popular OSes are Microsoft Windows, Mac OS X, and GNU/Linux.
See also →System

Part
Music to be played or sung by one or a group of musicians. In a string quartet, 1st part = Violin
1, 2nd part = Violin 2, 3rd part = Viola, 4th part = Cello.

Pickup Measure (→Anacrusis)
Incomplete first measure of a piece or a section of a piece of music.
See also Create new score: Time Signature... and Measure operations: Exclude from measure
count

Quaver (BE)
The British quaver is what is called an →eighth note in American English. It has an eighth the
duration of a whole note.
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Quadruplet
See →Tuplet

Quarter note
A note whose duration is a quarter of a whole note (semibreve). Same as British →crotchet.

Quintuplet
See →Tuplet

Respell Pitches
Tries to guess the right accidentals for the whole score (see Accidentals)

Rest
Interval of silence of a specified duration.

Re-pitch Mode
A way in MuseScore to rewrite a passage with note changes but no rhythm change (see Re-
pitch Mode)

Semibreve (BE)
A semibreve is the British term for a whole note. It lasts a whole measure in 4/4 time.

Semiquaver (BE)
Sixteenth note

Semihemidemisemiquaver (Quasihemidemisemiquaver) (BE)
Hundred twenty-eighth note.

Sextuplet
See →Tuplet

Sharp
Sign that indicates that the pitch of a note has to be raised one semitone.

Slur
→Tie and Slur are two words used to describe a curved line between two or more notes. Slur
means that the notes will be played without attack (legato). Tie is used between two or more
notes on the same pitch to indicate its duration:
Quarter note + Tie + Quarter note = Half note,
Quarter note + Tie + Eighth note = Dotted Quarter note
Quarter note + Tie + Eighth note + Tie + 16th note = Double Dotted Quarter note

Sori
An Iranian →accidental which means higher in pitch and it raises a note by a quarter tone (in
comparison to the sharp which raises a note by a semitone). It is possible to use this accidental
in a →key signature.
See also →Koron

Spatium (plural: Spatia)
Space
Staff Space
sp (abbr./unit)

The distance between two lines of a normal 5-line staff. In MuseScore this unit influences most
size settings. See also Layout and Formatting, Layout / Page Settings

Staff (AE)
Stave (BE)

Group of one to five horizontal lines used to lay on musical signs. In ancient music notation
(before 11th century) the staff/stave may have any number of lines. (The plural of staff is
staves.)

System
System: Set of staves to be read simultaneously in a score.
See also →Operating System (OS)

Tie
See →Slur

Transposition
A tune can be played in any tonality. There are many reasons to change the tonality of a score:
1. The tune is too low or too high for a singer.
2. The score is written for a C instrument and has to be played by a B Flat one.
3. The score is written for an orchestra and you want to imagine what the horn, the flute and the
clarinet are playing.
4. A darker or a more brilliant sound is desired.
- In the first case all the orchestra will have to transpose, which is very difficult without
professional musicians. MuseScore can do it very easily for you.
- In the second case the musician must play D when a C is written. If the score is written with a
G 2nd Clef, he'll have to think that the staff begins with a C 3rd Clef.
- In the third case the conductor has to transpose all the staves which are not written for C
instruments.
- In all cases the key signature must be mentally changed.
- On some instruments (Horns and Tubas for instance) the musicians transpose using
alternative fingerings.

Triplet (BE)
See →Tuplet
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Tuplet
A tuplet divides its next higher note value by a number of notes other than given by the time
signature. For example a →triplet divides the next higher note value into three parts, rather than
two. Tuplets may be: →triplets, →duplets, →quintuplets, and other.

Velocity
The velocity property of a note controls how loudly the note is played. This usage of the term
comes from MIDI synthesizers. On a keyboard instrument, it is the speed with which a key is
pressed that controls its volume. The usual scale for velocity is 0 (silent) to 127 (maximum).

Voice
Polyphonic instruments like Keyboards, Violins, or Drums need to write notes of different
duration at the same time on the same →staff. To write such things each horizontal succession
of notes has to be written on the →staff independently.

Volta
In a repeated section of music, it is common for the last few measures of the section to differ.
Markings called voltas are used to indicate how the section is to be ended each time. These
markings are often referred to simply as →endings.

External links

http://www.robertcarney.net/musical-terms-definitions.htm
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